Bug 1214092 - [abrt] ibus-anthy-python: factory.py:55:__init__:NameError: global name 'sys' is not defined
Summary: [abrt] ibus-anthy-python: factory.py:55:__init__:NameError: global name 'sys'...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-anthy
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: fujiwara
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:410dd0c0b652c0dca397da4bcd2...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-21 23:23 UTC by kitmaxter
Modified: 2015-05-02 18:10 UTC (History)
4 users (show)

Fixed In Version: ibus-anthy-1.5.6-6.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-26 12:53:18 UTC


Attachments (Terms of Use)
File: backtrace (865 bytes, text/plain)
2015-04-21 23:23 UTC, kitmaxter
no flags Details
File: environ (752 bytes, text/plain)
2015-04-21 23:23 UTC, kitmaxter
no flags Details

Description kitmaxter 2015-04-21 23:23:38 UTC
Description of problem:
1. Ended Skype conversation
2. Quit Skype
3. ibus-daemon crashed (probably bug #1036332)
4. ibus-anthy-python crashed.

Version-Release number of selected component:
ibus-anthy-python-1.5.6-2.fc20

Additional info:
reporter:       libreport-2.2.3
cmdline:        python3 /usr/share/ibus-anthy/engine/main.py --ibus
executable:     /usr/share/ibus-anthy/engine/main.py
kernel:         3.18.7-100.fc20.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
factory.py:55:__init__:NameError: global name 'sys' is not defined

Traceback (most recent call last):
  File "/usr/share/ibus-anthy/engine/main.py", line 188, in <module>
    main()
  File "/usr/share/ibus-anthy/engine/main.py", line 185, in main
    launch_engine(exec_by_ibus)
  File "/usr/share/ibus-anthy/engine/main.py", line 81, in launch_engine
    IMApp(exec_by_ibus).run()
  File "/usr/share/ibus-anthy/engine/main.py", line 67, in __init__
    self.__factory = factory.EngineFactory(self.__bus)
  File "/usr/share/ibus-anthy/engine/factory.py", line 55, in __init__
    file=sys.stderr)
NameError: global name 'sys' is not defined

Local variables in innermost frame:
bus: <Bus object at 0x7f88909080a0 (IBusBus at 0x20292f0)>
self: <EngineFactory object at 0x7f88909080f0 (factory+EngineFactory at 0x2039410)>
__class__: <class 'factory.EngineFactory'>

Comment 1 kitmaxter 2015-04-21 23:23:41 UTC
Created attachment 1017175 [details]
File: backtrace

Comment 2 kitmaxter 2015-04-21 23:23:42 UTC
Created attachment 1017176 [details]
File: environ

Comment 3 fujiwara 2015-04-22 03:38:15 UTC
Thank you for the report.
However the root cause is that your ibus-config is terminated.
It would be good to restart ibus or reboot the system.

I will fix the bug itself soon but I cannot reproduce your problem.

Comment 4 Fedora Update System 2015-04-22 06:16:59 UTC
ibus-anthy-1.5.6-6.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/ibus-anthy-1.5.6-6.fc20

Comment 5 Fedora Update System 2015-04-22 06:18:08 UTC
ibus-anthy-1.5.6-6.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/ibus-anthy-1.5.6-6.fc21

Comment 6 Fedora Update System 2015-04-22 06:18:17 UTC
ibus-anthy-1.5.6-6.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/ibus-anthy-1.5.6-6.fc22

Comment 7 Fedora Update System 2015-04-23 16:05:22 UTC
Package ibus-anthy-1.5.6-6.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-anthy-1.5.6-6.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-6704/ibus-anthy-1.5.6-6.fc21
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2015-04-26 12:53:18 UTC
ibus-anthy-1.5.6-6.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2015-05-02 18:06:35 UTC
ibus-anthy-1.5.6-6.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2015-05-02 18:10:35 UTC
ibus-anthy-1.5.6-6.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.