Bug 121436 - ifup ignores space at the end of a wireless WEP key
ifup ignores space at the end of a wireless WEP key
Status: CLOSED DUPLICATE of bug 129930
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-21 11:34 EDT by Vladimir Mencl
Modified: 2014-03-16 22:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 17:14:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Mencl 2004-04-21 11:34:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040116

Description of problem:
When the wireless key contains a space at the end, ifup trims the key
string and ignores the space at the end.

When iwconfig is used directly, the space is correctly used.



Version-Release number of selected component (if applicable):
initscripts-7.42.2-1

How reproducible:
Always

Steps to Reproduce:
1. cat /etc/sysconfig/network-scripts/keys-eth1
KEY='s:s:ABCD '

2. ifup eth1

    

Actual Results:  iwconfig eth1 
outputs
Encryption key:733A-4142-4344-0000-0000-0000-00   Security mode:open


Expected Results:  Encryption key:733A-4142-4344-2000-0000-0000-00

can be achieved with

iwconfig eth1 key 's:s:ABCD '

Additional info:

Workaround possible: use the hex-key instead in the key-eth1 file.
Comment 1 Bill Nottingham 2005-09-30 17:14:53 EDT

*** This bug has been marked as a duplicate of 129930 ***

Note You need to log in before you can comment on or make changes to this bug.