Bug 129930 - $KEY Should Be Surrounded by Quotes
$KEY Should Be Surrounded by Quotes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
: 121436 (view as bug list)
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-14 13:04 EDT by Jim Peterson
Modified: 2014-03-16 22:47 EDT (History)
2 users (show)

See Also:
Fixed In Version: 7.62-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-19 00:36:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jim Peterson 2004-08-14 13:04:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4)
Gecko/20030624 Netscape/7.1 (ax)

Description of problem:
The $KEY variable, used to store the encryption key for WEP, can be a
passphrase (like mine is) through the use of the "s:" prefix, and
therefore can contain spaces (like mine does).  I suggest that the
following line:

    iwconfig $DEVICE key $KEY

be changed to:

    iwconfig $DEVICE key "$KEY"

to support such a situation, assuming this change has not already been
made.


Version-Release number of selected component (if applicable):
initscripts-7.53-1

How reproducible:
Always

Steps to Reproduce:
1. Configure a wireless network card using a WEP passphrase that
contains a space.
2. Try "ifup ath0" (or "ifup eth0", or whatever).
3. Note that the WEP key does not get initialized properly (e.g., with
"iwconfig")
    

Actual Results:  The WEP key was not set to the appropriate phrase

Expected Results:  The WEP key should have been set

Additional info:
Comment 1 Jim Peterson 2004-08-14 13:10:02 EDT
Oops.  I meant to mention that this was for the
/etc/sysconfig/network-scripts/ifup-wireless script.  I don't know of
any other occurences.
Comment 2 Bill Nottingham 2004-08-19 00:36:03 EDT
Added, will be in 7.62-1.
Comment 3 Bill Nottingham 2005-09-30 17:14:56 EDT
*** Bug 121436 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.