Bug 1214562 - Config error: Error parsing "installonly_limit = u'1'": Out of range integer value.
Config error: Error parsing "installonly_limit = u'1'": Out of range integer ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-23 01:42 EDT by Ralf Corsepius
Modified: 2016-04-13 03:22 EDT (History)
7 users (show)

See Also:
Fixed In Version: dnf-1.1.8-1.fc24 dnf-1.1.8-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-13 03:22:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2015-04-23 01:42:09 EDT
Description of problem:

Trying to investigate BZ#1214538, I tried to reduce the number of parallel d/l connections being used by dnf, by trying to set "installonly_limit=1" in /etc/dnf/dnf.conf

# cat /etc/dnf/dnf.conf
[main]
gpgcheck=1
installonly_limit=1
clean_requirements_on_remove=true

This resulted into this non-helpful error message from dnf update:
# dnf update
Config error: Error parsing "installonly_limit = u'1'": Out of range integer value.


Version-Release number of selected component (if applicable):
dnf-0.6.5-1.fc22.noarch

How reproducible:
Always

Additional info:
- I could not find any option in dnf which would reflect my intentions.
- IMO, either the decision to force dnf on users in F22 should be reverted or this bug be made a release blocker.
Comment 1 Parag Nemade 2015-04-23 02:01:12 EDT
It looks like value 1 is only giving this problem. I see in code https://github.com/rpm-software-management/dnf/blob/master/dnf/yum/config.py#L757 which says minimum value allowed is 2.
Comment 2 Ralf Corsepius 2015-04-23 02:32:42 EDT
(In reply to Parag from comment #1)
> It looks like value 1 is only giving this problem. I see in code
> https://github.com/rpm-software-management/dnf/blob/master/dnf/yum/config.
> py#L757 which says minimum value allowed is 2.

Thanks. However, I do not understand why 1 should not be allowed.
Comment 3 Radek Holy 2015-04-23 04:43:30 EDT
The "kernel" package is marked as "installonly" by default. DNF also protects you from removing the currently running kernel. In the end it means, that you're not able to (easily) install another kernel because you cannot remove the current one and by installing another one, you'd exceed the limit.

On the other hand, if the user removes kernel from the list of "installonly" packages, I don't see a reason why shouldn't we allow them to do what they want... This is just another protection measure inherited from YUM which may be moved into a plugin (like protected packages), if the reporter wants.

Anyway, we should at least:
- improve the message (e.g. by mentioning the allowed range)
- print a warning if the value is "risky"
- improve the documentation of the config option
Comment 4 Fedora Update System 2016-04-06 10:38:38 EDT
dnf-plugins-core-0.1.20-1.fc24 dnf-1.1.8-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-5dae5d2add
Comment 5 Fedora Update System 2016-04-07 06:02:06 EDT
dnf-1.1.8-1.fc23 dnf-plugins-core-0.1.20-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ddeabfcfe6
Comment 6 Fedora Update System 2016-04-07 12:54:18 EDT
dnf-1.1.8-1.fc24, dnf-plugins-core-0.1.20-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-5dae5d2add
Comment 7 Fedora Update System 2016-04-08 12:59:09 EDT
dnf-1.1.8-1.fc24, dnf-plugins-core-0.1.20-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2016-04-08 16:51:27 EDT
dnf-1.1.8-1.fc23, dnf-plugins-core-0.1.20-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ddeabfcfe6
Comment 9 Fedora Update System 2016-04-13 03:21:36 EDT
dnf-1.1.8-1.fc23, dnf-plugins-core-0.1.20-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.