Bug 121463 - Save Dual-Head Settings
Save Dual-Head Settings
Status: CLOSED DUPLICATE of bug 136916
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-21 16:02 EDT by Kyle Pinkley
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Config File as Requested (59.46 KB, text/plain)
2004-04-22 16:34 EDT, Kyle Pinkley
no flags Details

  None (edit)
Description Kyle Pinkley 2004-04-21 16:02:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
I select the Radeon 9800 XT Video Card and Viewsonic VA720 monitor
under Hardware and go to the Dual head tab.  When I enable Dual Head
and select a generic CRT Monitor (or Viewsonic) under Monitor Type and
Span Desktops under Desktop Layout, I am unable to hit OK to save the
configuration.   I receive this error:

Traceback (most recent call last):
  File "/usr/share/system-config-display/xConfigDialog.py", line 180,
in ok
    if card.getCardData()["NAME"] ==
self.secondVideocardOptionMenu.get_menu().get_active().get_data("NAME"):
AttributeError: 'NoneType' object has no attribute 'get_data'


Version-Release number of selected component (if applicable):
system-config-display-1.0.13-3

How reproducible:
Always

Steps to Reproduce:
1. Enable Dual Head
2. Select Generic CRT (or Viewsonic) under Monitor Type
3. Select Spam Desktops
4. Click OK
    

Additional info:

P4 2.8, 1GB RAM, Radeon 9800XT Video, Viewsonic LCD and CRT
Comment 1 Brent Fox 2004-04-22 16:30:42 EDT
Can you attach your /usr/share/system-config-display/display.glade?
Comment 2 Kyle Pinkley 2004-04-22 16:34:31 EDT
Created attachment 99639 [details]
Config File as Requested
Comment 3 Kyle Pinkley 2004-04-22 21:52:42 EDT
I'm not sure if this is normal either (or related), but upon selecting
the Video Card and clicking OK (without the Dual Head enabled) and it
makes the XF86config change and states to restart the X server, when I
reload X and run the system-config-display utility it shows the VESA
video card instead of the ATI Radeon 9800 XT that I selected.
Comment 4 Paul Nasrat 2004-08-12 04:41:09 EDT
Can you retest on Fedora Core 3 test 1 (system-config-display  1.0.17)
and see if you get the same exception.
Comment 5 John 2004-11-13 06:12:26 EST
I am actually having the same problem with Core3 (and also had it with
 Core2). 

Don't know whether this might help troubleshooting the issue:
[root@localhost ~]# system-config-display -v
[Startup]
Read configuration file /etc/X11/xorg.conf
Trying with card: ATI Radeon 9800 XT
[selecting dual head and choosing monitor]
in hydrate_second
[Click OK]
Traceback (most recent call last):
  File "/usr/share/system-config-display/xConfigDialog.py", line 208, in
ok
    primaryPCIBus = "PCI:%d:%d:%d" % (self.state.get_videocard_PCIBus(),
TypeError: int argument required
[Click OK again]
Traceback (most recent call last):
  File "/usr/share/system-config-display/xConfigDialog.py", line 155, in
ok
    lower_vrefresh, upper_vrefresh = self.second_monitor_vrefresh
ValueError: too many values to unpack

please let me know if there's anything else I can provide you with to
get this working.
Comment 6 Peter 2004-11-19 14:54:14 EST
uname -a
Linux bunny 2.6.9-1.678_FC3 #1 Mon Nov 15 18:28:07 EST 2004 i686
athlon i386 GNU/Linux

[ton@bunny ~]$ system-config-display
Proberen met kaart: NVIDIA GeForce 2 MX (generic)
in hydrate_second
Traceback (most recent call last):
  File "/usr/share/system-config-display/xConfigDialog.py", line 136,
in ok
    lower_vrefresh, upper_vrefresh =
string.split(str(self.second_monitor_vrefre sh), "-")
ValueError: unpack list of wrong size
Traceback (most recent call last):
  File "/usr/share/system-config-display/xConfigDialog.py", line 208,
in ok
    primaryPCIBus = "PCI:%d:%d:%d" % (self.state.get_videocard_PCIBus(),
TypeError: int argument required
Traceback (most recent call last):
  File "/usr/share/system-config-display/xConfigDialog.py", line 155,
in ok
    lower_vrefresh, upper_vrefresh = self.second_monitor_vrefresh
ValueError: too many values to unpack

and so and so on
Comment 7 Paul Nasrat 2004-11-23 07:59:05 EST
Can you test the system-config-display in updates-testing:

 system-config-display-1.0.24
Comment 8 Paul Nasrat 2004-11-23 10:04:36 EST

*** This bug has been marked as a duplicate of 136916 ***
Comment 9 Peter 2004-11-23 17:43:12 EST
looks like it is fixed. No more error messages when testing with
system-config-display-1.0.24-1 

thanks :)
Comment 10 Red Hat Bugzilla 2006-02-21 14:02:42 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.