Bug 136916 (DualHeadConfig) - If dual display is checked on OK button doesn't work
Summary: If dual display is checked on OK button doesn't work
Status: CLOSED CURRENTRELEASE
Alias: DualHeadConfig
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
Keywords:
: 121463 126318 136331 136919 138049 138640 138663 140237 140527 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-23 00:59 UTC by Hugh Caley
Modified: 2007-11-30 22:10 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-04 16:08:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Tentative patch (1.27 KB, patch)
2004-11-10 19:04 UTC, Marc Andre Morissette
no flags Details | Diff
/etc/X11/xorg.conf for attempted dual head see Comment #17 (3.43 KB, text/plain)
2004-11-23 04:29 UTC, P V
no flags Details

Description Hugh Caley 2004-10-23 00:59:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3)
Gecko/20040913 Firefox/0.10.1

Description of problem:
If I run system-config-display after installation and choose "Dual
Head" I cannot then hit OK to submit the change.  OK works if I don't
enable "Dual Head"

I have a Dell 1501FP monitor and a Matrox G550 display card.  The
second monitor is a Dell 1901FP.

Version-Release number of selected component (if applicable):
system-config-display-1.0.21-1

How reproducible:
Always

Steps to Reproduce:
1. run system-config-display
2. choose dual-head tab
3. Click on use dual head checkbox
4. click on OK
    

Actual Results:  Nothing

Expected Results:  OK should be accepted

Additional info:

[root@puglia hcaley]# system-config-display
Trying with card: Matrox Millennium G550
in hydrate_second
Traceback (most recent call last):
  File "/usr/share/system-config-display/xConfigDialog.py", line 196,
in ok
    primaryPCIBus = "PCI:%d:%d:%d" % (self.state.get_videocard_PCIBus(),
TypeError: int argument required
Traceback (most recent call last):
  File "/usr/share/system-config-display/xConfigDialog.py", line 143,
in ok
    lower_vrefresh, upper_vrefresh = self.second_monitor_vrefresh
ValueError: too many values to unpack
Traceback (most recent call last):
  File "/usr/share/system-config-display/xConfigDialog.py", line 143,
in ok
    lower_vrefresh, upper_vrefresh = self.second_monitor_vrefresh
ValueError: too many values to unpack

Comment 1 Bill Nottingham 2004-10-23 04:30:19 UTC
*** Bug 136919 has been marked as a duplicate of this bug. ***

Comment 2 Demond James 2004-10-24 13:51:54 UTC
I can confirm this with an ATI Rage 128 and also with S3 Virge Pci

$ rpm -q system-config-display
system-config-display-1.0.23-1


Comment 3 Tobias Bradtke 2004-10-27 14:41:09 UTC
I can confirm this with an "NVIDIA GeForce 2 MX (generic)".

# system-config-display
Versuche mit Karte: NVIDIA GeForce 2 MX (generic)
in hydrate_second
Traceback (most recent call last):
  File "/usr/share/system-config-display/xConfigDialog.py", line 208,
in ok
    primaryPCIBus = "PCI:%d:%d:%d" % (self.state.get_videocard_PCIBus(),
TypeError: int argument required
Traceback (most recent call last):
  File "/usr/share/system-config-display/xConfigDialog.py", line 155,
in ok
    lower_vrefresh, upper_vrefresh = self.second_monitor_vrefresh
ValueError: too many values to unpack

# rpm -q system-config-display
system-config-display-1.0.23-1

Comment 4 Paul Nasrat 2004-10-27 14:45:52 UTC
Just to let everyone know I'm away for a few days - I'll try to get a
test package out early next week.  Thanks.

Comment 5 Ben Konrath 2004-11-10 14:44:00 UTC
I'm experiencing the same problem with FC3 final and an ATI Radeon 9200.

% rpm -q system-config-display
system-config-display-1.0.23-1


Comment 6 Marc Andre Morissette 2004-11-10 19:03:36 UTC
I fixed it (I think). Here is a tentative patch.

By the way, it would be nice to be able to specify where the primary
is located relative to the secondary display (left or right).

Comment 7 Marc Andre Morissette 2004-11-10 19:04:45 UTC
Created attachment 106433 [details]
Tentative patch

Comment 8 Paul Nasrat 2004-11-11 18:26:36 UTC
Thanks for the patch, I'll do some testing tomorrow.  

Comment 9 Paul Nasrat 2004-11-11 18:27:34 UTC
*** Bug 138640 has been marked as a duplicate of this bug. ***

Comment 10 Ben Konrath 2004-11-11 21:42:20 UTC
I just applied the patch and it worked for me. 

Marc:

You might want to consider filing another bug for the feature you
requested.  



Comment 11 Paul Nasrat 2004-11-11 21:42:43 UTC
*** Bug 126318 has been marked as a duplicate of this bug. ***

Comment 12 Paul Nasrat 2004-11-11 21:46:15 UTC
*** Bug 138663 has been marked as a duplicate of this bug. ***

Comment 13 Paul Nasrat 2004-11-15 18:43:02 UTC
Can people please test system-config-display 1.0.24-1 in updates testing

Comment 14 Zack Cerza 2004-11-15 21:42:18 UTC
Fixed here.

Comment 15 Need Real Name 2004-11-16 00:23:28 UTC
works fine here but 

Hardware -> Monitor Type
and 
Dual Head -> Second monitor type

are listed as the same 

although Monitor0 and Monitor1 are different and listed (correctly) in
xorg.conf

Seems to have both listed as Monitor1

Comment 16 Frank Swasey 2004-11-18 21:30:35 UTC
the test version (1.0.24-1) fixed it for me just fine (ati radeon
7000, dual head with a dell 1901FP Digital and a 1900FP Digital).

Comment 17 P V 2004-11-19 06:12:31 UTC
Hi, OK button works now, but dual head still does not!

Video Cards: AGP "RIVA TNT2" & PCI "ATI Radeon 7200"
Monitors: "Dell D1626HT" & Sony 420GS
$ rpm -q system-config-display
system-config-display-1.0.24-1
$ uname -a
Linux localhost.localdomain 2.6.9-1.678_FC3 #1 Mon Nov 15 18:28:07 EST
2004 i686 athlon i386 GNU/Linux

Comment 18 Paul Nasrat 2004-11-22 15:50:18 UTC
Comment #17 - please can you attach the generated xorg.conf 

Comment 19 Paul Nasrat 2004-11-22 15:51:42 UTC
*** Bug 140237 has been marked as a duplicate of this bug. ***

Comment 20 P V 2004-11-23 04:29:02 UTC
Created attachment 107281 [details]
/etc/X11/xorg.conf for attempted dual head see Comment #17

Comment 21 Paul Nasrat 2004-11-23 13:08:46 UTC
*** Bug 136331 has been marked as a duplicate of this bug. ***

Comment 22 Paul Nasrat 2004-11-23 13:10:24 UTC
Comment #20 - can you file a new bug about your configuration -
attaching the xorg.conf and the Xorg.0.log and details about hardware.
 This is a seperate issue to this bug.

Comment 23 Paul Nasrat 2004-11-23 13:12:56 UTC
*** Bug 138049 has been marked as a duplicate of this bug. ***

Comment 24 Paul Nasrat 2004-11-23 14:00:20 UTC
*** Bug 140527 has been marked as a duplicate of this bug. ***

Comment 25 Need Real Name 2004-11-23 14:42:23 UTC
WFM

Comment 26 Paul Nasrat 2004-11-23 15:04:43 UTC
*** Bug 121463 has been marked as a duplicate of this bug. ***

Comment 27 Adam Croot 2004-12-03 19:50:47 UTC
im running a ati x800 pci-e 256mb with 2 x benq fp783 (1x dvi, 1xvga)
and the ok button doesnt work

i tried that fix but above but now im getting this 

[root@adam ~]# system-config-display
Trying with card: ATI Radeon X800XT
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 379, in ?
    import xConfigDialog
  File "/usr/share/system-config-display/xConfigDialog.py", line 207
    second_videocard.identifier = "Videocard1"
    ^
SyntaxError: invalid syntax

maybe im doing something wrong (i assumed i just need to edit
xConfigdDialog.py and then save it off) 

if i am could someone direct me in the way to do it properly ? 

bit of a n00b when it comes to using linux localy and the graphics
card config etc, i do most of my work via ssh 

thanks
adam 

Comment 28 Paul Nasrat 2004-12-05 23:34:42 UTC
Comment #27 - that is a different bug, can you open a new bug in
bugzilla against s-c-display please.

Comment 29 Paul Nasrat 2005-01-04 16:08:57 UTC
Closing as OK button works.  Work todo on improving dual head covered elsewhere.


Note You need to log in before you can comment on or make changes to this bug.