Bug 121486 - harddrive --partition=/dev/hda2 fails
Summary: harddrive --partition=/dev/hda2 fails
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 133260
TreeView+ depends on / blocked
 
Reported: 2004-04-22 02:56 UTC by Alexandre Oliva
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 14:55:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexandre Oliva 2004-04-22 02:56:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
Specifying /dev/<device name> fails, although if you end up choosing
the devices by hand, you're presented with a list in which device
names all start with /dev/.  It would be consistent for anaconda to
accept (and discard, if appropriate), the /dev/ prefix in device names.

I get the impression that anaconda also fails if --dir= starts with a
slash.  I had that as well as /dev/hda2 in my kickstart file but,
after that failed and I chose /dev/hda2 from the list presented to me
by anaconda, it still failed to mount.  Before realizing the slash
might be a problem, I changed the kickstart file to --partition=hda2,
and removed the slash from --dir as well, so I'm not sure about this
problem.  It could also be that it rejected a pathname such as
--dir=/foo/bar; after moving the isos from foo/bar to foo, and
changing the kickstart file to say --dir=foo, it worked.

Version-Release number of selected component (if applicable):
anaconda-9.92-8

How reproducible:
Always

Steps to Reproduce:
1.set up a kickstart file with harddrive --dir=/foo/bar
--partition=/dev/hda2

Actual Results:  It won't mount /dev/hda2, but rather fail ot mount
/dev//dev/hda2.

After selecting /dev/hda2 in the list of options, it will still fail
to find the isos.

Expected Results:  Ideally, same as --dir=foo/bar --partition=hda2

Additional info:

Comment 1 Jeremy Katz 2004-09-27 19:15:50 UTC
Fixed in CVS

Comment 2 Alexandre Oliva 2004-10-04 14:55:04 UTC
Confirmed, --partition=/dev/hda2 works in re1001.0, thanks!


Note You need to log in before you can comment on or make changes to this bug.