Bug 1215019 - Improve dependency view
Summary: Improve dependency view
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: Dependency Views
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: 5.0
Assignee: Jeff Fearn 🐞
QA Contact: tools-bugs
URL:
Whiteboard:
: 1173599 1179554 (view as bug list)
Depends On: 1298042
Blocks: 1164132 1173599 1179554 UI-Modernization
TreeView+ depends on / blocked
 
Reported: 2015-04-24 06:54 UTC by Jason McDonald
Modified: 2018-12-09 06:29 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-18 05:01:07 UTC


Attachments (Terms of Use)

Description Jason McDonald 2015-04-24 06:54:56 UTC
Feedback from several users suggests that the Dependency View should be improved, though few specific suggestions have been made.  This RFE has been raised to give users a place to submit and discuss suggestions.

Comment 1 David Cantrell 2015-05-01 18:51:07 UTC
I would like to see any of the following:

1) The big white space on a BZ page under the Blocks field and to the left of PM Score through Flags would be a nice place to put a dependency graph.

2) I would like the dependency graph to show the bug number, the component name, and the bug state.

3) For RHEL releases, everything that is acked for a release should block the main release bug.  That way we could see a dependency graph or tree for the entire release.  Everything should have a place in that tree.

4) We should have a needinfo? type flag or state specifically to nag owners of Depends On bugs that we are waiting on.  That sort of mail should be able to sort higher in priority that ordinary BZ mail.

5) A bug that moves to CLOSED and is in a dependency tree should notify Blocks components.  This has happened before in RHEL and the component Blocked by something that closes fails to notice that and ends up waiting around.

6) Similar to #5, if a bug in a dependency tree moves to a different RHEL release (via flag, not the version field), that should notify Depends On and Blocks components.

That's all I have for now.

Comment 2 Jeff Fearn 🐞 2015-06-04 01:00:25 UTC
devnote: assess https://github.com/bayoteers/TreeViewPlus

Comment 3 Jeff Fearn 🐞 2016-02-28 22:24:26 UTC
(In reply to David Cantrell from comment #1)
> I would like to see any of the following:
> 
> 1) The big white space on a BZ page under the Blocks field and to the left
> of PM Score through Flags would be a nice place to put a dependency graph.
> 
> 2) I would like the dependency graph to show the bug number, the component
> name, and the bug state.
> 
> 3) For RHEL releases, everything that is acked for a release should block
> the main release bug.  That way we could see a dependency graph or tree for
> the entire release.  Everything should have a place in that tree.
> 
> 4) We should have a needinfo? type flag or state specifically to nag owners
> of Depends On bugs that we are waiting on.  That sort of mail should be able
> to sort higher in priority that ordinary BZ mail.
> 
> 5) A bug that moves to CLOSED and is in a dependency tree should notify
> Blocks components.  This has happened before in RHEL and the component
> Blocked by something that closes fails to notice that and ends up waiting
> around.
> 
> 6) Similar to #5, if a bug in a dependency tree moves to a different RHEL
> release (via flag, not the version field), that should notify Depends On and
> Blocks components.
> 
> That's all I have for now.

Hi, we won't be adding work flow to the dependency viewer, that is what the rules engine is for.

We will be going with the default upstream TreeViewPlus and then getting feedback on it when it hits staging.

Comment 4 Jeff Fearn 🐞 2016-02-29 06:03:58 UTC
*** Bug 1173599 has been marked as a duplicate of this bug. ***

Comment 5 Jeff Fearn 🐞 2016-02-29 06:04:21 UTC
*** Bug 1179554 has been marked as a duplicate of this bug. ***

Comment 6 Hui Wang 2016-03-21 08:12:30 UTC
Verified this issue.
version 5.0.2.rh2
bz 5.0 is integrated with TreeView+, so change the status to Verified.
QE will file new bugs to track about the TreeView+ bugs.


Note You need to log in before you can comment on or make changes to this bug.