Bug 12155 - time of in textmode timezone selection
time of in textmode timezone selection
Status: CLOSED DUPLICATE of bug 6175
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-12 15:25 EDT by Hans de Goede
Modified: 2007-04-18 12:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:47:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2000-06-12 15:25:40 EDT
Hi,

When I'm in the textmode timezone selection the time displayed initially is
correct, after walking through the list and selecting the right timezone it
is of however, selecting and then deselecting HW clock set to GMT fixes
this.

I have the feeling this also is a problem in the graphical installer, since
I got messaages about /etc/modules.conf being newer then modules.dep there.
Comment 1 Pekka Savola 2000-06-22 11:50:39 EDT
this was fixed in beta2.
Comment 2 Hans de Goede 2000-07-27 15:42:11 EDT
Nice try, although the removing of showing the actual time in textmode (which I
thought was a nice feature) fooled me for a while. I though I should verify
this.

Installer generated files like:
/etc/localtime
/etc/passwd
/etc/group

etc.

Still have a time 2 hours later in my case, as the acutal time the installer was
run, so there is still something silly done with the time (my timezone is CET +
1, so it seems to try todo some sort of RTC in GMT time correction)

Comment 3 Hans de Goede 2000-07-27 15:42:59 EDT
This was with a graphical install btw.
Comment 4 Michael Fulbright 2000-08-17 17:24:03 EDT
The original bug said the problem was in the text mode installer - is that
problem resolved?

Is there also another problem in the graphical mode installer as well?
Comment 5 Hans de Goede 2000-08-19 06:46:57 EDT
Okay, the complete long story:

Originally I and a couple of others noticed that the neat current time according
to anaconda box in the textinstaller went a few hours of when you walked through
the list, iow it showed the wrong time after walking through the list to my
timezone.

This could be fixed by checking and then unchecking the rtc is in gmt box.

Later I and others noticed that modules.conf as created by anaconda had the same
wrong time as shown in the box in textmode anaconda.

Even later I found the same was true for a graphical anaconda. The most visible
effect of this was insmod complaining about modules.conf being newer then
modules.dep during the first boot, since depmod was run with the correct time
and the modules.conf was created with a time a few hours into the future.

This bug was closed and with that the display of the time according to anaconda
disappeared. So noone noticed anymore, now I did a graphical install some time
ago and noticed that all installer created files had a stimestamp sometime in
the future.

To reproduce:
-do a graphical
-install a default workstation
-choose western europa/amsterdam as timezone
-continue
-check the timestamps of /etc/passwd /etc/modules.conf and other installer
created/touched files, they will be a few hours into the future.

I guess you could also try this with a text based install to see if the problem
is there also.
Comment 6 David Balažic 2002-11-20 16:11:48 EST
Just to note that the bug about the time in future is still present in RHL 8.0
also see bug #60672
Comment 7 Michael Fulbright 2003-02-26 13:05:40 EST
We have no plans to include the current time in this screen.
Comment 8 Hans de Goede 2003-02-26 15:09:16 EST
Please read the bug before closing it !!

This bug no longer is about the time not being shown right (and hasn't been
about this for a long time). It is about the time not being right, causing
config files to be created with a time in the future, which in turn causes
warnings during boot (when the time is correct). Also see bug 60672

Comment 9 David Balažic 2003-02-27 04:26:38 EST
This issue is a duplicate of bug 6175. I also posted a patch there to correct 
the display of time in TUI timezone selection display ( your original complaint, 
Hans ), although nobody seems to be inrerested in it.
As I am not an owner of this bug, I wont mark it as a duplicate. Hans or Michael 
should do it.
Comment 10 Hans de Goede 2003-02-27 06:29:19 EST
David,

Thanks for the heads up, I should have seen 60672 was a duplicate of 6175 (I
thought it was a duplicate of this bug, silly me)

Closing as duplicate of 6175.


*** This bug has been marked as a duplicate of 6175 ***
Comment 11 Red Hat Bugzilla 2006-02-21 13:47:41 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.