Bug 1215896 - Typos in the messages logged by the CTR translator
Summary: Typos in the messages logged by the CTR translator
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Joseph Elwin Fernandes
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On:
Blocks: 1220100 1260923
TreeView+ depends on / blocked
 
Reported: 2015-04-28 05:53 UTC by Nithya Balachandran
Modified: 2016-06-20 00:01 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1220100 (view as bug list)
Environment:
Last Closed: 2016-06-16 12:56:44 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Nithya Balachandran 2015-04-28 05:53:25 UTC
Description of problem:

There are several typos and missing punctuation in the messages written to the brick logs by the changetimerecorder translator.

1.
[ctr-helper.c:249:extract_ctr_options] 0-gfdbdatastore: CTR Xlator is Disable!

should be 
[ctr-helper.c:249:extract_ctr_options] 0-gfdbdatastore: CTR Xlator is disabled. 


2.
0-patchy-changetimerecorder: Failed retriving sql-db-pagesize from paramsAssigning default value: 4096

Typo : retrieving. Though "Failed to retrieve" might be better.
Missing punctuation (period) before "Assigning"








Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
No typos. Exclamation marks in log messages are usually unnecessary.

Additional info:

Comment 1 Anand Avati 2015-05-08 11:10:10 UTC
REVIEW: http://review.gluster.org/10668 (CTR/Libgfdb: Log typo fix) posted (#1) for review on master by Joseph Fernandes (josferna@redhat.com)

Comment 2 Anand Avati 2015-05-08 13:15:23 UTC
REVIEW: http://review.gluster.org/10668 (CTR/Libgfdb: Log typo fix) posted (#2) for review on master by Joseph Fernandes (josferna@redhat.com)

Comment 3 Anand Avati 2015-05-10 05:00:21 UTC
REVIEW: http://review.gluster.org/10668 (CTR/Libgfdb: Log typo fix) posted (#3) for review on master by Vijay Bellur (vbellur@redhat.com)

Comment 4 Niels de Vos 2015-05-15 13:07:28 UTC
This change should not be in "ON_QA", the patch posted for this bug is only available in the master branch and not in a release yet. Moving back to MODIFIED until there is an beta release for the next GlusterFS version.

Comment 5 Nagaprasad Sathyanarayana 2015-10-25 14:54:32 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 6 Niels de Vos 2016-06-16 12:56:44 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.