Bug 121637 - XKB activation error when log in to GNOME
Summary: XKB activation error when log in to GNOME
Status: CLOSED DUPLICATE of bug 120858
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-24 10:35 UTC by Jones Lee
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:02:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jones Lee 2004-04-24 10:35:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
I updated all packages of X.org (23/4/2004), and I found a new bug
when I log in GNOME. There was a error dialog:
-----------------------------------------------------------------
Error activating XKB configuration.
Probably internal X server problems.

X server version data:
The X.org foundation
60700000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
------------------------------------------------------------------------

Here are extra info when I run 2 command as said in dialog:

[mojo@Vigor10 mojo]$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xfree86", "pc105", "us", "", ""


[mojo@Vigor10 mojo]$ gconftool-2 -R
/desktop/gnome/peripherals/keyboard/xkb
 layouts = [us]
 model = pc105
 overrideSettings = false
 options = []


If developer need more info, don't hesistate to contact me.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Log in GNOME
2. XKB error dialog show up
3.
    

Actual Results:  Nothing

Expected Results:  Error dialog

Additional info:

Comment 1 Jones Lee 2004-04-24 12:24:52 UTC
And go along with this bug is a series of bug related to X. I can't
log in to X when boot up, I have to run "setup" and let it detect the
X again then X boot up again. And now Mozilla does not work, Nautilus
crash often. I have to download Mozilla tarball and use it to submit
this addition comment.

Comment 2 Jones Lee 2004-04-24 12:26:34 UTC
Yes I found out that if firewall policy affect this. If disble
firewall and selinux, then X starts fine (though still get the XKB
error dialog). 

Comment 3 Jeremy Phillips 2004-04-24 19:45:22 UTC
This bug is already out there, bug # 117134.

Comment 4 Miloslav Trmac 2004-04-26 15:01:18 UTC

*** This bug has been marked as a duplicate of 120858 ***

Comment 5 Red Hat Bugzilla 2006-02-21 19:02:45 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.