Bug 12167 - XFree86 man files null
XFree86 man files null
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Preston Brown
:
: 12315 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-12 17:20 EDT by Gene Czarcinski
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-29 04:46:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2000-06-12 17:20:32 EDT
Most (all?) of the XFree86 4.0 unqiue man files are null (in effect
missing) -- e.g., /usr/X11R6/man/man1/XFree86.1x.gz and
/usr/X11/man/man5/XF86Config.5x.gz.

The missing information is critical to correctly configuring the
/etc/X11/XF86Config-4 file.  For example, only here is the DefaultDepth
option documented.

Other examples are the driver man files in /usr/X11R6/man/man4/.

Gene
Comment 1 Michael Redinger 2000-06-16 11:53:16 EDT
*** Bug 12315 has been marked as a duplicate of this bug. ***
Comment 2 Gene Czarcinski 2000-06-16 12:04:08 EDT
Since posting this bug, I have come to realize that this is probably NOT a
RedHat problem but is basic to the current (4.0) distribution of XFree86. 
Looking through the directory tree built by the SRPM for XFree86-4.0, the man
files are not obviously present.  This may be an indication that 4.0 is not
ready for prime time.

Gene
Comment 3 Bill Nottingham 2000-07-03 18:53:52 EDT
It's actually a problem with the preprocessor in the compiler. This
should be fixed in XFree86-4.0-0.30 and later builds.

Note You need to log in before you can comment on or make changes to this bug.