Bug 121671 - Rhythmbox does not play (.ogg) files; says "Could not pause playback"
Rhythmbox does not play (.ogg) files; says "Could not pause playback"
Status: CLOSED DUPLICATE of bug 119958
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-25 00:17 EDT by alaska subedi
Modified: 2013-03-13 00:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-15 11:44:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description alaska subedi 2004-04-25 00:17:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
Selecting a music file (.ogg) file to play in Rhythumbox gives an
error: "Could not pause playback".

Version-Release number of selected component (if applicable):
Rhythmbox 0.8.1

How reproducible:
Always

Steps to Reproduce:
1. Open Rhythmbox
2. Select a file
3. Hit play button
    

Actual Results:  A dialog box pops up with the message:
Could not pause playback


Expected Results:  It should have played the music

Additional info:

Gaim, and other games produce sound. The cdplayer does not produce any
sound.
Comment 1 François Kooman 2004-04-30 12:18:18 EDT
I'm having the same problem with Rhythmbox. I tried using ogg123, but
the files stop playing after a random play time.

ogg123: pcm.c:5896: snd_pcm_mmap_commit: Assertion `frames <=
snd_pcm_mmap_avail(pcm)' failed.
Aborted

Using ""ogg123 -d oss file.ogg"" works fine however. Maybe this is
related to the Rhythmbox error and there's some
alsa/gstreamer/intel8xx sound problem?
Comment 2 Harry Waye 2004-05-03 15:08:08 EDT
No message on box with snd_intel8x0 playing ogg in Rhythmbox.  Plays fine.

Do get "Could not pause playback" on box with snd_ens1371 playing ogg
and also when trying to play mp3 (although I haven't install
gstreamer-plugin-mp3 yet.)  Can play oggs fine in xmms.
Comment 3 Will Backman 2004-05-06 12:53:21 EDT
I get the same with rhythmbox-0.8.3-1
"Cannot pause playback."
driver: snd-ens1371
desc: "Ensoniq|5880 AudioPCI"
Comment 4 François Kooman 2004-05-19 07:15:15 EDT
Problem is still there in FC2 final (fresh install) on a Tosbiba
Satellite Pro 6100

lspci:
00:1f.5 Multimedia audio controller: Intel Corp. 82801CA/CAM AC'97
Audio Controller (rev 02)
        Subsystem: Toshiba America Info Systems: Unknown device 0001
        Flags: bus master, medium devsel, latency 0, IRQ 11
        I/O ports at 1400
        I/O ports at 1040 [size=64]

dmesg:
MC'97 1 converters and GPIO not ready (0xf200)
intel8x0_measure_ac97_clock: measured 65910 usecs
intel8x0: clocking to 48000

lsmod:
Module                  Size  Used by
snd_pcm_oss            40740  0
snd_mixer_oss          13824  3 snd_pcm_oss
snd_intel8x0           26280  6
snd_ac97_codec         50436  1 snd_intel8x0
snd_pcm                68872  3 snd_pcm_oss,snd_intel8x0
snd_timer              17156  1 snd_pcm
snd_page_alloc          7940  2 snd_intel8x0,snd_pcm
gameport                3328  1 snd_intel8x0
snd_mpu401_uart         4864  1 snd_intel8x0
snd_rawmidi            17184  1 snd_mpu401_uart
snd_seq_device          6152  1 snd_rawmidi
snd                    38372  16
snd_pcm_oss,snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore               6112  3 snd

More info required?
Comment 5 Colin Walters 2004-05-19 13:56:07 EDT
Ok.  Try this command:

gst-launch gnomevfssrc location=/path/to/file.ogg ! typefind ! spider
! audioconvert ! audioscale ! alsasink

That one should fail - can you verify that?

Next, try this:

gst-launch gnomevfssrc location=/path/to/file.ogg ! typefind ! spider
! audioconvert ! audioscale ! osssink


Comment 6 François Kooman 2004-05-19 16:52:57 EDT
[fkooman@flappie fkooman]$ gst-launch-0.8 -v --gst-debug-level=2
gnomevfssrc location=/home/fkooman/D12/D12\ World/06\ -\ My\ Band.ogg
! typefind ! spider ! audioconvert ! audioscale ! alsasink
RUNNING pipeline ...
/pipeline0/gnomevfssrc0.src: caps = application/octet-stream
/pipeline0/typefindelement0.sink: caps = application/octet-stream
WARN             alsa( 2732)
gstalsa.c(1202):gst_alsa_probe_hw_params:<alsasink0>
"snd_pcm_hw_params_set_period_size_near (this->handle, hw_params,
&period_size, 0)": Invalid argument
ERROR: pipeline doesn't want to play.
/pipeline0/typefindelement0.sink: caps = NULL
[fkooman@flappie fkooman]$

[fkooman@flappie fkooman]$ gst-launch-0.8  gnomevfssrc
location=/home/fkooman/D12/D12\ World/06\ -\ My\ Band.ogg ! typefind !
spider ! audioconvert ! audioscale ! osssink
RUNNING pipeline ...
Caught interrupt.
Execution ended after 1602 iterations (sum 1991884000 ns, average
1243373 ns, min 62000 ns, max 28351000 ns).
[fkooman@flappie fkooman]$

With osssink it plays the file :)
Comment 7 François Kooman 2004-05-27 07:04:32 EDT
Is there any progress with regard to this bug? It seems gstreamer
related. Is there anything I can do? For now it works with osssink,
but it would be nice to have alsasink working.
Comment 8 Sitsofe Wheeler 2004-05-27 10:17:42 EDT
This looks suspiciously like a dup of bug 119958 ... If I'm correct
then both the cause and a temporary workaround can be found there.
Comment 9 Colin Charles 2004-06-09 10:55:36 EDT
Same issues with Fedora Core 2 (this bug being opened during test3
time), as in comment 6. It works using ossink, but not alsasink.

If this is closed upstream like bug 119958, will we be getting a new
release of gstreamer soon? I can imagine this biting a lot of folk, as
Rhythmbox is becoming the new default audio playback tool.
Comment 10 John Thacker 2006-04-15 11:44:02 EDT
This bug is old, being for FC2, and should be fixed now, especially with all the
changes to gstreamer-0.10.  Closing as a dup of 119958 anyway.

*** This bug has been marked as a duplicate of 119958 ***

Note You need to log in before you can comment on or make changes to this bug.