Bug 119958 - rhythmbox always gives "Could not pause playback"
rhythmbox always gives "Could not pause playback"
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
:
: 119967 121671 122001 (view as bug list)
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-04-04 00:58 EST by Joshua Daniel Franklin
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-15 21:00:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Daniel Franklin 2004-04-04 00:58:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040312 Epiphany/1.1.12

Description of problem:
Rhythmbox opens correctly and looks good. I can add wav, ogg, and mp3
files to the browser. However, attempting to play any file results in
a Error dialog box with the message "Could not pause playback".

If rhythmbox is launched from the command line, it outputs the
following error to stderr:

Got error opening "file:///home/joshuadf/music/tmp/music.wav": Could
not pause playback


It is possible that this is a gstreamer problem, but I think that
unlikely since the following command plays the song as expected:

gst-launch -v filesrc location=sample.wav ! alsasink device="hw:0,0"


Version-Release number of selected component (if applicable):
rhythmbox-0.7.1-2 gstreamer-0.8.0-3

How reproducible:
Always

Steps to Reproduce:
1. Open rhythmbox
2. Add songs with Music | Import Folder... (for example, 
/usr/share/system-config-soundcard/ will get you the sound-sample.wav)
3. Attempt to play a song


Actual Results:  Error dialog box with the message "Could not pause
playback"

Expected Results:  Song should begin playing

Additional info:
Comment 1 Bill Nottingham 2004-04-06 12:49:52 EDT
*** Bug 119967 has been marked as a duplicate of this bug. ***
Comment 2 Colin Walters 2004-04-15 15:38:13 EDT
What does this command output?

gconftool-2 -g /system/gstreamer/0.8/default/audiosink
Comment 3 Toni Willberg 2004-04-15 16:10:04 EDT
I got the same error (bug 119967).
rhythmbox-0.7.2-1

$ gconftool-2 -g /system/gstreamer/0.8/default/audiosink
alsasink

Comment 4 Colin Walters 2004-04-15 18:03:03 EDT
How about after you run this command:

gconftool-2 -s /system/gstreamer/0.8/default/audiosink -t string
"alsasink device=hw:0"
Comment 5 Toni Willberg 2004-04-15 18:17:59 EDT
$ gconftool-2 -s /system/gstreamer/0.8/default/audiosink -t string
"alsasink device=hw:0"

$ gconftool-2 -g /system/gstreamer/0.8/default/audiosink
alsasink device=hw:0

And still the same error when trying to play music.

Btw, if it matters, I use esd with Xmms, and it works.
Not sure then what esd uses as backend...
Comment 6 Joshua Daniel Franklin 2004-04-15 20:31:00 EDT
Thanks, Rhythmbox now works for me after doing:

gconftool-2 -s /system/gstreamer/0.8/default/audiosink -t string
"alsasink device=hw:0"

I also had to un-mute my sound with alsamixer, but I guess that's a
separate bug. I tried XMMS and it also required me to set the ALSA
output plugin to hw:0 (Preferences->ALSA Output->Configure). 

This is, by the way, using the builtin sound on an ASUS A7N266-VM/AA,
nvidia nforce chipset, standard snd_intel8x0 driver. (I'm not using
the funky nforce surround-sound features.)
Comment 7 Colin Walters 2004-04-15 21:00:05 EDT
Ok.  This is a duplicate of ALSA bug 0000116.  You can view it by
going to:
https://bugtrack.alsa-project.org/alsa-bug/main_page.php
Then type 000116 into "jump" on the right, and login as guest.

If you can manage to make an account and talk to the developers via
that bug, I would appreciate it.  

I'll check in on the status periodically; feel free to ping this bug
if there's any resolution there, so I'll know to make sure an updated
version of alsalib gets into Fedora.
Comment 8 Joshua Daniel Franklin 2004-04-15 22:24:25 EDT
Thanks. You can also go there with this link:

https://bugtrack.alsa-project.org/alsa-bug/bug_view_advanced_page.php?bug_id=0000116

If you're not logged in click on "Guest"
Comment 9 Féliciano Matias 2004-04-21 14:46:35 EDT
Just a "me too".
gst and rhythmbox had never worked with FC2 here.
sound card : "Ensoniq ES1371" (snd_ens1371)
$ gconftool-2 -g /system/gstreamer/0.8/default/audiosink
alsasink device=hw:0


Other programs work fine (aplay, mplayer, ogg123, helixplayer, ...).
Comment 10 Féliciano Matias 2004-04-21 15:00:21 EDT
Find a workaround in bug #119982 comment #10 .
> gconftool-2 -s /system/gstreamer/0.8/default/audiosink -t string esdsink
Comment 11 Ilya Konstantinov 2004-04-23 15:34:46 EDT
This only happens to me if I use a dmix'ed device. Doesn't happen when
I use the real hw (hw:0) device.
Comment 12 Colin Walters 2004-07-07 14:28:46 EDT
*** Bug 122001 has been marked as a duplicate of this bug. ***
Comment 13 John Thacker 2006-04-15 11:44:15 EDT
*** Bug 121671 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.