Bug 1216960 - data tiering: do not allow tiering related volume set options on a regular volume
Summary: data tiering: do not allow tiering related volume set options on a regular vo...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: mainline
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: ---
Assignee: Mohammed Rafi KC
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On:
Blocks: 1229261 1230560 1260923
TreeView+ depends on / blocked
 
Reported: 2015-04-29 10:06 UTC by Nag Pavan Chilakam
Modified: 2016-06-16 12:56 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1229261 1230560 (view as bug list)
Environment:
Last Closed: 2016-06-16 12:56:44 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Nag Pavan Chilakam 2015-04-29 10:06:51 UTC
Description of problem:
======================
Currently user is able to set tiering volume set options even on a regular volume. This should be disallowed
Volume Name: regv1
Type: Distribute
Volume ID: bcbb83b1-5a54-4315-acd9-1d7830f0fa00
Status: Started
Number of Bricks: 1
Transport-type: tcp
Bricks:
Brick1: yarrow:/brick_100G_9/regv1
Options Reconfigured:
cluster.tier-demote-frequency: 120
cluster.tier-promote-frequency: 120
features.ctr-enabled: on


Version-Release number of selected component (if applicable):
==========================================================
[root@yarrow glusterfs]# gluster --version
glusterfs 3.7.0alpha0 built on Apr 28 2015 01:37:11
Repository revision: git://git.gluster.com/glusterfs.git
Copyright (c) 2006-2011 Gluster Inc. <http://www.gluster.com>
GlusterFS comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of GlusterFS under the terms of the GNU General Public License.
[root@yarrow glusterfs]# rpm -qa|grep gluster
glusterfs-fuse-3.7.0alpha0-0.17.gited96153.el7.centos.x86_64
glusterfs-libs-3.7.0alpha0-0.17.gited96153.el7.centos.x86_64
glusterfs-3.7.0alpha0-0.17.gited96153.el7.centos.x86_64
glusterfs-cli-3.7.0alpha0-0.17.gited96153.el7.centos.x86_64
glusterfs-server-3.7.0alpha0-0.17.gited96153.el7.centos.x86_64
glusterfs-api-3.7.0alpha0-0.17.gited96153.el7.centos.x86_64



Steps to Reproduce:
===================
1.create a regular volume like dist-rep or distribute volume 
2.set tiering related options like "features.ctr-enabled" to on
cluster.tier-demote-frequency to some value


these should be disallowed....as they are meant for tiered volume only

Comment 1 Anand Avati 2015-05-11 09:16:50 UTC
REVIEW: http://review.gluster.org/10751 (tier/volume set: Validate volume set option for tier) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 2 Anand Avati 2015-05-29 07:18:17 UTC
REVIEW: http://review.gluster.org/10751 (tier/volume set: Validate volume set option for tier) posted (#2) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 3 Anand Avati 2015-06-03 14:52:46 UTC
REVIEW: http://review.gluster.org/10751 (tier/volume set: Validate volume set option for tier) posted (#3) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 4 Nagaprasad Sathyanarayana 2015-10-25 14:56:22 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 5 Niels de Vos 2016-06-16 12:56:44 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.