Bug 1230560 - data tiering: do not allow tiering related volume set options on a regular volume
Summary: data tiering: do not allow tiering related volume set options on a regular vo...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: 3.7.1
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: ---
Assignee: Mohammed Rafi KC
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On: 1216960
Blocks: 1229261 1260923
TreeView+ depends on / blocked
 
Reported: 2015-06-11 07:21 UTC by Mohammed Rafi KC
Modified: 2015-10-30 17:32 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.7.2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1216960
Environment:
Last Closed: 2015-06-20 09:50:36 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Mohammed Rafi KC 2015-06-11 07:21:27 UTC
+++ This bug was initially created as a clone of Bug #1216960 +++

Description of problem:
======================
Currently user is able to set tiering volume set options even on a regular volume. This should be disallowed
Volume Name: regv1
Type: Distribute
Volume ID: bcbb83b1-5a54-4315-acd9-1d7830f0fa00
Status: Started
Number of Bricks: 1
Transport-type: tcp
Bricks:
Brick1: yarrow:/brick_100G_9/regv1
Options Reconfigured:
cluster.tier-demote-frequency: 120
cluster.tier-promote-frequency: 120
features.ctr-enabled: on


Version-Release number of selected component (if applicable):
==========================================================
[root@yarrow glusterfs]# gluster --version
glusterfs 3.7.0alpha0 built on Apr 28 2015 01:37:11
Repository revision: git://git.gluster.com/glusterfs.git
Copyright (c) 2006-2011 Gluster Inc. <http://www.gluster.com>
GlusterFS comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of GlusterFS under the terms of the GNU General Public License.
[root@yarrow glusterfs]# rpm -qa|grep gluster
glusterfs-fuse-3.7.0alpha0-0.17.gited96153.el7.centos.x86_64
glusterfs-libs-3.7.0alpha0-0.17.gited96153.el7.centos.x86_64
glusterfs-3.7.0alpha0-0.17.gited96153.el7.centos.x86_64
glusterfs-cli-3.7.0alpha0-0.17.gited96153.el7.centos.x86_64
glusterfs-server-3.7.0alpha0-0.17.gited96153.el7.centos.x86_64
glusterfs-api-3.7.0alpha0-0.17.gited96153.el7.centos.x86_64



Steps to Reproduce:
===================
1.create a regular volume like dist-rep or distribute volume 
2.set tiering related options like "features.ctr-enabled" to on
cluster.tier-demote-frequency to some value


these should be disallowed....as they are meant for tiered volume only

--- Additional comment from Anand Avati on 2015-05-11 05:16:50 EDT ---

REVIEW: http://review.gluster.org/10751 (tier/volume set: Validate volume set option for tier) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

--- Additional comment from Anand Avati on 2015-05-29 03:18:17 EDT ---

REVIEW: http://review.gluster.org/10751 (tier/volume set: Validate volume set option for tier) posted (#2) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

--- Additional comment from Anand Avati on 2015-06-03 10:52:46 EDT ---

REVIEW: http://review.gluster.org/10751 (tier/volume set: Validate volume set option for tier) posted (#3) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 1 Anand Avati 2015-06-17 05:13:29 UTC
COMMIT: http://review.gluster.org/11173 committed in release-3.7 by Atin Mukherjee (amukherj@redhat.com) 
------
commit a975c385c9cb0bb0b42993c2eb23a6f9bf277991
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Mon May 11 14:43:23 2015 +0530

    tier/volume set: Validate volume set option for tier
    
    Volume set option related to tier volume can only be set
    for tier volume, also currently all volume set i for tier
    option accepts a non-negative integer. This patch validate
    both condition.
    
    Back port of:
    >Change-Id: I3611af048ff4ab193544058cace8db205ea92336
    >BUG: 1216960
    >Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    >Signed-off-by: Dan Lambright <dlambrig@redhat.com>
    >Reviewed-on: http://review.gluster.org/10751
    >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    >Reviewed-by: Joseph Fernandes
    
    
    (cherry picked from commit f6a062044a3447bea5bf0fcf21a3f85c00fb6c7d)
    
    Change-Id: Ic6081f0ce7ae7effac69ba192bd35c8d382a11d5
    BUG: 1230560
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/11173
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Joseph Fernandes
    Tested-by: Joseph Fernandes

Comment 2 Niels de Vos 2015-06-20 09:50:36 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.2, please reopen this bug report.

glusterfs-3.7.2 has been announced on the Gluster Packaging mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/packaging/2015-June/000006.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.