Bug 121705 - mtr has no requirement for gtk+(-devel)
mtr has no requirement for gtk+(-devel)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mtr (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On: 124553
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-26 09:44 EDT by Robert Scheck
Modified: 2015-03-04 20:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-24 08:14:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2004-04-26 09:44:57 EDT
Description of problem:
There is no dependence from mtr-gtk to gtk+ and there is no 
build dependence from mtr to gtk+-devel and rebuilding without
gtk+(-devel) will die:

--- snipp ---
aclocal: configure.in: 87: macro `AM_PATH_GTK' not found in library
--- snapp ---

Version-Release number of selected component (if applicable):
mtr-0.54-5

How reproducible & Steps to Reproduce:
Everytime. Try to rebuild mtr at a system without gtk+devel or try 
to start mtr-gtk at a system without gtk+.
  
Actual results/Expected results:
A few dependencies...for my own use, I changed it as posted below.
I added gtk+-devel to the main package as build requirement, 
because aclocal will fail, if no GTK+ is present...

--- mtr.spec            2004-04-21 17:55:35.000000000 +0200
+++ mtr.spec.rsc        2004-04-26 15:48:12.000000000 +0200
@@ -13,7 +13,7 @@
 Patch1:        mtr-0.54-ipv6-kame.patch
 Patch2:        mtr-0.48-nogtk.patch
 Patch3:        mtr-0.52-SA_LEN.patch
-
+BuildRequires: gtk+-devel
 Buildroot: %{_tmppath}/%{name}-%{version}-root

 %description
@@ -26,7 +26,7 @@
 Summary: The GTK+ interface for mtr.
 Epoch: %{epoch}
 Group: Applications/Internet
-Requires: mtr, usermode >= 1.37
+Requires: mtr, usermode >= 1.37, gtk+

 %description gtk
 The mtr-gtk package provides the GTK+ interface for the mtr network
Comment 1 Phil Knirsch 2004-07-01 08:39:20 EDT
Fixed in latest mtr package to appear on Rawhide soon.

Read ya, Phil
Comment 2 John Thacker 2004-08-10 13:39:15 EDT
Hmm.  I'm looking at the new mtr-0.54-7 package in Rawhide and it
looks to me like the fix is wrong.  You didn't really need to add the
Requires: gtk+, since rpmbuild picks that up anyway and sets a
requirement for libgtk-1.2.so.0 and libgdk-1.2.so.0

More importantly, though, the BuildRequires: gtk+-devel line doesn't
seem to have been added in the 0.54-7 package in Rawhide.  It needs
that added, since it won't build without gtk+-devel.
Comment 3 Robert Scheck 2004-08-10 13:46:37 EDT
John, you're right, I think...I didn't check the new package yet. The
first part of my suggested change is missing. And the second one isn't
really relevant but it doesn't hurt anyone ;-)

There should be a "BuildRequires: gtk+-devel" in the main page, 
reopening.
Comment 4 Warren Togami 2004-08-24 08:14:41 EDT
Fixed this and more spec cleanup, should be in rawhide soon.

Note You need to log in before you can comment on or make changes to this bug.