This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 121717 - can't change screen resolution / HorizSync/VertRefresh not uncommented in xorg.conf
can't change screen resolution / HorizSync/VertRefresh not uncommented in xor...
Status: CLOSED DUPLICATE of bug 120950
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-26 15:02 EDT by Captain
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot showing the double frame resulting from the bug (19.10 KB, image/jpeg)
2004-04-26 21:13 EDT, Tino Meinen
no flags Details

  None (edit)
Description Captain 2004-04-26 15:02:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b)
Gecko/20040316

Description of problem:
I installed FC2test3, rebooted and X config came up. I selected
1024x768, but GNOME came up with 800x600.
system-config-display only showed 800x600 and 640x480.
No chance to get it working with 1024x768 (even selected a default
monitor [1024x768] and edited xorg.conf - added "1024x768" for the
default depth)

Graphics card: ATI Mach64VT
Monitor: Siemens Nixdorf MCM 1702

# system-config-display
* ddcprobe returned bogus values:
ID: SNIcc0b
Name: SNIcc0b
HorizSync: None
VertSync: None

Trying with card: ATI Mach64VT (264VT)

# kudzu --probe --bus=DDC
-
class: VIDEO
bus: DDC
detached: 0
driver: unknown
desc: "ATI Technologies Inc. MACH64VT"
mem: 2048
-
class: MONITOR
bus: DDC
detached: 0
driver: unknown
desc: "(null)"
id: SNIcc0b
mode: 800x600
mode: 1024x768
mode: 1152x864
mode: 640x480
mode: 800x600
mode: 1024x768


Version-Release number of selected component (if applicable):
system-config-display-1.0.13-3

How reproducible:
Always

Steps to Reproduce:
1. install FC2test3
2. select 1024x768 in the X configuration
3. graphical login, KDE and GNOME comes up in 800x600
    

Actual Results:  Couldn't change the screen resolution to 1024x768

It is reproducable no matter how often I run system-config-display,
but I haven't tried another install...

Expected Results:  system-config-display should have at least the
option 1024x768 which I chose during the X configuration

Additional info:

I solved the problem by editing xorg.conf again and uncommenting the
lines for HorizSync and VertRefresh.

I believe it is a bug in system-config-display, since xorg.conf is
created by it.
Comment 1 Forrest 2004-04-26 15:11:57 EDT
I have the same problem.  I had to manually uncomment the H&Vsync
options because my machines are on a KVM switch.  The DDC probe
doesn't work, so I have to manually specify the monitor.

This would be a Bad Thing if this is going to be the default.  Most
people at our company use KVM switch boxes, and I don't really want to
have to manually change the conf file on each installation.
Comment 2 Tino Meinen 2004-04-26 21:13:11 EDT
Created attachment 99708 [details]
screenshot showing the double frame resulting from the bug
Comment 3 Tino Meinen 2004-04-26 21:13:53 EDT
Same problem here, resulting in a double frame display, with the lower
half not sensitive to the mouse.
Taking a screenshot, reveals the hole desktop however, so I attach a
fotograph from my monitor. (iiyama vision master pro510)
The was correctly detected by the configurator.

Uncommenting the two Hsync en Vsync lines resolves the problem

Tino Meinen
Comment 4 François Kooman 2004-04-27 18:53:32 EDT
The DDC probe doesn't seem to work with my notebook as well (Toshiba
Satellite Pro 6100: P4, Geforce 4 Go 420,1024x768 TFT panel)
Uncommenting the two Hsync en Vsync lines resolved the problem for me too.
Comment 5 Jeremy Katz 2004-04-27 21:16:36 EDT
This is due to libxf86config in xorg commenting these out by default
(see bug 120950)
Comment 6 Olu Akins 2004-04-30 08:15:18 EDT
I had the same problem on my notebook but xorg detected the right
resolution. Comparing /etc/X11/xorg.conf and /etc/X11/xorg.conf.backup
shows that the xorg.conf.backup has the Hsync and Vsync uncommented.

Solution
 #cp /etc/X11/xorg.conf.backup /etc/X11/xorg.conf
Comment 7 Max Kessler 2004-05-01 21:52:38 EDT
Same problem with CyberBlade (Generic) and Iiyama VisionMaster
MF-8317.  I routinely use 1024x768, which even works under that
glass-thingy OS.  FC2 test 2 was able to use the same resolution.

I'm also using a KVM switch, but that should be irrelevant, since it
detected the video card correctly and I specified the monitor in Anaconda.

Firstboot gave me an option of 640x480 or 800x600.  I figured I would
have to manually tweak the setting afterward, so I selected 800x600. 
It booted into 640x480 instead.  After manually editing the xorg.conf
file to specify 1024x768 it boots into 800x600.
Comment 8 Nico Kadel-Garcia 2004-05-05 16:02:02 EDT
I found similar behavior on the Sony Vaio PCG-SRX77P. The workaround 
is to hand-edit the /etc/X11/xorg.conf and inform it gently, that the 
DefaultDepth is 16 and change the Display settings to support 16-bit 
resolution, something like the excerpt below.



Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     16
        SubSection "Display"
                Depth     16
                Modes    "1024x768" "800x600" "640x480"
        EndSubSection
#       DefaultDepth     24
#       SubSection "Display"
#               Depth     24
#               Modes    "1024x768" "800x600" "640x480"
#       EndSubSection
EndSection
Comment 9 Mike A. Harris 2004-05-07 09:44:12 EDT

*** This bug has been marked as a duplicate of 120950 ***
Comment 10 Red Hat Bugzilla 2006-02-21 14:02:47 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.