Bug 1217432 - DHT:Quota:- brick process crashed after deleting .glusterfs from backend
Summary: DHT:Quota:- brick process crashed after deleting .glusterfs from backend
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: 3.5.4
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Vijaikumar Mallikarjuna
QA Contact:
URL:
Whiteboard:
Depends On: 1203629
Blocks: glusterfs-3.5.5 1217419
TreeView+ depends on / blocked
 
Reported: 2015-04-30 10:57 UTC by Vijaikumar Mallikarjuna
Modified: 2016-05-11 22:48 UTC (History)
10 users (show)

Fixed In Version: glusterfs-3.5.5
Doc Type: Bug Fix
Doc Text:
Clone Of: 1203629
Environment:
Last Closed: 2015-07-19 19:33:00 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-04-30 11:01:26 UTC
REVIEW: http://review.gluster.org/10471 (posix: handle failure from posix_resolve) posted (#1) for review on release-3.5 by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 2 Anand Avati 2015-06-15 09:21:31 UTC
REVIEW: http://review.gluster.org/10471 (posix: handle failure from posix_resolve) posted (#2) for review on release-3.5 by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 3 Anand Avati 2015-06-28 19:51:06 UTC
COMMIT: http://review.gluster.org/10471 committed in release-3.5 by Niels de Vos (ndevos@redhat.com) 
------
commit 734f68f4116fd32066aa49cda93707b02ba194cf
Author: vmallika <vmallika@redhat.com>
Date:   Thu Apr 30 16:26:03 2015 +0530

    posix: handle failure from posix_resolve
    
    This is backport of http://review.gluster.org/#/c/9941/
    
    > When building ancestory, posix_resolve gets the inode
    > from the gfid. We need to handle the failure case from
    > this function
    >
    > Change-Id: I19f0f0c739686b1b0ef96309212aa1c7911b3589
    > BUG: 1203629
    > Signed-off-by: vmallika <vmallika@redhat.com>
    > Reviewed-on: http://review.gluster.org/9941
    > Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    > Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    
    Change-Id: If3f9a910be3d08293199748c9e04b3be2d8633c7
    BUG: 1217432
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/10471
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 4 Niels de Vos 2015-07-19 19:33:00 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.5, please reopen this bug report.

glusterfs-3.5.5 has been announced on the Gluster Packaging mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://article.gmane.org/gmane.comp.file-systems.gluster.devel/11986
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.