Bug 121791 - Setting to invalid SELinux state: -1
Setting to invalid SELinux state: -1
Status: CLOSED DUPLICATE of bug 121907
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-27 17:00 EDT by Neal Pape
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda debug log from setting to invalid SELinux state: -1 (30.58 KB, text/plain)
2004-04-27 17:01 EDT, Neal Pape
no flags Details

  None (edit)
Description Neal Pape 2004-04-27 17:00:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.0.3705)

Description of problem:
I am performing a custom installation of Fedora Core 2 Test 3 on a 
Dell Optiplex GX1p.  After I choose "No Firewall" and click next,
I receive an exception traceback which includes the message:
ValueError: Setting to invalid SELinux state: -1



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  On firewall choice screen, select "No firewall"
2.  Click Next
3.
    

Actual Results:  Exception occured

Expected Results:  Installation should continue

Additional info:

Anaconda log attached
Comment 1 Neal Pape 2004-04-27 17:01:12 EDT
Created attachment 99725 [details]
Anaconda debug log from setting to invalid SELinux state: -1
Comment 2 Craig Cruden 2004-04-28 01:58:39 EDT
I think I ran into the same thing... (same set of crash points), I
then tried to rerun install but just checking the firewall on --
another error.  I then backed up a little bit and instead of "Custom"
install, I selected "workstation" [then afterwords install all
packages] install I was able to get by this point [I cannot remember
if I checked firewall or NOT at that point -- I am guessing not....  
Comment 3 Forrest 2004-04-28 15:35:12 EDT
I got this error, too, doing an NFS install.  It crashed when I did
the firewall with SSH.  I tried it a second time, and it crashed
during package installation (uncompressing some rpms).  The third
time, it worked smoothly.
Comment 4 Olu Akins 2004-04-29 23:01:45 EDT
I selected custom install and at the firewall configuration I 
selected "Enable Firewall" and the next, then an exception occurred 
and this is the error message
"
Traceback (most recent call last):
 File "/usr/lib/anaconda/gui.py", line 759, in nextClicked
  rc = self.currentWindow.getNext()
 File "/usr/lib/anaconda/iw/firewall_gui_py", line 32, in getNext
  self.security.setSELinux(self.se_option_menu.get_history())
 File "/usr/lib/anaconda/security.py", line 39, in setSELinux
  raise ValueError, "Setting to invalid SELinux state: %s" %(val,)
ValueError: Setting to invalid SELinux state: -1
"

This was during a clean install
Comment 5 Francisco Javier Zaleta 2004-04-30 19:47:26 EDT
I got the same Error...

Dell Inspiron 8100/PIII 1GHz/512MB/30GB

- Workstation Install
- Delete all Linux partition on system
  - Look at changed
- No Firewall
- Crash

Exception Text:

Traceback (most recent call last):
 File "/usr/lib/anaconda/gui.py", line 759, in nextClicked
  rc = self.currentWindow.getNext()
 File "/usr/lib/anaconda/iw/firewall_gui_py", line 32, in getNext
  self.security.setSELinux(self.se_option_menu.get_history())
 File "/usr/lib/anaconda/security.py", line 39, in setSELinux
  raise ValueError, "Setting to invalid SELinux state: %s" %(val,)
ValueError: Setting to invalid SELinux state: -1
Comment 6 Shawn Walker 2004-05-03 13:27:58 EDT
I got this error as well when I left the firewall enabled and selected
to allow incoming "ssh".
Comment 7 Jacob Adams 2004-05-03 23:30:34 EDT
I am getting the same error on a home-built p2 350.  custom install,
enable firewall, allow ssh and www(http).  also occurs with not
allowing anything.  This occurs when booting from cd1 but not when
doing an nfs via boot.iso from disk1.  
Comment 8 Jacob Adams 2004-05-03 23:33:33 EDT
edit: able to work around via Craig's method- workstation then no
firewall.  
Comment 9 Miloslav Trmac 2004-05-04 07:39:37 EDT

*** This bug has been marked as a duplicate of 121907 ***
Comment 10 Red Hat Bugzilla 2006-02-21 14:02:47 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.