Bug 121815 - anaconda crash during install
Summary: anaconda crash during install
Status: CLOSED DUPLICATE of bug 121096
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-28 04:08 UTC by Dan
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:02:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dan 2004-04-28 04:08:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
Exception Occurred


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
basically during the last section of install after all the rpms have
been installed a window displaying an Exception Occurred
tried different package combonations
tried the text version of anaconda

Actual Results:  anaconda quits and I'm unable to boot into the
operating system

Expected Results:  should have completed the full installation

Additional info:

"An unhandled exception has occurred.  This is most likely a bug. 
Please copy the full text of this exception and file a detailed report
bug report against anaconda at http://bugzilla.redhat.com/bugzilla/

Traceback (most recent call last):
File "/usr/bin/anaconda", line 1129, in ? intf.run(id, dispatch,
configFileData)
File "/usr/lib/anaconda/text.py", line 475, in run dispatch.gotoNext()
File "/usr/lib/anaconda/dispatch.py", line 169, in gotoNext
self.moveStep()
File "/usr/lib/anaconda/dispatch.py", line 237, in moveStep rc =
apply(func, self.bindArgs(args))
File "/usr/lib/anaconda/packages.py", line 1111, in doPostInstall
devnull = os.open("/dev/null", os.O_RDWR)
OSError: [Errno 6] no such device or address: '/dev/nul'"

Comment 1 Pete/Piet Delaney 2004-04-29 00:49:59 UTC
I also had a anaconda exception with /dev/null. 
Seems a dup of 121096. In 121096 it's said that
installing in text mode avoids the bug.

================================================================
Traceback (most recent call last):

File "/usr/lib/anaconda/gui.py", line 1044, in handleRenderCallback
  self.currentWindow.renderCallback()

File "/usr/lib/anaconda/iw/progress_gui.py", line 242, in renderCallback
  self.intf.icw.nextClicker()

File "/usr/lib/anacconda/gui.py, line 763, in nextClicked
  self.dispatch.gotoNext()

File "/usr/lib/anaconda/dispatch.py", line 237, in moveStep
  rc = apply(func, self.bindArgs(args))


File "/usr/lib/anaconda/dispatch.py", line 169, in gotoNext
  self.moveStep()

File "usr/lib/anaconda/packages.py, line 1111, in doPostInstall
  devnull = os.open("/dev/null", os.O_RDWR)

OSError: [Erro 1] Operation not permitted: '/dev/null'
===============================================================================


Comment 2 Jeremy Katz 2004-04-29 01:45:56 UTC

*** This bug has been marked as a duplicate of 121096 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:02:48 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.