Bug 12182 - Install stalls at "Performing post-install configuration"
Install stalls at "Performing post-install configuration"
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brock Organ
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-13 00:21 EDT by Brent Nordquist
Modified: 2007-04-18 12:27 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-11 00:12:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brent Nordquist 2000-06-13 00:21:10 EDT
A custom graphical install of Winston Beta-1 from CD got all the way
through copying packages.  At the end, it showed the zip package, with
remaining packages 2, bytes 0, time 0:00 (the 2 remaining packages might be
a bug also).

After a slight pause, it popped up a rectangle with "Performing
post-install configuration".  All hard drive and CD activity ceased and it
sat for over an hour.  The mouse was still responsive.  No errors were
apparent in the VTs except the "neighbor table full" error documented by
someone else.  Killed X with Ctrl+Alt+Backspace and the machine rebooted.

[Intel Seattle 2 (100MHz) mobo, PII-450, 128MB RAM, Diamond Viper V550,
three ultra/wide SCSI disks (4.5, 4.5, 9GB) on Adaptec 2940UW controller,
one narrow SCSI CD-ROM, one IDE CD-RW drive.]
Comment 1 Brent Nordquist 2000-06-13 07:38:18 EDT
Tested again, same machine, custom install from CD in text mode.  Stalled at 
the same place (post-install configuration) for at least 10-15 minutes (again, 
no disk activity apparent).  I let it sit overnight, and eventually it did 
complete the install.
Comment 2 Brent Nordquist 2000-06-23 15:46:18 EDT
Using Winston beta2 on a different (all-IDE) machine, a custom graphical 
install asked for disc 2, ejected it, and displayed the little mini-
dialog "Performing post-install configuration".

Then it painted a grey rectangle over the mini-dialog, and all disk activity 
stopped.  Switching to the vt's didn't reveal anything unusual in the output, 
but when I returned to F7, the screen is black with blue rectangles where the 
frames should be.  The mouse and pointer are still active.  It's been sitting 
here for 15 minutes now.
Comment 3 Brent Nordquist 2000-06-26 07:06:55 EDT
...and I let the all-IDE machine sit over the weekend, and it never finished.

I also tried Winston Beta-2 on the same machine (SCSI) against which I submitted
this bug.  It still stalls at "Performing post-install configuration":  mouse
active but no screen repaint when I switch to VT1 and back to VT7 -- it took
about an hour before it moved on to boot disk creation.
Comment 4 Brent Nordquist 2000-06-26 08:15:54 EDT
See also bug 11715 against 6.2.

See also test case HW-4-10, although given that I've seen it on two very
different machines (and HW-4-10 makes three), I doubt this is "Misc. Hardware
Issues".
Comment 5 Brock Organ 2000-06-26 17:57:58 EDT
hi brent ... thanks for your efforts on this ... does this occur for you
regardless of which package groups you select in custom, or is it specific (ie
minimal, default, full, etc...) ...?

I'm not able to see this doing minimal, default & full installs on generic test
lab hardware ...
Comment 6 Brent Nordquist 2000-06-28 13:07:08 EDT
Good thought!  What I discovered through trial and error is that a custom
graphical with only X, GNOME, and Networked Workstation selected fails (exhibits
the long pause, blue frames when switching back to F7, etc.), but a custom
graphical with my normal long list of things, *without* X, GNOME, or KDE, works
fine.

So it looks like something in or after "Performing post-install configuration"
that's related to X or GNOME is the culprit.  Useful narrowing of the problem.

Here are the things I changed from default during the Beta-2 custom graphical
that failed:

   U.S. English w/ISO9995-3
   Generic 2 Button Mouse (PS/2) ([X] Emulate 3 Buttons)
   Install Custom System
   (allocate with Disk Druid)
   [ ] Create boot disk
   [ ] Use linear mode
   Boot label: redhat-6.9
   [X] Configure using DHCP
   UTC Offset UTC-06 US Central
   (enter 16-char root password)
   Package Group Selection (only X Window System, GNOME, Net. Workstation)
   (monitor freqs autodiscovered)
   [X] Customize X Configuration
   [X] 8-bit 640x480  [X] 16-bit 1024x768  [X] 32-bit 1024x768
Comment 7 Brent Nordquist 2000-06-28 18:49:34 EDT
The video card in this machine is an ATI RAGE 128 VR AGP (8MB).  Hmmm...
Comment 8 Bill Nottingham 2000-07-06 16:53:42 EDT
There's a potential hang with authconfig in beta2, IIRC. Does this
happen with beta3?
Comment 9 Brent Nordquist 2000-07-11 00:12:03 EDT
I've re-tested this with Winston Beta-3 on both the above-mentioned machines,
and I'm happy to report that it's fixed... the install does the "post-install
configuration" in a timely manner and moves on with no problem.

The math error (2 remaining packages at the end) is fixed too.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.