Bug 121834 - (SI3512 SATA)Installer fails to recognize SATA Controller
(SI3512 SATA)Installer fails to recognize SATA Controller
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
: 123152 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-28 09:29 EDT by Jose H Soltren
Modified: 2013-07-02 22:19 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 01:22:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jose H Soltren 2004-04-28 09:29:06 EDT
Description of problem:
Installer and other utilities fail to see a serial ATA hard disk connected to an onboard serial 
ATA controller.

Version-Release number of selected component (if applicable):
lspci gives: 01:0d.0 Unknown mass storage controller: Silicon Image, Inc. (formerly CMD 
Technology Inc) Silicon Image Serial ATARaid Controller [ CMD/Sil 3512 ] (rev 01)

How reproducible:
Buy a Gigabyte K8NNXP-940 motherboard, or any form of the component, and attach a 
hard disk.

Steps to Reproduce:
1. Build machine with SATA card and hard drive.
2. Boot Fedora Core 2 test3
3. Try to install.
  
Actual results:
Drive not seen.

Expected results:
Successful install.

Additional info:
Comment 1 Jose H Soltren 2004-04-28 09:38:50 EDT
dmesg fails to mention anything about said serial ATA card.
Comment 2 dijuremo 2004-04-29 09:32:22 EDT
I am not sure wether or not sil3152 is supported by sata_sil.ko on the
2.6.5 kernel. However, I found the same problem with sil3114; the hard
drives are not detected.  FC2 Test 3 does not have the sata_sil module
included in the modules.cgz file that is part of the boot cd/dvd.

I have extracted the isolinux folder from the AMD64 FC2Test3 and
modified it to work.  You can get a copy at

http://www.math.gatech.edu/~dijuremo/downloads/FC2Test3-AMD64-isolinux.tar.bz2

The silicon image is widely used on amd64 motherboards, so it would be 
very discouraging to fedora users if this module is not included in
the final release.

Diego

Comment 3 dijuremo 2004-05-05 08:18:19 EDT
I have checked with Jose and after modifying the initrd on the cd the
controller gets recognized.  Here is how you do it (for the impatient
and in case this does not make it to FC2 release):

1. You need another machine already running the distribution to obtain
the sata_sil.ko module.  Make sure the kernel version and architecture
from the running version is the same as the kernel used on the boot
cd.   It should be under /lib/modules/2.6.5-1.327/kernel/drivers/scsi/
If you had a FC2 Test2 machine already running you could just install
the new kernel RPM and then obtain the module from there.

2. Start with the FC2 Test 3 ISO that is adequate for your computer
(X86 or X86_64).  I recommend you to use a copy of the ISO so that you
do not damage the original one.  I will mount the ISO on /tmp/FC2T3:

3. cd /tmp
   mkdir /tmp/FC2T3
   mount -o loop /path/to/iso/ /tmp/FC2T3
   mkdir /tmp/initrdloop
   gunzip -c /tmp/FC2T3/isolinux/initrd.img > /tmp/initrd.img
   mount -o loop /tmp/isolinux/initrd.img /tmp/initrdloop
   vi /tmp/initrdloop/modules/pcitable
   Add the following entries for sil3114 and sil3512 chipsets(One line
no wrapping and use tabs instead of spaces.  I have not tried sil3112
so It may also should be added like 3114 and 3512):

   -----snip----
   0x108e  0x2bad  "sungem"        "Sun|GEM"
   0x1095  0x3114  "sata_sil"      "Silicon Graphics, Inc.|SiL 3114
controller"
   0x1095  0x3512  "sata_sil"      "Silicon Graphics, Inc.|SiL 3512
controller"
   0x10a9  0x0009  "acenic"        "Silicon Graphics, Inc.|AceNIC
Gigabit Ethernet"
   -----snip----

   vi /tmp/initrdloop/modules/modules.dep
   find the "sata_" entries and add sata_sil if missing as shown:

   sata_sil: libata scsi_mod

   vi /tmp/initrdloop/modules/module-info
   find the "sata_" entries and add:
   ---snip----
   sata_promise
        scsi
        "Promise SATA controllers"
   sata_sil
           scsi
           "Silicon Image SATA controllers"
   sata_via
        scsi
        "VIA SATA controllers"
   ---snip-----

3. mkdir /tmp/modules
   cd /tmp/modules
   gunzip -c /tmp/initrdloop/modules/modules.cgz | cpio -dvi
   ls /tmp/modules/2.6.5-1.327/x86_64 
   You should see a bunch of modules there (notice that I am working
with X86_64, so your version may just be /tmp/modules/2.6.5-1.327/x86
for the 32 bit version of Fedora).
   Now you need to copy the sata_sil module here:
   cp /path/to/module/sata_sil.ko/from/fc2-test3/installed/on/pc
/tmp/modules/2.6.5-1.327/x86_64/
   cd /tmp/modules
   find 2.6.5-1.327 -print -depth| cpio -H crc -o | gzip -c > modules.cgz
   Now overwrite the modules.cgz on the initrdloop/modules folder
   cp /tmp/modules/modules.cgz /tmp/initrdloop/modules/
    
4. We can now unmount the initrd and put it back on the cd
   cd /tmp
   umount /tmp/initrdloop
   gzip -c initrd.img > newinitrd.img
   cp -rp /tmp/newinitrd.img /tmp/FC2T3/isolinux/initrd.img

5. Clean up!
   umount /tmp/FC2T3
   rm -rf /tmp/initrdloop /tmp/initrd.img /tmp/newinitrd.img /tmp/FC2T3

6. Burn a new CD with the modified ISO and enjoy.

      
Comment 4 Rainer Koenig 2004-05-13 03:26:21 EDT
I tried to modify the CD as you described. But there is a small problem:
cp -rp /tmp/newinitrd.img /tmp/FC2T3/isolinux/initrd.img does not work
because the ISO9660 file system is read only by definition. So what
can I do now?
Comment 5 Rainer Koenig 2004-05-13 04:20:12 EDT
Ok, solved my problem with mkisofs :-) 

Looks pretty nice now and works with all 4 S-ATA drives. Thanks.
Comment 6 Rainer Koenig 2004-05-13 04:22:10 EDT
*** Bug 123152 has been marked as a duplicate of this bug. ***
Comment 7 Dave Jones 2004-12-08 01:11:30 EST
any better with the latest 2.6.9 updates ?
Comment 8 Dave Jones 2005-04-16 01:22:24 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.