Bug 1218360 - [abrt] octave: Fl_Gl_Window::show(): octave-cli-3.8.2 killed by SIGSEGV
Summary: [abrt] octave: Fl_Gl_Window::show(): octave-cli-3.8.2 killed by SIGSEGV
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: octave
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaromír Cápík
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:c65280f711ecac2a7fcae550ac0...
: 1220627 1220831 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-04 17:46 UTC by Mark Fuller
Modified: 2016-02-01 02:01 UTC (History)
11 users (show)

Fixed In Version: octave-3.8.2-11.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-17 06:40:31 UTC


Attachments (Terms of Use)
File: backtrace (160.96 KB, text/plain)
2015-05-04 17:46 UTC, Mark Fuller
no flags Details
File: cgroup (190 bytes, text/plain)
2015-05-04 17:46 UTC, Mark Fuller
no flags Details
File: core_backtrace (18.84 KB, text/plain)
2015-05-04 17:46 UTC, Mark Fuller
no flags Details
File: dso_list (9.56 KB, text/plain)
2015-05-04 17:46 UTC, Mark Fuller
no flags Details
File: environ (3.46 KB, text/plain)
2015-05-04 17:46 UTC, Mark Fuller
no flags Details
File: limits (1.29 KB, text/plain)
2015-05-04 17:46 UTC, Mark Fuller
no flags Details
File: maps (45.61 KB, text/plain)
2015-05-04 17:46 UTC, Mark Fuller
no flags Details
File: open_fds (240 bytes, text/plain)
2015-05-04 17:46 UTC, Mark Fuller
no flags Details
File: proc_pid_status (943 bytes, text/plain)
2015-05-04 17:46 UTC, Mark Fuller
no flags Details

Description Mark Fuller 2015-05-04 17:46:26 UTC
Version-Release number of selected component:
octave-3.8.2-9.fc21

Additional info:
reporter:       libreport-2.3.0
backtrace_rating: 4
cmdline:        /usr/bin/octave-cli-3.8.2
crash_function: Fl_Gl_Window::show
executable:     /usr/bin/octave-cli-3.8.2
kernel:         3.19.5-200.fc21.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000
var_log_messages: [System Logs]:\n-- Logs begin at Thu 2014-09-04 14:20:15 EDT, end at Mon 2015-05-04 12:19:06 EDT. --

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 Fl_Gl_Window::show at Fl_Gl_Window.cxx:87
 #1 Fl_Window::handle at Fl.cxx:1613
 #2 Fl_Gl_Window::handle at Fl_Gl_Window.cxx:563
 #3 OpenGL_fltk::handle at dldfcn/__init_fltk__.cc:252
 #4 Fl_Group::handle at Fl_Group.cxx:283
 #5 plot_window::handle at dldfcn/__init_fltk__.cc:1277
 #6 Fl_X::make_xid at Fl_x.cxx:2565
 #7 plot_window::plot_window at dldfcn/__init_fltk__.cc:779
 #8 figure_manager::do_new_window at dldfcn/__init_fltk__.cc:1710
 #9 new_window at dldfcn/__init_fltk__.cc:1571

Comment 1 Mark Fuller 2015-05-04 17:46:29 UTC
Created attachment 1021825 [details]
File: backtrace

Comment 2 Mark Fuller 2015-05-04 17:46:30 UTC
Created attachment 1021826 [details]
File: cgroup

Comment 3 Mark Fuller 2015-05-04 17:46:31 UTC
Created attachment 1021827 [details]
File: core_backtrace

Comment 4 Mark Fuller 2015-05-04 17:46:32 UTC
Created attachment 1021828 [details]
File: dso_list

Comment 5 Mark Fuller 2015-05-04 17:46:33 UTC
Created attachment 1021829 [details]
File: environ

Comment 6 Mark Fuller 2015-05-04 17:46:34 UTC
Created attachment 1021830 [details]
File: limits

Comment 7 Mark Fuller 2015-05-04 17:46:36 UTC
Created attachment 1021831 [details]
File: maps

Comment 8 Mark Fuller 2015-05-04 17:46:37 UTC
Created attachment 1021832 [details]
File: open_fds

Comment 9 Mark Fuller 2015-05-04 17:46:38 UTC
Created attachment 1021833 [details]
File: proc_pid_status

Comment 10 Orion Poplawski 2015-05-04 17:51:41 UTC
Can you reproduce this?  If so, can you post the steps?

Comment 11 Ondrej Majerech 2015-05-10 17:14:41 UTC
(In reply to Orion Poplawski from comment #10)
> Can you reproduce this?  If so, can you post the steps?

Hi, I'm having the same problem. Reproducing it is simple:

1) Run octave
2) Type "colormap(gray)" at the prompt

A figure window pops up for a split second and Octave crashes.

Comment 12 Orion Poplawski 2015-05-12 03:56:55 UTC
*** Bug 1220627 has been marked as a duplicate of this bug. ***

Comment 13 Orion Poplawski 2015-05-12 03:58:39 UTC
fltk-1.3.3 update broke API.  I'm rebuilding octave now.

Comment 14 Fedora Update System 2015-05-12 13:38:39 UTC
octave-3.8.2-11.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/octave-3.8.2-11.fc21

Comment 15 Orion Poplawski 2015-05-12 15:50:56 UTC
*** Bug 1220831 has been marked as a duplicate of this bug. ***

Comment 16 Fedora Update System 2015-05-14 11:12:31 UTC
Package octave-3.8.2-11.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing octave-3.8.2-11.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-8129/octave-3.8.2-11.fc21
then log in and leave karma (feedback).

Comment 17 Fedora Update System 2015-05-17 06:40:31 UTC
octave-3.8.2-11.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.