Bug 1220627 - Plots broken
Summary: Plots broken
Keywords:
Status: CLOSED DUPLICATE of bug 1218360
Alias: None
Product: Fedora
Classification: Fedora
Component: octave
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaromír Cápík
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-12 03:33 UTC by Susi Lehtola
Modified: 2016-02-01 02:01 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-12 03:56:55 UTC


Attachments (Terms of Use)

Description Susi Lehtola 2015-05-12 03:33:36 UTC
For some reason Octave's plotting capability seems to be broken down. I can reproduce this on two machines running Fedora 21.

In a clean environment, starting Octave and running a plot results in a segfault

octave:1> x=0:.01:2*pi;
octave:2> plot(x,sin(x));
panic: Segmentation fault -- stopping myself...
attempting to save variables to 'octave-workspace'...
save to 'octave-workspace' complete
Segmentation fault (core dumped)

This also happens with

octave:1> graphics_toolkit("fltk");
octave:2> x=0:.01:10;
octave:3> plot(x,sin(x))
panic: Segmentation fault -- stopping myself...
attempting to save variables to 'octave-workspace'...
save to 'octave-workspace' complete
Segmentation fault (core dumped)

but with gnuplot it works

octave:1> graphics_toolkit("gnuplot");
octave:2> x=0:.01:10;
octave:3> plot(x,sin(x));
octave:4>

Could it be that fltk's ABI has been broken?

Comment 1 Orion Poplawski 2015-05-12 03:56:55 UTC

*** This bug has been marked as a duplicate of bug 1218360 ***


Note You need to log in before you can comment on or make changes to this bug.