Bug 1218388 - While enabling repositories it was failing with '500: Internal Server Error'
Summary: While enabling repositories it was failing with '500: Internal Server Error'
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Christine Fouant
QA Contact: sthirugn@redhat.com
David O'Brien
URL:
Whiteboard:
Depends On:
Blocks: sat61-release-notes
TreeView+ depends on / blocked
 
Reported: 2015-05-04 18:45 UTC by Brad Buckingham
Modified: 2017-02-23 20:05 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-12 16:03:36 UTC


Attachments (Terms of Use)
Traceback (12.26 KB, text/plain)
2015-05-04 18:45 UTC, Brad Buckingham
no flags Details

Description Brad Buckingham 2015-05-04 18:45:53 UTC
Created attachment 1021900 [details]
Traceback

Description of problem:

While enabling repositories, it was failing with a "500: Internal Server Error".

Version-Release number of selected component (if applicable):
Satellite 6.1 beta

How reproducible:
Not sure.

Steps to Reproduce:
1. Import a manifest (Content -> Red Hat Subscriptions)
2. Attempt to enable a repository (Content -> Red Hat Repositories)

Actual results:
500 ISE

Expected results:
No error

Additional info:

Note: it was observed that refreshing the manifest resolved the issue.

This issue was raised by AshishH during a Sat 6.1 Beta test day.

Comment 1 RHEL Product and Program Management 2015-05-04 19:03:14 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Christine Fouant 2015-06-16 21:47:34 UTC
tested on 6.1 Snap 8 Compose 3 and could not reproduce this issue.

Comment 5 sthirugn@redhat.com 2015-07-08 19:16:47 UTC
Verified. This works fine for me.

I saw a similar error when trying to upload an old manifest, but I figured that the manifest's corresponding satellite entry had been removed from portal.

I will reopen this issue if I see it happening again.

Comment 8 David O'Brien 2015-07-21 14:46:55 UTC
Does this require a rel note something like "if you run into this issue try refreshing (recreating?) your manifest"?

Otherwise, is a rel note required at all?

thanks

Comment 9 Bryan Kearney 2015-08-12 16:03:36 UTC
This bug was fixed in Satellite 6.1.1 which was delivered on 12 August, 2015.


Note You need to log in before you can comment on or make changes to this bug.