Bug 121862 - (TB613f503b) TB613f503b maindialog.py:531:hydrateIPsec:AttributeError: ---- system-config-network crashes after saving a profile and changing to another profile
TB613f503b maindialog.py:531:hydrateIPsec:AttributeError: ---- system-config...
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
: 124631 126315 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2004-04-28 14:37 EDT by Pankaj Jain
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-08-30 06:43:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Pankaj Jain 2004-04-28 14:37:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040211 Firefox/0.8

Description of problem:
I created a new profile, saved it and then tried to change back to the
"Common" profile.  This caused the crash.  I then ran
system-network-config again, made a change to the DHCP profile I
previously created and then tried to change to the "Common" profile
and the crash ocurred again.  I haven't been able to get test3 yet to
see if the problem occurs there as well.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Create or Edit a profile
2. Save the profile
3. Change to a different profile

Actual Results:  Crash
Component: system-config-network
Version: 1.3.16
Summary: TB613f503b maindialog.py:531:hydrateIPsec:AttributeError:
'NoneType' object has no attribute 'clear'
Traceback (most recent call last):
line 1037, in on_profileMenuItem_activated
line 420, in hydrate
line 531, in hydrateIPsec
AttributeError: 'NoneType' object has no attribute 'clear'
Local variables in innermost frame:
clist: None
self: <netconfpkg.gui.maindialog.mainDialog instance at 0x55441f6c>

Expected Results:  selected profile should be active.

Additional info:
Comment 1 Harald Hoyer 2004-05-28 04:13:33 EDT
*** Bug 124631 has been marked as a duplicate of this bug. ***
Comment 2 Peter Fales 2004-06-06 21:14:02 EDT
I'm seeing the same thing in FC2.  For what it's worth, I'm able to
switch profiles using the command line tool (system-config-network-cmd).
Comment 3 Michal Jaegermann 2004-06-07 11:22:06 EDT
Hm, switching profiles through system-config-network-cmd it is not
so hot either in my experience.  See bug #124643.  The whole setup
seems to be awfully brittle.
Comment 4 Harald Hoyer 2004-06-19 09:29:26 EDT
*** Bug 126315 has been marked as a duplicate of this bug. ***
Comment 5 Michael "Murph" Robbert 2004-07-07 13:22:34 EDT
I want to add my name to the list of people experiencing this problem.
I am getting it on a fresh install of FC2. Is this going to get fixed
or should I look for another way to have multiple network configurations?
Comment 6 Patrice Dumas 2006-08-30 06:31:47 EDT
This old bug seems to be fixed in fedora core 5. Maybe this bug 
could be closed or assigned to the right product?

Note You need to log in before you can comment on or make changes to this bug.