Bug 126315 - changing profile after profile modification crashes installer
Summary: changing profile after profile modification crashes installer
Status: CLOSED DUPLICATE of bug 121862
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
(Show other bugs)
Version: 2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-18 21:51 UTC by Patrice Dumas
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:04:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Patrice Dumas 2004-06-18 21:51:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
In system-config-network.

When I modify something in a profile and then switch to another
profile the application crash with a backtrace:

Component: system-config-network
Version: 1.3.16
Summary: TB613f503b maindialog.py:531:hydrateIPsec:AttributeError:
'NoneType' object has no attribute 'clear'
Traceback (most recent call last):
  File
"/usr/src/build/377922-noarch/install/usr/share/system-config-network/netconfpkg/gui/maindialog.py",
line 1037, in on_profileMenuItem_activated
  File
"/usr/src/build/377922-noarch/install/usr/share/system-config-network/netconfpkg/gui/maindialog.py",
line 420, in hydrate
  File
"/usr/src/build/377922-noarch/install/usr/share/system-config-network/netconfpkg/gui/maindialog.py",
line 531, in hydrateIPsec
AttributeError: 'NoneType' object has no attribute 'clear'
 
Local variables in innermost frame:
clist: None
self: <netconfpkg.gui.maindialog.mainDialog instance at 0xf6cf408c>
ipseclist:


Version-Release number of selected component (if applicable):
system-config-network-1.3.16-1

How reproducible:
Sometimes

Steps to Reproduce:
1. create more than one profile
2. change something in a profile
3. choose another profile
    

Actual Results:  Often a crash




Additional info:

Comment 1 Harald Hoyer 2004-06-19 13:29:24 UTC

*** This bug has been marked as a duplicate of 121862 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:04:09 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.