Bug 1219068 - Firefox crashes when trying to play videos on youtube
Summary: Firefox crashes when trying to play videos on youtube
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gstreamer1-vaapi   
(Show other bugs)
Version: 22
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Simon Farnsworth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1219276 1222054 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-06 14:13 UTC by Heiko Adams
Modified: 2015-10-29 18:35 UTC (History)
21 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1218724
Environment:
Last Closed: 2015-07-02 14:35:29 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
RPM Fusion 3645 None None None Never

Description Heiko Adams 2015-05-06 14:13:09 UTC
+++ This bug was initially created as a clone of Bug #1218724 +++

Description of problem:
Since one of the last updates for fedora 22 firefox crashes when trying to playback html5-videos on youtube.

Version-Release number of selected component (if applicable):
$ rpm -q firefox
firefox-38.0-1.fc22.x86_64 (installed from koji but also happens with 37.0.2)

How reproducible:
allways

Steps to Reproduce:
1. Start firefox
2. Navigate to youtube
3. Open i.e. https://www.youtube.com/watch?v=oYjfa5SktXA

Actual results:
Firefox crashes

Expected results:
Firefox should play the video without crashing

Additional info:

--- Additional comment from Heiko Adams on 2015-05-06 12:16:04 CEST ---

This happens everytime you try watch a video which via HTML5. Flash-Videos seem to work fine

Comment 1 Nicolas Chauvet (kwizart) 2015-05-06 16:42:50 UTC
Can you verify if the problem is solved by using the matching libva backend driver ?
http://download1.rpmfusion.org/free/fedora/development/22/x86_64/os/libva-intel-driver-1.5.1-1.fc22.x86_64.rpm

Either way, if the libva backend driver is not installed, firefox should correctly discard the libva code path. In this case you can still report the issue to the libva upstream bug tracker at bugs.freedesktop.org

Comment 2 Heiko Adams 2015-05-06 17:11:01 UTC
$ rpm -qa \*libva\* \*vaapi\*
gstreamer1-vaapi-0.5.10-2.fc22.x86_64
libva-intel-driver-1.4.1-1.fc22.x86_64
libva-1.5.1-1.fc22.x86_64

When running firefox from shell the following lines are printed when firefox crashes:
libva info: VA-API version 0.37.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib64/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_36
libva info: va_openDriver() returns 0

Comment 3 Heiko Adams 2015-05-06 17:56:45 UTC
After applying the libva-intel-driver-1.5.1-1.fc22.x86_64 update the following lines are printed when firefox crashes:

** (firefox:25114): CRITICAL **: gst_app_src_set_size: assertion 'GST_IS_APP_SRC (appsrc)' failed

** (firefox:25114): CRITICAL **: gst_app_src_set_size: assertion 'GST_IS_APP_SRC (appsrc)' failed

** (firefox:25114): CRITICAL **: gst_app_src_set_size: assertion 'GST_IS_APP_SRC (appsrc)' failed

Comment 4 Nicolas Chauvet (kwizart) 2015-05-06 19:02:39 UTC
@Simon,
maybe we can rebuild gst-vaapi for 0.37 api (libva 1.5.x) but I don't think that will solve this particular issue.

Comment 5 Nerijus Baliūnas 2015-05-07 10:39:29 UTC
Does it crash if you remove gstreamer1-vaapi?

Comment 6 Heiko Adams 2015-05-07 11:00:54 UTC
After removing gstreamer1-vaapi it no longer crashes

Comment 7 core bots 2015-05-07 12:14:29 UTC
same type of problem here; but removing gstreamer1-vaapi  has no effect on the crashes. I'm using the Nvidia proprietary driver if that matters.

Comment 8 Martin Stransky 2015-05-07 12:16:59 UTC
If you still see Firefox crashes please file a new bug and provide a backtrace of the crash: http://fedoraproject.org/wiki/Debugging_guidelines_for_Mozilla_products

Comment 9 Sergio Monteiro Basto 2015-05-12 16:52:59 UTC
dnf remove gstreamer1-plugins-bad-freeworld

fixes this bug for me , is rpmfusion package

Comment 10 Stanislav Graf 2015-05-12 20:04:16 UTC
(In reply to Sergio Monteiro Basto from comment #9)
> dnf remove gstreamer1-plugins-bad-freeworld
> 
> fixes this bug for me , is rpmfusion package

fixes this bug for me also

Comment 11 Nicolas Chauvet (kwizart) 2015-05-12 21:15:06 UTC
(In reply to Sergio Monteiro Basto from comment #9)
> dnf remove gstreamer1-plugins-bad-freeworld
> 
> fixes this bug for me , is rpmfusion package
This doesn't explain what's going on there, or which patch should be applied to have the feature back.

Comment 12 Nicolas Chauvet (kwizart) 2015-05-12 21:18:48 UTC
Also I would bet that the same streams play fine with totem and all theses gst plugins.

Comment 13 Simon Farnsworth 2015-05-13 09:34:27 UTC
(In reply to Nicolas Chauvet (kwizart) from comment #4)
> @Simon,
> maybe we can rebuild gst-vaapi for 0.37 api (libva 1.5.x) but I don't think
> that will solve this particular issue.

I can't see how it would help, but I'm happy to trigger a rebuild. Which versions of Fedora do you want me to hit? Just Rawhide and F22 branch?

Comment 14 Sergio Monteiro Basto 2015-05-18 17:35:14 UTC
After update gstreamer1-plugins-bad-freeworld to 1.4.5-2.fc22.x86_64, rpm of
May 17 and after :
dnf remove  gstreamer1-libav
dnf install gstreamer1-libav

Firefox is playing html5 videos of youtube without problems . So this seems
fixed 

Thanks,

Comment 15 Martin Stransky 2015-05-18 17:58:50 UTC
*** Bug 1219276 has been marked as a duplicate of this bug. ***

Comment 16 Nicholas Kudriavtsev 2015-05-19 09:54:27 UTC
Confirm, html5 videos are playing.

Comment 17 Martin Stransky 2015-05-25 11:43:55 UTC
*** Bug 1222054 has been marked as a duplicate of this bug. ***

Comment 18 Johannes Raggam 2015-05-26 08:28:54 UTC
Confirmed too! Solved for me on Fedora 22 with testing repositories enabled.

Comment 19 Eike Hein 2015-05-26 12:45:27 UTC
FWIW, on my system (nVidia) I had to remove gstreamer-ffmpeg to avoid Nightly crashing. I have gstreamer1-libav installed (removing made no diff), gstreamer1-vaapi not installed (removing made no diff) and gstreamer1-plugins-bad-freeworld not installed (also no diff).

Comment 20 Sergio Monteiro Basto 2015-07-02 14:35:29 UTC
https://bugzilla.rpmfusion.org/show_bug.cgi?id=3645 is fixed

Comment 21 Didier 2015-08-14 17:33:11 UTC
firefox-40.0-3.fc22.x86_64 (updates-testing)

gstreamer1-libav-1.4.5-1.fc22.x86_64
libva-1.5.1-1.fc22.x86_64
gstreamer1-plugins-bad-freeworld-1.4.5-2.fc22.x86_64
libva-vdpau-driver-0.7.4-10.fc22.x86_64


Firefox crashes (previous versions up to 39.0 did not), returning an identical error message as quoted in comment#2.

Tested all 'dnf remove' permutations with the abovementioned packages : only removing "libva-vdpau-driver" prevents firefox from crashing.


(https://bugs.archlinux.org/task/40807#comment135905 describes a similar experience.)

Should this bug be reopened ?
(disclaimer : akmod-nvidia-352.30-2.fc22.x86_64)

Comment 22 Didier 2015-08-14 19:43:49 UTC
With regard to comment#21 :

Bad assertion, firefox-40.0-3.fc22.x86_64 keeps crashing with gstreamer1-libav-1.4.5-1.fc22.x86_64, gstreamer1-plugins-bad-freeworld-1.4.5-2.fc22.x86_64 and libva-vdpau-driver-0.7.4-10.fc22.x86_64.

Reverting back to firefox-39.0.3-1.fc22.x86_64.

Comment 23 Didier 2015-08-14 19:56:52 UTC
Apologies for the spam, comment#22 should read :

"firefox-40.0-3.fc22.x86_64 keeps crashing with gstreamer1-libav-1.4.5-1.fc22.x86_64, gstreamer1-plugins-bad-freeworld-1.4.5-2.fc22.x86_64 and libva-vdpau-driver-0.7.4-10.fc22.x86_64 *removed*".

Comment 24 Didier 2015-08-19 10:36:43 UTC
Tested with firefox-40.0-4.fc22.x86_64 for the past 2 days :

firefox stops crashing (error log, cfr. comment #2) when package "libva-vdpau-driver" is removed.

Related to bug #1247518 ?


Note You need to log in before you can comment on or make changes to this bug.