Bug 1247518 - firefox with gpu hwaccel and crash reports (empty?)
firefox with gpu hwaccel and crash reports (empty?)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
22
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-28 04:21 EDT by lejeczek
Modified: 2015-08-20 07:43 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-20 05:04:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lejeczek 2015-07-28 04:21:24 EDT
Description of problem:

having:
layers.acceleration.force-enabled
layers.offmainthreadcomposition.enabled

firefox crashes constantly and I send "crash reports" to Mozilla, but then I click for details there is nothing, empty field. So I wonder if these reports work in the first place?

Version-Release number of selected component (if applicable):

39.0

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Didier 2015-08-19 06:36:40 EDT
firefox-40.0-4.fc22.x86_64 (with layers.offmainthreadcomposition.enabled by default set to false) stops crashing (I am also experiencing the empty crash details pages) when package "libva-vdpau-driver" is uninstalled (cfr. bug #1219068 ?).
Comment 2 Martin Stransky 2015-08-20 05:04:16 EDT
Yes, 40.0-4 disables the OMTC. We're going to re-enable it in FF41.
Comment 3 lejeczek 2015-08-20 07:39:28 EDT
but how about those internal crash reports to Mozilla, does this even work? Like I said, field with details is each time empty.
Comment 4 Martin Stransky 2015-08-20 07:43:35 EDT
Those reports are malformed because of the corrupted memory.

Note You need to log in before you can comment on or make changes to this bug.