Bug 121910 - Error activating XKB configuration
Error activating XKB configuration
Status: CLOSED DUPLICATE of bug 120858
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-28 20:42 EDT by Subhendu Ghosh
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Subhendu Ghosh 2004-04-28 20:42:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
Upgrade from FC1 to FC2-test3.
On graphical login, Error message -- 
Error activating XKB configuration
Probably  internal X Server problem
XServer version 60700000

[root]# xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xfree86", "pc105", "us", "", ""

[root]# gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
 layouts = [us]
 model = pc105
 overrideSettings = false
 options = []


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.graphical login, any account
2.
3.
    

Additional info:
Comment 1 Harri H. 2004-04-30 06:01:53 EDT
Excatly same error and same listing (except I'm having Finnish
keyboard layout.)

If I comment out "Option= xkbDisable" from XFree86.conf, my keyboard
looses few characters, example the important "@" sign.

I installed FC test 2 and didn't got this error until I updated some
xorg related packages via up2date.
Comment 2 Michael Young 2004-04-30 06:57:42 EDT
I think this is another symptom of bug 121016. Try the workaround
suggested in #4.
triage->duplicate 121016
Comment 3 Subhendu Ghosh 2004-04-30 08:13:35 EDT
Workaround of commenting out the line for 

Option "Xkbrules" "xfree86" 

in /etc/X11/XF86Config eliminates the error msg.

Thanks
Comment 4 Miloslav Trmac 2004-04-30 08:54:00 EDT
Mike, in bug 120858 you have offered to automatically edit the config
file and remove the Xkbrules line.

It looks like this will really be needed for people upgrading from FC1.
Comment 5 Mike A. Harris 2004-05-04 11:59:18 EDT

*** This bug has been marked as a duplicate of 120858 ***
Comment 6 Mike A. Harris 2004-05-04 14:17:14 EDT
mitr: Agreed..   I just filed bug #122454 to track the config file
mod issue, and CC'd you on it.

Thanks for the reminder.
Comment 7 Red Hat Bugzilla 2006-02-21 14:02:50 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.