Bug 121942 - screen corruption switching from X to text mode with i830 graphics
screen corruption switching from X to text mode with i830 graphics
Status: CLOSED DUPLICATE of bug 115753
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2004-04-29 04:58 EDT by Mary Ellen Foster
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:02:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Mary Ellen Foster 2004-04-29 04:58:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)

Description of problem:
When I switch from X back to a virtual console -- either with ctrl-alt-fN or when shutting down -- the screen gets all corrupted and swirly. It's kind of hard to describe, and obviously I can't take a screenshot, but basically there are swirls of colour all over the screen, with regularly-spaced horizontal black lines.

This is something that started happening with the switch from XFree86 4.3.0-42 to 4.3.0-55 in FC1 -- that is, I could switch to text mode fine in -42, but when I updated to -55, I started seeing this problem. I bugzilla'd that, but I think it went into a black hole somewhere.

I just installed FC2t3 last night, and the problem persists with the new X server.

I seem to recall this also being a problem with the initial X server shipped with Redhat 9, and one that got fixed with a later update on that product -- I could be remembering incorrectly though.

NB: If I hit ctrl-alt-f7 after this, X generally returns successfully; it's just the virtual consoles that are messed up.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Boot computer in runlevel 5
2. ctrl-alt-F1

Actual Results:  Corrupted, psychedelic screen

Expected Results:  A useable virtual console

Additional info:

- Intel i830 built-in motherboard graphics
- Acer travelmate 220 laptop
- LCD display, 1024x768
Comment 1 Mike A. Harris 2004-05-05 11:57:34 EDT

*** This bug has been marked as a duplicate of 115753 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:02:50 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.