Bug 121946 - system-config-display: can only access 800x600 and 640x480 screen resolutions
system-config-display: can only access 800x600 and 640x480 screen resolutions
Status: CLOSED DUPLICATE of bug 120950
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-29 05:20 EDT by Michael Opdenacker
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My last xorg.0.log (30.66 KB, text/plain)
2004-05-02 08:54 EDT, Mike Becker
no flags Details

  None (edit)
Description Michael Opdenacker 2004-04-29 05:20:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040422

Description of problem:
Hello,

This is an issue that was introduced in FC2 T3.
I didn't face it in FC2 T1 and T2.

I have a 1600x1200 LCD Panel
and a ATI Radeon Mobility M9 (9000) video card.

I have no display problem at all: the screen resolution
is 1600x1200 as it should be.

The only problem is that system-config-display
("System Settings" -> "Display") only lets
me choose between the 800x600 and 640x480 resolutions.

This can confuse users when system-config-display
is run during the first boot.

Here are the corresponding sections in my /etc/X11/XF86Config file:

Section "Device"
        Identifier  "Videocard0"
        Driver      "radeon"
        VendorName  "Videocard vendor"
        BoardName   "ATI Radeon Mobility M9"
EndSection
                                                                     
                                                      
Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     16
                Modes    "1600x1200" "1400x1050" "1280x1024"
"1280x960" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "800x600" "640x480"
        EndSubSection
EndSection

Don't hesitate to ask me for more details!
Thank you for everything!

:-)

Michael.

Version-Release number of selected component (if applicable):
xorg-x11-6.7.0-0.5

How reproducible:
Always

Steps to Reproduce:
1. Run system-config-display
    

Additional info:
Comment 1 Michael Opdenacker 2004-04-29 05:28:16 EDT
I removed the below subsection:

        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "800x600" "640x480"
        EndSubSection

... and restarted the X server.
This didn't have any impact on the behaviour of
system-config-display.
Comment 2 Nils Hammar 2004-04-30 16:24:15 EDT
I experienced the same problem on a machine with an Intel I810
graphics card and a HP A4033A 21" monitor capable of 1600x1200.
Comment 3 Mike Becker 2004-05-02 08:53:04 EDT
Basically the same here on this Gateway M500 but xorg sets the res to
1024x768 instead of the 1280x854 the system uses.  I added the
ModeLine to xorg.conf, it did work on the initial X startup but fails
to use 1280x854 on subsequent starts.

My xorg.conf (partial):

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "LCD Panel 1280x854"
	HorizSync    31.5 - 48.5
	VertRefresh  40.0 - 60.0
	Option	     "dpms"
	ModeLine     "1280x854" 85.26 1280 1296 1552 1792 854 854 861 892
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "nv"
	VendorName  "Videocard vendor"
	BoardName   "NVIDIA GeForce 4 (generic)"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     16
	SubSection "Display"
		Viewport   0 0
		Depth     16
		Modes    "1280X854" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

I have used these parameters since FC1 with success...
Comment 4 Mike Becker 2004-05-02 08:54:02 EDT
Created attachment 99881 [details]
My last xorg.0.log
Comment 5 Mike Becker 2004-05-03 10:48:52 EDT
OK guys, for some reason I was able to get the 1280x854 screen
resolution simply by adding one '#' to the SubSection/Modes line, as in:

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     16
	SubSection "Display"
		Viewport   0 0
		Depth     16
		Modes    "1280X854" #"1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Upon the next reboot, I had a 1280x854 screeen resolution!!!  This
will give me but one screen resolution but one is all I need.

Now if only I could get my Gnome system sounds to work...

Thanks guys...
Comment 6 Doug Morton 2004-05-04 23:28:04 EDT
This may seem a little "simple-minded", but I found that I cound get 
around this problem with the following procedure:

1. Select "system settings" and then "display"
2. Then I changed my monitor to some other monitor, clicked "OK"
3. Then immediately change the monitor back and click "OK". 

This refreshes the display resolution list, allowing selection of the 
correct resolution. A quick reboot and I had the resolution I wanted).
Comment 7 Nicholas Ruddick 2004-05-05 13:28:08 EDT
I have a similar problem with an Optiquest Q41 monitor.
System-display-settings lets me choose 640x480, 800x600, 1024x768.
However it will only boot up on 640x480 no matter what setting I
choose. This is reflected in the Gnome settings for screeen resolution
that only lets me choose 640x480.
Comment 8 Tim Mortlock 2004-05-05 19:21:47 EDT
Same for me runnig an Athlon XP1700+ with a Radeon 7500... Looks like 
I'm gonna have to play...

Tim
Comment 9 Mike A. Harris 2004-05-05 22:54:44 EDT
Michael:

Please update your system to all of the latest packages from rawhide,
and then remove the XF86Config file or rename it to something else
as a backup.  After that, rerun "system-config-display --reconfig"
which will generate a new config file from scratch.  Try this config
out, and if the problem persists, edit the config file, which should
be /etc/X11/xorg.conf and go to the monitor section.  If the monitor
section contains commented out stuff, uncomment it and restart X and
see if that makes a difference.  Then attach your current xorg.conf,
and the X server log file to the report using the file attachment
below, and we can troubleshoot further.


Nils:

Your problem is possibly the same, but may be a different problem
also.  The Intel i810 video driver is strictly limited to using
the video modes built into the VESA BIOS, which on many systems
restricts the available modes considerably.  In many cases for
example, there are laptop displays which are 1400x1050 native
resolution, but the BIOS on board does not support 1400x1050, so
Linux users are stuck using a non-native resolution, or using a
stretched display.  This is a limitation in the video BIOS which
is unavoidable on many laptop LCD panels, and also on DFP displays
connected to Intel video hardware.  If you're using a CRT, the
video mode limitation also applies, however you won't see a stretched
display.


Others who are experiencing problems should try the advice I've
provided to Michael above also.  Your problems may be the same issue,
or may be completely different issues with similar symptoms.

Thanks in advance for your testing.  I'll re-review this report
in the future once the requested files have been attached, and
troubleshoot further.

Comment 10 Mike A. Harris 2004-05-05 22:58:32 EDT
This report and/or one of the other problems reported above, may
be a duplicate of bug #120950.  You may wish to review that report
for comparison/troubleshooting, etc.  Please indicate if you think
it is the same as the issue you're experiencing.

Thanks in advance.
Comment 11 Michael Opdenacker 2004-05-06 10:01:25 EDT
Hi Mike,

I followed your guidelines: upgraded to all available updates
and moved away the /etc/X11/XF86Config file.

However, I couldn't run the below command:

> system-config-display --reconfig
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 412, in ?
    hardware_state.merge_into(xconfig)
NameError: name 'hardware_state' is not defined

So, I just ran:

> system-config-display
* ddcprobe returned bogus values:
ID:   None
Name: None
HorizSync: None
VertSync:  None
                                                                     
          
Trying with card: ATI Radeon Mobility M9

Still had only access to 640x480 (default) and 800x600.

I got the below /etc/X11/xorg.conf file:
http://michaelo.free.fr/issues/display_config_may6_2004/xorg.conf.0

I uncommented stuff in the Monitor section as you suggested and got:
http://michaelo.free.fr/issues/display_config_may6_2004/xorg.conf.1

Then I restarted X and end up with a 640x480 resolution.

Here's the X log file in /var/log before
(http://michaelo.free.fr/issues/display_config_may6_2004/Xorg.0.log.0)
and after restarting X
(http://michaelo.free.fr/issues/display_config_may6_2004/Xorg.0.log.1)

Fortunately, when I ran system-config-display then,
I could select the 1600x1200 resolution.
Here's the X config file that I got:

http://michaelo.free.fr/issues/display_config_may6_2004/xorg.conf.2

... and the X log file after restarting X and getting back to
the correct resolution:
http://michaelo.free.fr/issues/display_config_may6_2004/Xorg.0.log.2

Then, I reran system-config-display and once more
got stuck with only the 640x480 and 800x600 choices.

Sorry for just reporting raw data to you and not really
investigating... I'm pretty busy with other things at the moment.

If you have a fix for the "--reconfig" option, I'll be glad
to try again!

Thanks for everything!

Cheers,

Michael.
Comment 12 Mike A. Harris 2004-05-07 09:43:27 EDT

*** This bug has been marked as a duplicate of 120950 ***
Comment 13 Michael Opdenacker 2004-05-25 04:32:41 EDT
Confirming that this issue no longer happens to me
in FC2 final.

Thanks for everything!

Cheers,

Michael.
Comment 14 Red Hat Bugzilla 2006-02-21 14:02:51 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.