Bug 121955 - network install fails, if network device is via-rhine type
network install fails, if network device is via-rhine type
Status: CLOSED DUPLICATE of bug 120289
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2004-04-29 06:37 EDT by Jirka Jurek
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:02:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jirka Jurek 2004-04-29 06:37:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
If i boot from images/boot.iso cd or using askmethod from normal cd
and choose network install, it pops message, that there is no
available network device to perform this kind of istallation. The
driver is loaded so using ifconfig on second console i can manually
setup eth0 and it works.
I have tryed 2 motherboards (Jetway P4MDPT and Asus A7V8X-X, both VIA
KT400 based boards with integrated via network device) with same result.

My guess is that there is some kind of race condition problem related
to  this driver(via-rhine). It looks like Anaconda checks available
networks devices before via-rhine driver make one available.

As a side note, on second console pump doesn't work on those devices
too. It ends with message:
Traceback (most recent call last):
  File "/usr/bin/pump", line 30, in ?
    ns = isys.pumpNetDevice(iface, None)
  File "/usr/lib/anaconda/isys.py", line 485, in pumpNetDevice
    return _isys.pumpnetdevice(device, klass)
TypeError: argument 2 must be string, not None

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.try network install FC2-test3 using via-rhine based nic

Additional info:
Comment 1 Maxime George-Bourreau 2004-04-29 16:11:52 EDT
Same problem for me, on a acer aspire 1304, with FC2T2 and FC2T3. 
The via-rhine driver seems to be loaded, but anaconda ask for a 
network driver, and I can't install FC2 (FC1 is ok). 
I didn't check the anaconda log, cause I'm new to Fedora Core. 
Comment 2 Barry K. Nathan 2004-05-05 07:16:43 EDT
Me too, on FC-devel from 2004-05-04. eth0 seems to be loaded, but
anaconda somehow doesn't see that. :( (This is a Via C3M266 (I think)
motherboard, CLE266 chipset.)
Comment 3 Jeremy Katz 2004-05-05 18:22:38 EDT

*** This bug has been marked as a duplicate of 120289 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:02:51 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.