Bug 120289 - Installer does not detect ne2k-pci
Installer does not detect ne2k-pci
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
: 120360 121955 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-07 12:05 EDT by Marek Kassur
Modified: 2014-03-16 22:43 EDT (History)
7 users (show)

See Also:
Fixed In Version: 1.1.60-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-10 12:35:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/tmp/anaconda.log (5.20 KB, text/plain)
2004-04-07 22:59 EDT, Marek Kassur
no flags Details
/tmp/syslog (25.10 KB, text/plain)
2004-04-07 23:00 EDT, Marek Kassur
no flags Details
output of python -c 'import kudzu... (202 bytes, text/plain)
2004-04-07 23:01 EDT, Marek Kassur
no flags Details

  None (edit)
Description Marek Kassur 2004-04-07 12:05:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
When trying to install FC2 test2 via ftp installer does not recognize
Compex RL2000 card and prompt for a driver selection, but there is no
ne2k-pci driver on the list. However according to the logs ne2k-pci is
already loaded:

* loaded 8390 from /modules/modules.cgz
* loaded ne2k-pci from /modules/modules.cgz

and

<6>ne2k-pci.c:v1.03 9/22/2003 D. Becker/P. Gortmaker
<7>divert: allocating divert_blk for eth0
<4>eth0: Compex RL2000 found at 0xd800, IRQ 11, 00:80:48:C2:70:32.

Installation goes normally when using other card (e.g. Pcnet32) on
that machine. BTW, the testbox is an i586 SMP 2xP233MMX
Compex RL2000 is my higly-tested card, it works for shure.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot from boot.iso with ne2k-pci compatibile card.
2. Installer can't find network card prompting for a driver.
Comment 1 Miloš Komarčević 2004-04-07 14:29:27 EDT
I have the same problem here with an RTL8129 card, tried with both
test2 and 04/04 development images.
Comment 2 Jeremy Katz 2004-04-07 21:49:35 EDT
So you have a different card in there?  Can you get to the second
stage of the install and switch to tty2 and grab /tmp/anaconda.log,
/tmp/syslog and the output of

# /usr/bin/python -c 'import kudzu; print
kudzu.probe(kudzu.CLASS_NETWORK, kudzu.BUS_UNSPEC, kudzu.PROBE_ALL)'

Comment 3 Marek Kassur 2004-04-07 22:59:50 EDT
Created attachment 99223 [details]
/tmp/anaconda.log
Comment 4 Marek Kassur 2004-04-07 23:00:18 EDT
Created attachment 99224 [details]
/tmp/syslog
Comment 5 Marek Kassur 2004-04-07 23:01:35 EDT
Created attachment 99225 [details]
output of python -c 'import kudzu...
Comment 6 Miloš Komarčević 2004-04-08 07:27:30 EDT
Sorry, my card is RTL8029 (uses ne2k-pci as well), not 8129.
I can't get to stage2 as I don't have another card in my machine but I
suspect it would be more or less the same output. I do see though in
stage1 in tty3 and tty4 that ne2k-pci is loaded and eth0 is up.
Comment 7 Miloš Komarčević 2004-04-19 05:19:34 EDT
Still no dice with 4/18 pxeboot images, but I hope I'll be able to at
least give test3 a spin :)
Comment 8 Marek Kassur 2004-04-28 21:31:20 EDT
Same thing with Test3. Its on the list this time, but still no go.
How about you Milos ?
Comment 9 Miloš Komarčević 2004-04-30 07:24:02 EDT
No success here either with test3's boot.iso
Comment 10 Marek Kassur 2004-05-02 21:08:09 EDT
A wired thing happeded when I add an ne2k-pci to my other test box
(i810 with e100 on-board). It mess up my network settings (re-oreder
ne2k-pci as eth0 and e100 as eth1, but preserve MAC settings). I can
manually setup ne2k-pci using ifconfig, but not e100, don't know why
as e100 module is loaded reporting itself as eth1.
I also discovered that my USB mouse stopped working with an ne2k-pci
controller.
Comment 11 Leonard den Ottolander 2004-05-03 11:52:35 EDT
I am not so sure this is a kudzu bug. My RTL-8029 gets detected fine
according to the output in tty4, it just is not brougth up. Manually
inserting an ISA 3Com Etherlink III also fails. The card is also
recognized, but not brought up.

Maybe ifconfig does not get run? I can't do it manually as there is no
prompt in tty2 yet.
Comment 12 Panu Matilainen 2004-05-04 06:48:15 EDT
I'm seeing the same here (see
http://www.redhat.com/archives/fedora-test-list/2004-April/msg02882.html)
Indeed the card is detected and driver loaded, it's just that anaconda
doesn't think there's anything to install from.

FC2 test2 installed over the network just fine on the same box. 
Comment 13 Leonard den Ottolander 2004-05-04 07:21:10 EDT
See also bug 120360. And forget about the ISA card ;-)

Running "linux rescue" from CD 1 does detect my RTL-8029 and Winbond
ne2k-pci cards and configures them.
Comment 14 Marek Kassur 2004-05-04 12:25:25 EDT
I just want to add to my earlier #10 comment that it's normally
working already installed system using e100 on-board (eth0). It's
messed up by just plug-in an RL2000. Kudzu detect it and ask for
configuration, but then ne2k-pci came up with e100 settings (IP, MAC).
On-board e100 is partially configured as eth1 but refuses to came up:

#ifup eth1
cannot change name of eth0 to eth1: Device or resource busy
interface 'eth0' not found
Device eth1 has different MAC address than expected, ignoring
Comment 15 Jeremy Katz 2004-05-05 18:22:24 EDT
*** Bug 120360 has been marked as a duplicate of this bug. ***
Comment 16 Jeremy Katz 2004-05-05 18:22:46 EDT
*** Bug 121955 has been marked as a duplicate of this bug. ***
Comment 17 Jeremy Katz 2004-05-05 18:24:55 EDT
Fixed in kudzu-1.1.60-1.  The kernel translates the - in the module
name to an _ and thus confuses kudzu's isLoaded() logic.
Comment 18 Marek Kassur 2004-05-08 18:33:51 EDT
There is still something wrong with ne2k-pci, not sure about other
modules with dash in the name. My problem only appear with two or more
NICs, when one of them is ne2k-pci. I tested my system with 3 NICs
adding one by one (e100 is on-board). When I add pcnet32 everything
seems to be ok.
modprobe.conf:
alias eth0 e100
alias eth1 pcnet32

dmesg:
e100: eth0: e100_probe: addr 0xff8fe000, irq 11, MAC addr
00:03:47:12:35:AA
e100: eth0: e100_watchdog: link up, 100Mbps, full-duplex
                           ^^^
pcnet32: PCnet/PCI II 79C970A at 0xdf80, warning: CSR address invalid,
    using instead PROM address of 08 00 06 08 47 37 assigned IRQ 11.
eth1: registered as PCnet/PCI II 79C970A
pcnet32: 1 cards_found.

Then I plug-in ne2k-pci (not connected to hub).
modprobe.conf looks sane for me as well:
alias eth0 e100
alias eth1 pcnet32
alias eth2 ne2k-pci

But dmesg:
eth0: Compex RL2000 found at 0xdf80, IRQ 10, 00:80:48:C2:70:32.
eth1: registered as PCnet/PCI II 79C970A
e100: eth2: e100_probe: addr 0xff8f6000, irq 11, MAC addr
00:03:47:12:35:AA
...
NETDEV WATCHDOG: eth0: transmit timed out
eth0: Tx timed out, cable problem? TSR=0x0, ISR=0x0, t=397.
NETDEV WATCHDOG: eth0: transmit timed out
eth0: Tx timed out, cable problem? TSR=0x0, ISR=0x0, t=553.
NETDEV WATCHDOG: eth0: transmit timed out

May be related to Bug 121860 ?
Could someone else verify this behaviour.

Additional info:
kudzu-1.1.62-1
kernel-2.6.5-1.349
Comment 19 Jeremy Katz 2004-05-10 12:35:01 EDT
That's not related to this bug.  It's instead something on the kernel
side.  Please open a separate bug for tracking this.

Note You need to log in before you can comment on or make changes to this bug.