Bug 1219582 - [abrt] deluge-gtk: torrentview.py:457:update_view:TypeError: value is of the wrong type for this column
Summary: [abrt] deluge-gtk: torrentview.py:457:update_view:TypeError: value is of the ...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: deluge (Show other bugs)
(Show other bugs)
Version: 22
Hardware: i686 Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Cronenworth
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:2d29ac5f9535b9f806fc8861c03...
Keywords:
: 1224437 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-07 17:23 UTC by holzstock
Modified: 2016-04-22 01:49 UTC (History)
4 users (show)

Fixed In Version: deluge-1.3.12-3.fc24 deluge-1.3.12-3.fc23 deluge-1.3.12-3.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-15 21:32:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.57 KB, text/plain)
2015-05-07 17:23 UTC, holzstock
no flags Details
File: environ (2.45 KB, text/plain)
2015-05-07 17:23 UTC, holzstock
no flags Details

Description holzstock 2015-05-07 17:23:24 UTC
Description of problem:
Downloading one torrent, another one was in paused mode. Did not do anything else, other open programs were firefox, thunderbird and transmission

Version-Release number of selected component:
deluge-gtk-1.3.11-1.fc20

Additional info:
reporter:       libreport-2.2.3
cmdline:        deluge-gtk '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' ''
executable:     /usr/bin/deluge-gtk
kernel:         3.19.5-100.fc20.i686+PAE
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
torrentview.py:457:update_view:TypeError: value is of the wrong type for this column

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/deluge/ui/gtkui/torrentview.py", line 457, in update_view
    self.liststore.set(row.iter, *to_update)
TypeError: value is of the wrong type for this column

Local variables in innermost frame:
torrent_id: 'fb9311cb258c2a1dff6beeb6d9b5f3622c53f3a1'
status: {'16b688239934f5fb39c599920b074b04aeddbd48': {'total_wanted': 2099624085L, 'name': u'Cleveland Cavaliers - Chicago Bulls 06.05.15.mkv', 'upload_payload_rate': 0, 'queue': 0, 'state': 'Downloading', 'eta': 0, 'progress': 0.0, 'download_payload_rate': 0}, 'fb9311cb258c2a1dff6beeb6d9b5f3622c53f3a1': {'total_wanted': 3426746368L, 'name': u'CLEvsCHI', 'upload_payload_rate': 0, 'queue': 1, 'state': 'Paused', 'eta': 3413688320L, 'progress': 0.3809999907389283, 'download_payload_rate': 1}}
column_index: [16]
i: 16
torrent_status: {'total_wanted': 3426746368L, 'name': u'CLEvsCHI', 'upload_payload_rate': 0, 'queue': 1, 'state': 'Paused', 'eta': 3413688320L, 'progress': 0.3809999907389283, 'download_payload_rate': 1}
self: <deluge.ui.gtkui.torrentview.TorrentView object at 0x99290ac>
to_update: [20, 3413688320L, 16, 1]
column: u'Down Speed'
row_value: 1
load_new_list: False
torrent_id_in_status: True
fields_to_update: [(3, 'queue'), (4, 'state'), (5, 'name'), (20, 'eta'), (9, 'progress'), (10, 'state'), (6, 'total_wanted'), (17, 'upload_payload_rate'), (16, 'download_payload_rate')]
status_field: 'download_payload_rate'
filter_column: 0
row: <gtk.TreeModelRow object at 0xb533fda0>

Comment 1 holzstock 2015-05-07 17:23:27 UTC
Created attachment 1023219 [details]
File: backtrace

Comment 2 holzstock 2015-05-07 17:23:28 UTC
Created attachment 1023220 [details]
File: environ

Comment 3 Michael Cronenworth 2015-05-23 04:04:14 UTC
*** Bug 1224437 has been marked as a duplicate of this bug. ***

Comment 4 Calum 2015-10-07 22:56:04 UTC
Upstream bug: http://dev.deluge-torrent.org/ticket/2762

A fix for this will be in next release, 1.3.13.

Comment 5 Fedora Update System 2016-04-12 05:17:12 UTC
deluge-1.3.12-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-55e5d566c7

Comment 6 Fedora Update System 2016-04-12 05:18:11 UTC
deluge-1.3.12-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ef5670260f

Comment 7 Fedora Update System 2016-04-12 05:19:02 UTC
deluge-1.3.12-3.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b6ac96d107

Comment 8 Fedora Update System 2016-04-12 10:51:59 UTC
deluge-1.3.12-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-55e5d566c7

Comment 9 Fedora Update System 2016-04-13 08:34:59 UTC
deluge-1.3.12-3.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b6ac96d107

Comment 10 Fedora Update System 2016-04-13 09:26:57 UTC
deluge-1.3.12-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ef5670260f

Comment 11 Fedora Update System 2016-04-15 21:32:46 UTC
deluge-1.3.12-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2016-04-20 19:21:15 UTC
deluge-1.3.12-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2016-04-22 01:49:46 UTC
deluge-1.3.12-3.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.