Bug 1224437 - [abrt] deluge-gtk: torrentview.py:457:update_view:TypeError: value is of the wrong type for this column
Summary: [abrt] deluge-gtk: torrentview.py:457:update_view:TypeError: value is of the ...
Keywords:
Status: CLOSED DUPLICATE of bug 1219582
Alias: None
Product: Fedora
Classification: Fedora
Component: deluge
Version: 21
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Cronenworth
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:2d29ac5f9535b9f806fc8861c03...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-23 01:41 UTC by Steven Jones
Modified: 2015-07-22 16:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-23 04:04:14 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (1.36 KB, text/plain)
2015-05-23 01:42 UTC, Steven Jones
no flags Details
File: environ (1.43 KB, text/plain)
2015-05-23 01:42 UTC, Steven Jones
no flags Details

Description Steven Jones 2015-05-23 01:41:59 UTC
Version-Release number of selected component:
deluge-gtk-1.3.11-1.fc21

Additional info:
reporter:       libreport-2.3.0
cmdline:        deluge-gtk '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' ''
executable:     /usr/bin/deluge-gtk
kernel:         3.17.4-301.fc21.i686
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
torrentview.py:457:update_view:TypeError: value is of the wrong type for this column

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/deluge/ui/gtkui/torrentview.py", line 457, in update_view
    self.liststore.set(row.iter, *to_update)
TypeError: value is of the wrong type for this column

Local variables in innermost frame:
torrent_id: '6c0bdc727aab1a84625c75ffe6ad415d0747a2ae'
status: {'6c0bdc727aab1a84625c75ffe6ad415d0747a2ae': {'total_wanted': 2740275454L, 'name': u'VMware vCenter Server v6.0-[FirstUploads]', 'upload_payload_rate': 0, 'queue': 0, 'state': 'Error', 'eta': 2740275454L, 'progress': 0.0, 'download_payload_rate': 1}}
column_index: [16]
i: 16
torrent_status: {'total_wanted': 2740275454L, 'name': u'VMware vCenter Server v6.0-[FirstUploads]', 'upload_payload_rate': 0, 'queue': 0, 'state': 'Error', 'eta': 2740275454L, 'progress': 0.0, 'download_payload_rate': 1}
self: <deluge.ui.gtkui.torrentview.TorrentView object at 0xb4e38b4c>
to_update: [20, 2740275454L, 16, 1]
column: u'Down Speed'
row_value: 1
load_new_list: False
torrent_id_in_status: True
fields_to_update: [(3, 'queue'), (4, 'state'), (5, 'name'), (20, 'eta'), (9, 'progress'), (10, 'state'), (6, 'total_wanted'), (17, 'upload_payload_rate'), (16, 'download_payload_rate')]
status_field: 'download_payload_rate'
filter_column: 0
row: <gtk.TreeModelRow object at 0xae2ebb40>

Potential duplicate: bug 1219582

Comment 1 Steven Jones 2015-05-23 01:42:02 UTC
Created attachment 1028964 [details]
File: backtrace

Comment 2 Steven Jones 2015-05-23 01:42:04 UTC
Created attachment 1028965 [details]
File: environ

Comment 3 Michael Cronenworth 2015-05-23 04:04:14 UTC

*** This bug has been marked as a duplicate of bug 1219582 ***


Note You need to log in before you can comment on or make changes to this bug.