Bug 121962 - automake-1.4 is marked as requirement everytime even if it isn't needed
Summary: automake-1.4 is marked as requirement everytime even if it isn't needed
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 125755
TreeView+ depends on / blocked
 
Reported: 2004-04-29 11:33 UTC by Robert Scheck
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-03 23:01:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Scheck 2004-04-29 11:33:58 UTC
Description of problem:
automake 1.4 is everytime marked as a requirement even it isn't 
needed (so automake is only used at s390 systems for disabling
some documentation).

Version-Release number of selected component (if applicable):
fontconfig-2.2.1-10

How reproducible & Steps to Reproduce:
Everytime, rebuild fontconfig on a non-s390 system and you see, that 
automake isn't used and also shouldn't be marked as a requirement.
I personally use the patch below, which works for me.
  
Actual results:
--- fontconfig.spec        2004-04-19 18:03:52.000000000 +0200
+++ fontconfig.spec.rsc    2004-04-29 13:18:02.000000000 +0200
@@ -39,8 +39,9 @@
 BuildRequires: expat-devel
 BuildRequires: perl
 # For nodocs patch
+%if %{disable_docs}
 BuildRequires: /usr/bin/automake-1.4
-
+%endif
 PreReq: freetype >= %{freetype_version}

 %description

Expected results:
A solution like mine or better ;-)

Comment 1 Owen Taylor 2004-08-03 23:01:28 UTC
I don't think a conditionalized dependency on architecture
makes sense, so I'm not going to fix this. (Though I'm going
to try removing the disabling of docs on s390 in the next build
which would make this irrelevant.)



Note You need to log in before you can comment on or make changes to this bug.