Bug 125755 - fontconfig 2.2.3 is released
fontconfig 2.2.3 is released
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
http://freedesktop.org/Software/FontC...
:
Depends On: 121962 125745
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-10 17:02 EDT by Robert Scheck
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-04 16:52:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2004-06-10 17:02:09 EDT
Description of problem:
fontconfig 2.2.2 was released at March 10, 2004 and Fedora 
Development is hanging around the older 2.2.1. For more information 
have a look to the changelog.

Version-Release number of selected component (if applicable):
fontconfig-2.2.1-10

Actual results:
Here's the diff from that what I did and what is working for me:

--- snipp ---
--- fontconfig.spec       2004-04-19 18:03:52.000000000 +0200
+++ fontconfig.spec.rsc   2004-06-10 22:54:15.000000000 +0200
@@ -1,4 +1,4 @@
-%define freetype_version 2.1.7
+%define freetype_version 2.1.8

 # Workaround for broken jade on s390, remove all disable_docs
 # handling once https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=97079
@@ -11,12 +11,12 @@

 Summary: Font configuration and customization library
 Name: fontconfig
-Version: 2.2.1
-Release: 10
+Version: 2.2.2
+Release: 1
 License: MIT
 Group: System Environment/Libraries
-Source: http://fontconfig.org/release/fontconfig-%{version}.tar.gz
-URL: http://fontconfig.org
+Source: http://freedesktop.org/~fontconfig/release/%{name}-%{version}.tar.gz
+URL: http://freedesktop.org/software/fontconfig
 BuildRoot: %{_tmppath}/%{name}-%{version}-root

 Patch1: fontconfig-defaultconfig.patch
@@ -27,10 +27,6 @@
 Patch13: fontconfig-2.1-fulldir.patch
 # Turn off doc generation since it doesn't work on s390 at the moment
 Patch14: fontconfig-nodocs.patch
-# Don't read from/write to NULL cache files
-Patch15: fontconfig-2.2.1-cache.patch
-# Fix freetype includes to work with recent FreeType versions
-Patch16: fontconfig-2.2.1-ftinclude.patch
 # Remove timestamp from fonts.conf
 # http://freedesktop.org/cgi-bin/bugzilla/show_bug.cgi?id=505
 Patch17: fontconfig-2.2.1-notimestamp.patch
@@ -39,8 +35,9 @@
 BuildRequires: expat-devel
 BuildRequires: perl
 # For nodocs patch
+%if %{disable_docs}
 BuildRequires: /usr/bin/automake-1.4
-
+%endif
 PreReq: freetype >= %{freetype_version}

 %description
@@ -76,9 +73,6 @@
 %patch14 -p1 -b .nodocs
 %endif

-%patch15 -p1 -b .cache
-%patch16 -p1 -b .ftinclude
-
 %build

 %if %{disable_docs}
@@ -164,6 +158,10 @@
 %endif

 %changelog
+* Thu Jun 10 2004 Robert Scheck <redhat@linuxnetz.de> 2.2.2-1
+- Upgrade to 2.2.2 and some spec file cleanup
+- Changed the automake requirement (#121962)
+
 * Mon Apr 19 2004 Owen Taylor <otaylor@redhat.com> 2.2.1-10
 - Require recent freetype (#109592, Peter Oliver)
 - Remove fonts.conf timestamp to fix multiarch conflict (#118182)
--- snapp ---

Expected results:
Upgrade to 2.2.2 ;-)

Additional info:
Patch 15 and 16 aren't no longer needed, they are already in 
upstream included.

This diff also contains my expected solution for bug #121962.
Comment 1 John Thacker 2004-07-12 13:23:33 EDT
2.2.3 is released now, with a couple more fixes.
Comment 2 Robert Scheck 2004-07-13 09:45:48 EDT
Thank you here also...a simple upgrade from 2.2.2 to 2.2.3 worked very
well for me :)
Comment 3 Owen Taylor 2004-08-04 16:52:41 EDT
* Tue Aug  3 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-1
- Upgrade to 2.2.3
- Convert man pages to UTF-8 (#108730, Peter van Egdom)
- Renable docs on s390

Note You need to log in before you can comment on or make changes to this bug.