Bug 1219732 - brick-op failure for glusterd command should log error message in cmd_history.log
Summary: brick-op failure for glusterd command should log error message in cmd_history...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Atin Mukherjee
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1223318
TreeView+ depends on / blocked
 
Reported: 2015-05-08 04:29 UTC by Atin Mukherjee
Modified: 2016-06-16 12:59 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1223318 (view as bug list)
Environment:
Last Closed: 2016-06-16 12:59:33 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Atin Mukherjee 2015-05-08 04:29:23 UTC
Description of problem:

In glusterd brick-op if underlying transport connection is broken between glusterd and brick, then the command fails with a blank error message

Version-Release number of selected component (if applicable):
Mainline

How reproducible:
Always

Steps to Reproduce:
1.Create a volume & start it
2. Take the glusterd process in gdb and put a break point in gd_syncop_submit_request () and continue
3. Stop the volume
3. the breakpoint will be hit, and set to ret to -1 after rpc_clnt_submit () is executed

Actual results:
In cmd_history.log the command will be logged as failed with no error message

Expected results:
error message should be logged.

Additional info:

Comment 1 Anand Avati 2015-05-08 04:30:38 UTC
REVIEW: http://review.gluster.org/10659 (glusterd: populate errstr if gd_syncop_submit_request fails) posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 2 Anand Avati 2015-05-08 06:40:45 UTC
REVIEW: http://review.gluster.org/10659 (glusterd: populate errstr if gd_syncop_submit_request fails) posted (#2) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 3 Anand Avati 2015-05-20 09:30:34 UTC
COMMIT: http://review.gluster.org/10659 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 988db25572b94220a7cc69bcc3040c2a77b8e9a5
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Fri May 8 09:53:50 2015 +0530

    glusterd: populate errstr if gd_syncop_submit_request fails
    
    Change-Id: Ie4a3edef5d553fc07de53b46f9485c46a4305245
    BUG: 1219732
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/10659
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: Krishnan Parthasarathi <kparthas@redhat.com>

Comment 4 Nagaprasad Sathyanarayana 2015-10-25 14:53:45 UTC
Fix for this bug is already made in a GlusterFS release. The cloned BZ has details of the fix and the release. Hence closing this mainline BZ.

Comment 5 Nagaprasad Sathyanarayana 2015-10-25 15:03:07 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 6 Niels de Vos 2016-06-16 12:59:33 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.