Bug 1219792 - On successful completion of upgrade, katello-installer.log ends with Error: <NilClass> nil
Summary: On successful completion of upgrade, katello-installer.log ends with Error: ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Upgrades
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Stephen Benjamin
QA Contact: Sachin Ghai
Russell Dickenson
URL:
Whiteboard:
Depends On:
Blocks: sat61-release-notes 1195450
TreeView+ depends on / blocked
 
Reported: 2015-05-08 09:57 UTC by Sachin Ghai
Modified: 2019-06-13 21:25 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
Issue: After a successful Satellite upgrade, you may see the following error message in the `installer.log` log file. This error message can be safely ignored and will be resolved in a future release. --- ERROR 2015-05-08 04:45:27 main] Repeating errors encountered during run: [ERROR 2015-05-08 04:45:27 main] <NilClass> nil --- Workaround: None at this time.
Clone Of:
Environment:
Last Closed: 2015-10-15 18:20:06 UTC


Attachments (Terms of Use)
foreman-debug logs (562.59 KB, application/x-xz)
2015-05-08 09:57 UTC, Sachin Ghai
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1911 normal SHIPPED_LIVE Satellite 6.1.3 bug fix update 2015-10-15 22:19:19 UTC

Description Sachin Ghai 2015-05-08 09:57:11 UTC
Created attachment 1023444 [details]
foreman-debug logs

Description of problem:
I was trying upgrade from sat6.0.8 --> sat6.1 GA snap3 compose2 on rhel66. Upgrade completed successfully and installer.log ends with an error:

--
[ INFO 2015-05-08 04:45:27 main] Katello upgrade completed!
[DEBUG 2015-05-08 04:45:27 main] Hook /usr/share/katello-installer/hooks/post/30-upgrade.rb returned [<Logging::Logger:0x3fb3514f24e8 name="main">, <Logging::Logger:0x3fb3514ae5f4 name="fatal">]
[ INFO 2015-05-08 04:45:27 main] All hooks in group post finished
[DEBUG 2015-05-08 04:45:27 main] Exit with status code: 2 (signal was 2)
[ERROR 2015-05-08 04:45:27 main] Repeating errors encountered during run:
[ERROR 2015-05-08 04:45:27 main] <NilClass> nil
[DEBUG 2015-05-08 04:45:27 main] Cleaning /etc/katello-installer/d20150508-21877-51r30s
[DEBUG 2015-05-08 04:45:27 main] Cleaning /tmp/default_values.yaml
--

I didn't see any other error in logs. I tried upgrade two times and everytime hit with error.

Version-Release number of selected component (if applicable):
upgrade from sat6.0.8 --> sat6.1 GA snap3 compose2 on rhel66

How reproducible:
always

Steps to Reproduce:
1. Install sat6.0.8
2. disable sat6.0.8 repo
3. enable sat6.1 repo
4. katello-service stop
5. service-wait mongod start
6. yum update -y
7. katello-installer --upgrade

Actual results:
Error in katello-installer.log:

ERROR 2015-05-08 04:45:27 main] Repeating errors encountered during run:
[ERROR 2015-05-08 04:45:27 main] <NilClass> nil


Expected results:
shouldn't be any error in logs

Additional info:
upgrade succeeded as per stdout messages:

[root@sat yum.repos.d]# katello-installer --upgrade
Upgrading...
Upgrade Step: stop_services...
Upgrade Step: start_mongo...
Upgrade Step: migrate_pulp...
Upgrade Step: migrate_candlepin...
Upgrade Step: migrate_foreman...
Upgrade Step: Running installer...
Installing             Done                                               [100%] [..................................................................]
  The full log is at /var/log/katello-installer/katello-installer.log
Upgrade Step: Restarting services...
Upgrade Step: db:seed...
Upgrade Step: Running errata import task (this may take a while)...
Katello upgrade completed!

Comment 3 Brad Buckingham 2015-07-10 15:14:30 UTC
Can you check to see if this error still occurs on latest snap?

Comment 4 Sachin Ghai 2015-07-14 06:08:36 UTC
yes, I can see the reported error with latest sat6.1.1 snap12.

[root@cloud-qe-17 ~]# tail -f /var/log/katello-installer/katello-installer.log 
[DEBUG 2015-07-10 09:06:30 main] Updating Expire Metadata for Custom Content

[ INFO 2015-07-10 09:06:30 main] Katello upgrade completed!
[DEBUG 2015-07-10 09:06:30 main] Hook /usr/share/katello-installer/hooks/post/30-upgrade.rb returned [<Logging::Logger:0x3f966200c4e4 name="main">, <Logging::Logger:0x3f9660a19164 name="fatal">]
[ INFO 2015-07-10 09:06:30 main] All hooks in group post finished
[DEBUG 2015-07-10 09:06:30 main] Exit with status code: 2 (signal was 2)
[ERROR 2015-07-10 09:06:30 main] Repeating errors encountered during run:
[ERROR 2015-07-10 09:06:30 main] <NilClass> nil
[DEBUG 2015-07-10 09:06:30 main] Cleaning /etc/katello-installer/d20150710-18216-dus36r
[DEBUG 2015-07-10 09:06:30 main] Cleaning /tmp/default_values.yaml

Comment 9 Marek Hulan 2015-09-10 12:53:31 UTC
I was unable to reproduce with last version, Sachin will retest and provide a reproducer if he encounter the issue again.

Comment 10 Sachin Ghai 2015-09-14 11:34:06 UTC
Yeah.. I tried upgrade from sat6.0.8 -> latest sat6.1.2 snap1 compose3 on rhel67.

This time error changed:  

----
[ INFO 2015-09-14 07:29:00 main] Katello upgrade completed!
[DEBUG 2015-09-14 07:29:00 main] Hook /usr/share/katello-installer/hooks/post/30-upgrade.rb returned [<Logging::Logger:0x3fba60c32d14 name="main">, <Logging::Logger:0x3fba60c1c348 name="fatal">]
[ INFO 2015-09-14 07:29:00 main] All hooks in group post finished
[DEBUG 2015-09-14 07:29:00 main] Exit with status code: 2 (signal was 2)
[ERROR 2015-09-14 07:29:00 main] Repeating errors encountered during run:
[ERROR 2015-09-14 07:29:00 main] httpd is stopped

[DEBUG 2015-09-14 07:29:00 main] Cleaning /etc/katello-installer/d20150914-19385-1qx6f9b
[DEBUG 2015-09-14 07:29:00 main] Cleaning /tmp/default_values.yaml
-----


In short, I didn't get  

<NilClass> nil

instead

I got httpd is stopped

Comment 11 Sachin Ghai 2015-09-14 11:34:59 UTC
On console, it was completed successfully,

Complete!
[root@cloud-qe-1 yum.repos.d]# katello-installer --upgrade
Upgrading...
Upgrade Step: stop_services...
Upgrade Step: start_mongo...
Upgrade Step: migrate_pulp...
Upgrade Step: start_httpd...
Upgrade Step: migrate_candlepin...
Upgrade Step: migrate_foreman...
Upgrade Step: Running installer...
Installing             Done                                               [100%] [..................................................................]
  The full log is at /var/log/katello-installer/katello-installer.log
Upgrade Step: restart_services...
Upgrade Step: db_seed...
Upgrade Step: errata_import (this may take a while) ...
Upgrade Step: update_gpg_urls (this may take a while) ...
Upgrade Step: update_repository_metadata (this may take a while) ...
Katello upgrade completed!
[root@cloud-qe-1 yum.repos.d]#

Comment 12 Sachin Ghai 2015-09-14 11:38:20 UTC
And we already filed an issue for httpd error as per comment 10.

https://bugzilla.redhat.com/show_bug.cgi?id=1245998

Comment 13 Sachin Ghai 2015-10-06 11:36:56 UTC
Verified with sat6.1.3

I upgraded setup from sat6.0.8 -> sat6.1.3. Upgrade completed and I didn't find the reported error: <NilClass> nil

katello-installer.log:
-----------------------

[ INFO 2015-10-06 07:31:06 main] Katello upgrade completed!
[DEBUG 2015-10-06 07:31:06 main] Hook /usr/share/katello-installer/hooks/post/30-upgrade.rb returned [<Logging::Logger:0x3fefc65ea560 name="main">, <Logging::Logger:0x3fefc6ddbe54 name="fatal">]
[ INFO 2015-10-06 07:31:06 main] All hooks in group post finished
[DEBUG 2015-10-06 07:31:06 main] Exit with status code: 2 (signal was 2)
[ERROR 2015-10-06 07:31:06 main] Repeating errors encountered during run:
[ERROR 2015-10-06 07:31:06 main] httpd is stopped


For httpd error, another bz is already filed as mentioned in comment 12

Moving this bz to verified.

Comment 15 errata-xmlrpc 2015-10-15 18:20:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1911


Note You need to log in before you can comment on or make changes to this bug.