Bug 1219841 - [RFE] vioscsi.sys should support MS Cluster Services
Summary: [RFE] vioscsi.sys should support MS Cluster Services
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Vadim Rozenfeld
QA Contact: Virtualization Bugs
URL:
Whiteboard: storage
: 1190965 (view as bug list)
Depends On: 1338043
Blocks: 1203710 1305606 1313485 1195140 1288337
TreeView+ depends on / blocked
 
Reported: 2015-05-08 13:02 UTC by Paolo Bonzini
Modified: 2017-02-21 04:03 UTC (History)
37 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
The vioscsi.sys file is now compatible with Microsoft Cluster Services, which enables the Windows virtio-scsi driver to support Windows Server Failover Clustering (WSFC) using shared storage. As a result, vioscsi.sys can pass all tests in the "Validate a Configuration" process.
Clone Of: 1195140
: 1338043 (view as bug list)
Environment:
Last Closed: 2016-11-04 08:45:28 UTC
Target Upstream Version:


Attachments (Terms of Use)
MS Failover Clustering configuration and validation guideline. (900.65 KB, application/pdf)
2016-06-16 11:58 UTC, Vadim Rozenfeld
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2937021 None None None 2017-02-21 04:03:41 UTC
Red Hat Product Errata RHBA-2016:2609 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2016-11-03 15:27:12 UTC

Comment 2 Yaniv Lavi 2015-07-07 06:56:05 UTC
any updates on this?

Comment 3 Vadim Rozenfeld 2015-07-07 07:25:24 UTC
(In reply to Yaniv Dary from comment #2)
> any updates on this?

Yes, we did some research regarding to adding Failover Clustering support. It will require some changes from qemu side, not only vioscsi Windows driver. I've started collecting the list of changes that need to be done from the both sides.

Comment 4 Yaniv Lavi 2015-07-07 07:39:36 UTC
(In reply to Vadim Rozenfeld from comment #3)
> (In reply to Yaniv Dary from comment #2)
> > any updates on this?
> 
> Yes, we did some research regarding to adding Failover Clustering support.
> It will require some changes from qemu side, not only vioscsi Windows
> driver. I've started collecting the list of changes that need to be done
> from the both sides.

Please block this bug on any new RFEs opened.

Comment 5 Yaniv Lavi 2015-08-06 12:48:06 UTC
(In reply to Yaniv Dary from comment #4)
> (In reply to Vadim Rozenfeld from comment #3)
> > (In reply to Yaniv Dary from comment #2)
> > > any updates on this?
> > 
> > Yes, we did some research regarding to adding Failover Clustering support.
> > It will require some changes from qemu side, not only vioscsi Windows
> > driver. I've started collecting the list of changes that need to be done
> > from the both sides.
> 
> Please block this bug on any new RFEs opened.

any update?

Comment 6 Vadim Rozenfeld 2015-08-07 00:50:41 UTC
(In reply to Yaniv Dary from comment #5)
> (In reply to Yaniv Dary from comment #4)
> > (In reply to Vadim Rozenfeld from comment #3)
> > > (In reply to Yaniv Dary from comment #2)
> > > > any updates on this?
> > > 
> > > Yes, we did some research regarding to adding Failover Clustering support.
> > > It will require some changes from qemu side, not only vioscsi Windows
> > > driver. I've started collecting the list of changes that need to be done
> > > from the both sides.
> > 
> > Please block this bug on any new RFEs opened.
> 
> any update?

The decision was made to postpone the MS Failover Clustering implementation to RHEL 7.3 time frame.

Comment 12 Vadim Rozenfeld 2016-05-30 03:09:00 UTC
virtio-scsi driver from our latest "unofficial" build (available from 
http://download.eng.bos.redhat.com/brewroot/packages/virtio-win10-prewhql/1/17/win/virtio-win10-prewhql-1.zip)
can satisfy MS failover clustering storage validation test requirements and should operate properly in failover clustering setup. I succeeded with building two-node WS2012R2 viostor-based cluster on top of iscsi target. But it is not enough because we would like to see how it works on top of real SAS-HBA or SAN, which fully complains with SCSI-3 Persistent Reservation requirements, and wonder if QE can arrange such kind of setup for the future testing.

Thanks,
Vadim.

Comment 13 juzhang 2016-05-30 03:43:24 UTC
Hi Yu,

Could you handle comment12?

Best Regards,
Junyi

Comment 14 Yu Wang 2016-06-01 08:08:12 UTC
(In reply to Vadim Rozenfeld from comment #12)
> virtio-scsi driver from our latest "unofficial" build (available from 
> http://download.eng.bos.redhat.com/brewroot/packages/virtio-win10-prewhql/1/
> 17/win/virtio-win10-prewhql-1.zip)
> can satisfy MS failover clustering storage validation test requirements and
> should operate properly in failover clustering setup. I succeeded with
> building two-node WS2012R2 viostor-based cluster on top of iscsi target. But
> it is not enough because we would like to see how it works on top of real
> SAS-HBA or SAN, which fully complains with SCSI-3 Persistent Reservation
> requirements, and wonder if QE can arrange such kind of setup for the future
> testing.
> 
> Thanks,
> Vadim.

Hi Vadim,

QE have researched something about MS failover clustering, but we have some question about that.

1  What does "viostor-based cluster on top of iscsi target" mean? As this is a vioscsi related feature.

2 We are not sure if our environment can satisfy the requirement, can you list us the device we need to prepare on top of real SAS-HBA or SAN?

3 We have search some docs on msft, https://technet.microsoft.com/en-us/library/jj612869%28v=ws.11%29.aspx, https://technet.microsoft.com/en-us/library/jj134244%28v=ws.11%29.aspx, but we are confused with these settings, do you have a more clear doc or maybe you have written a setup guide.

Thanks
Yu Wang

Comment 15 Vadim Rozenfeld 2016-06-01 09:13:24 UTC
(In reply to wangyu from comment #14)
> (In reply to Vadim Rozenfeld from comment #12)
> > virtio-scsi driver from our latest "unofficial" build (available from 
> > http://download.eng.bos.redhat.com/brewroot/packages/virtio-win10-prewhql/1/
> > 17/win/virtio-win10-prewhql-1.zip)
> > can satisfy MS failover clustering storage validation test requirements and
> > should operate properly in failover clustering setup. I succeeded with
> > building two-node WS2012R2 viostor-based cluster on top of iscsi target. But
> > it is not enough because we would like to see how it works on top of real
> > SAS-HBA or SAN, which fully complains with SCSI-3 Persistent Reservation
> > requirements, and wonder if QE can arrange such kind of setup for the future
> > testing.
> > 
> > Thanks,
> > Vadim.
> 
> Hi Vadim,
> 
> QE have researched something about MS failover clustering, but we have some
> question about that.
> 
> 1  What does "viostor-based cluster on top of iscsi target" mean? As this is
> a vioscsi related feature.
> 
> 2 We are not sure if our environment can satisfy the requirement, can you
> list us the device we need to prepare on top of real SAS-HBA or SAN?
> 
> 3 We have search some docs on msft,
> https://technet.microsoft.com/en-us/library/jj612869%28v=ws.11%29.aspx,
> https://technet.microsoft.com/en-us/library/jj134244%28v=ws.11%29.aspx, but
> we are confused with these settings, do you have a more clear doc or maybe
> you have written a setup guide.
> 
> Thanks
> Yu Wang

Hi Yu Wang,

1. I used Linux-IO Target (http://linux-iscsi.org/wiki/LIO) iSCSI as a target for building and testing MS Failover Clustering setup. Preparing such kind of setup we can make qemu communicating iSCSI target over virtio-scsi device.
(Something like this:
-drive file=iscsi://192.168.1.200:3260/iqn.2016-03.local.server:sas/0,if=none,media=disk,format=raw,rerror=stop,werror=stop,readonly=off,aio=threads,cache=none,cache.direct=on,id=drive-hotadd,serial=sas-test -device virtio-scsi-pci,id=scsi-hotadd -device scsi-block,drive=drive-hotadd,id=hotadd,bus=scsi-hotadd.0,bootindex=2
As you can see it is not different from a "normal" iSCSI target over virtio-scsi)

2. I'm not sure, but how QE usually check Linux clustering? I suppose that it requires some sort of SAS or SAN storage, which QE probably owns already. 

3. Well, I can try preparing some sort of document describing the steps that I did building by two-node cluster. It will probably take couple of days or more.

Meanwhile, can we arrange some preliminary HCK testing, as well as checking how vioscsi driver upgrade and downgrade procedures work?
We need to know about upgrade and downgrade procedure results asap mostly because the bustype parameter has been changed to satisfy MS Failover Clustering requirements, and it can have some undesirables side effect.  

Thanks,
Vadim.

Comment 16 Yu Wang 2016-06-01 10:14:26 UTC
(In reply to Vadim Rozenfeld from comment #15)
> (In reply to wangyu from comment #14)
> > (In reply to Vadim Rozenfeld from comment #12)
> > > virtio-scsi driver from our latest "unofficial" build (available from 
> > > http://download.eng.bos.redhat.com/brewroot/packages/virtio-win10-prewhql/1/
> > > 17/win/virtio-win10-prewhql-1.zip)
> > > can satisfy MS failover clustering storage validation test requirements and
> > > should operate properly in failover clustering setup. I succeeded with
> > > building two-node WS2012R2 viostor-based cluster on top of iscsi target. But
> > > it is not enough because we would like to see how it works on top of real
> > > SAS-HBA or SAN, which fully complains with SCSI-3 Persistent Reservation
> > > requirements, and wonder if QE can arrange such kind of setup for the future
> > > testing.
> > > 
> > > Thanks,
> > > Vadim.
> > 
> > Hi Vadim,
> > 
> > QE have researched something about MS failover clustering, but we have some
> > question about that.
> > 
> > 1  What does "viostor-based cluster on top of iscsi target" mean? As this is
> > a vioscsi related feature.
> > 
> > 2 We are not sure if our environment can satisfy the requirement, can you
> > list us the device we need to prepare on top of real SAS-HBA or SAN?
> > 
> > 3 We have search some docs on msft,
> > https://technet.microsoft.com/en-us/library/jj612869%28v=ws.11%29.aspx,
> > https://technet.microsoft.com/en-us/library/jj134244%28v=ws.11%29.aspx, but
> > we are confused with these settings, do you have a more clear doc or maybe
> > you have written a setup guide.
> > 
> > Thanks
> > Yu Wang
> 
> Hi Yu Wang,
> 
> 1. I used Linux-IO Target (http://linux-iscsi.org/wiki/LIO) iSCSI as a
> target for building and testing MS Failover Clustering setup. Preparing such
> kind of setup we can make qemu communicating iSCSI target over virtio-scsi
> device.
> (Something like this:
> -drive
> file=iscsi://192.168.1.200:3260/iqn.2016-03.local.server:sas/0,if=none,
> media=disk,format=raw,rerror=stop,werror=stop,readonly=off,aio=threads,
> cache=none,cache.direct=on,id=drive-hotadd,serial=sas-test -device
> virtio-scsi-pci,id=scsi-hotadd -device
> scsi-block,drive=drive-hotadd,id=hotadd,bus=scsi-hotadd.0,bootindex=2
> As you can see it is not different from a "normal" iSCSI target over
> virtio-scsi)
> 
> 2. I'm not sure, but how QE usually check Linux clustering? I suppose that
> it requires some sort of SAS or SAN storage, which QE probably owns already. 
> 

We will contact other QE to solve this.

> 3. Well, I can try preparing some sort of document describing the steps that
> I did building by two-node cluster. It will probably take couple of days or
> more.
> 
It is very helpful.

> Meanwhile, can we arrange some preliminary HCK testing, as well as checking
> how vioscsi driver upgrade and downgrade procedures work?
> We need to know about upgrade and downgrade procedure results asap mostly
> because the bustype parameter has been changed to satisfy MS Failover
> Clustering requirements, and it can have some undesirables side effect.  
> 
Sure, which system does it affect? Only test on win2008R2,win2012 and win2012R2 is OK? or adding win2016 and other system?

> Thanks,
> Vadim.

Comment 17 Vadim Rozenfeld 2016-06-01 10:25:38 UTC
(In reply to wangyu from comment #16)
> > Meanwhile, can we arrange some preliminary HCK testing, as well as checking
> > how vioscsi driver upgrade and downgrade procedures work?
> > We need to know about upgrade and downgrade procedure results asap mostly
> > because the bustype parameter has been changed to satisfy MS Failover
> > Clustering requirements, and it can have some undesirables side effect.  
> > 
> Sure, which system does it affect? Only test on win2008R2,win2012 and
> win2012R2 is OK? or adding win2016 and other system?
> 

I think we can start with WS2012R2

Best regards,
Vadim.

> > Thanks,
> > Vadim.

Comment 18 Yu Wang 2016-06-02 03:08:34 UTC
Hi Vadim,

QE have arranged some preliminary HCK testing on WS2012R2, all these preliminary HCK tests have been passed. Testing jobs refer to the attachment.

And upgrade and downgrade driver(build102/117 upgrade to  build 118 and build118 downgrade to build102/117) is passed.

QE found that there are 5 more cases in HCK :
* Bus Reset Test
* Lun Reset Test With Outstanding IO -All Disks
* Lun Reset Test With Outstanding IO -Single Disk
* Lun Reset Test Without Outstanding IO -All Disks
* Lun Reset Test Without Outstanding IO -Single Disk

Is that for MS Clustering Services?


Thanks
Yu Wang

Comment 20 Vadim Rozenfeld 2016-06-02 06:52:06 UTC
Hi Yu Wang,

I'm really sorry for being unclear when asking whan asking for HCK and upgrade/downgrade testing. For all these tests we need to use vioscsi driver from Win10 build available at http://download.eng.bos.redhat.com/brewroot/packages/virtio-win10-prewhql/1/17/win/virtio-win10-prewhql-1.zip

Sorry again, and yes this driver should be able satisfy MS Failofer Clustering 
requirements.

Best regards,
Vadim.

Comment 21 Yu Wang 2016-06-02 14:39:49 UTC
Hi Vadim,

Thanks for correct.

QE have retested upgrade and downgrade driver(virtio-win1.8.0-4 upgrade to  virtio-win10-prewhql-17 and virtio-win10-prewhql-17 downgrade to virtio-win1.8.0-4) is *passed*.

And for preliminary HCK testing on WS2012R2, all these have been "passed". Testing jobs refer to the attachment2 [details].


Thanks
Yu Wang

Comment 23 Vadim Rozenfeld 2016-06-02 22:10:38 UTC
(In reply to wangyu from comment #21)
> Hi Vadim,
> 
> Thanks for correct.
> 
> QE have retested upgrade and downgrade driver(virtio-win1.8.0-4 upgrade to 
> virtio-win10-prewhql-17 and virtio-win10-prewhql-17 downgrade to
> virtio-win1.8.0-4) is *passed*.
> 
> And for preliminary HCK testing on WS2012R2, all these have been "passed".
> Testing jobs refer to the attachment2 [details].
> 
> 
> Thanks
> Yu Wang

Many thanks, it looks very promising.
I should be able to prepare some Failover Clustering installation guild by mid of the next week.

Best regards,
Vadim.

Comment 32 Vadim Rozenfeld 2016-06-16 11:58:13 UTC
Created attachment 1168707 [details]
MS Failover Clustering configuration and validation guideline.

Very preliminary MS Failover Clustering configuration and validation guideline.

Comment 44 Vadim Rozenfeld 2016-07-04 03:40:46 UTC
*** Bug 1190965 has been marked as a duplicate of this bug. ***

Comment 51 lijin 2016-08-26 01:50:04 UTC
change status to verified according to comment#37 and comment#40

Comment 63 errata-xmlrpc 2016-11-04 08:45:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2609.html

Comment 64 Peixiu Hou 2016-11-30 05:38:25 UTC
Hi vadim,

(In reply to Vadim Rozenfeld from comment #6)
> > > >any updates on this?

> The decision was made to postpone the MS Failover Clustering implementation
> to RHEL 7.3 time frame.

We are running the vioscsi function tests on rhel6.9. Please help to confirm if this feature is supported on rhel6.9? Thanks a lot~

Best Regards~
Peixiu Hou

Comment 65 Vadim Rozenfeld 2016-12-01 13:46:01 UTC
(In reply to Peixiu Hou from comment #64)
> Hi vadim,
> 
> (In reply to Vadim Rozenfeld from comment #6)
> > > > >any updates on this?
> 
> > The decision was made to postpone the MS Failover Clustering implementation
> > to RHEL 7.3 time frame.
> 
> We are running the vioscsi function tests on rhel6.9. Please help to confirm
> if this feature is supported on rhel6.9? Thanks a lot~
> 

Unfortunately, MS Clustering will not work on rhel6.9 even with the latest vioscsi driver. MS Clustering needs some additional changes in qemu which 
probably will not be backported to rhel6.9 

Best regards,
Vadim.

> Best Regards~
> Peixiu Hou

Comment 66 Peixiu Hou 2016-12-02 02:40:51 UTC
(In reply to Vadim Rozenfeld from comment #65)
> (In reply to Peixiu Hou from comment #64)
> > Hi vadim,
> > 
> > (In reply to Vadim Rozenfeld from comment #6)
> > > > > >any updates on this?
> > 
> > > The decision was made to postpone the MS Failover Clustering implementation
> > > to RHEL 7.3 time frame.
> > 
> > We are running the vioscsi function tests on rhel6.9. Please help to confirm
> > if this feature is supported on rhel6.9? Thanks a lot~
> > 
> 
> Unfortunately, MS Clustering will not work on rhel6.9 even with the latest
> vioscsi driver. MS Clustering needs some additional changes in qemu which 
> probably will not be backported to rhel6.9 
> 
OK, got it, thanks a lot~~
> 
> > Best Regards~
> > Peixiu Hou


Note You need to log in before you can comment on or make changes to this bug.