Bug 1220024 - Can't change touchpad behavior in X Gnome session using control center
Summary: Can't change touchpad behavior in X Gnome session using control center
Keywords:
Status: CLOSED DUPLICATE of bug 1206961
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-09 08:56 UTC by yvan.masson
Modified: 2015-05-17 09:50 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-17 09:50:51 UTC


Attachments (Terms of Use)

Description yvan.masson 2015-05-09 08:56:16 UTC
Hi,

On a fresh install of Fedora 22 (and updates), I just hit the same bug as https://bugzilla.redhat.com/show_bug.cgi?id=1181565#c7

As I did not find a bug report for this specific issue, I write it here.

xorg-x11-drv-libinput is version 0.9.0 revision 1.fc22.

On the default session (Gnome on X), none of the touchpad settings in gnome-control-center can be set: you can move the speed cursors, tick the boxes, but it does not change the touchpad behavior.
However, this works using the Wayland session (which is for now not a good solution because then I can't copy and paste between applications).

As asked Hans de Goede in https://bugzilla.redhat.com/show_bug.cgi?id=1181565#c8, here are some information gathered with xinput :

$ xinput list
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ bcm5974                                 	id=11	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Power Button                            	id=7	[slave  keyboard (3)]
    ↳ Sleep Button                            	id=8	[slave  keyboard (3)]
    ↳ Apple Computer, Inc. IR Receiver        	id=9	[slave  keyboard (3)]
    ↳ Apple Inc. Apple Internal Keyboard / Trackpad	id=10	[slave  keyboard (3)]
    ↳ Built-in iSight                         	id=12	[slave  keyboard (3)]


$ xinput list-props 11
Device 'bcm5974':
	Device Enabled (139):	1
	Coordinate Transformation Matrix (141):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Tapping Enabled (275):	0
	libinput Tapping Enabled Default (276):	0
	libinput Accel Speed (277):	0.000000
	libinput Accel Speed Default (278):	0.000000
	libinput Natural Scrolling Enabled (279):	0
	libinput Natural Scrolling Enabled Default (280):	0
	libinput Send Events Modes Available (260):	1, 1
	libinput Send Events Mode Enabled (261):	0, 0
	libinput Send Events Mode Enabled Default (262):	0, 0
	libinput Left Handed Enabled (281):	0
	libinput Left Handed Enabled Default (282):	0
	libinput Scroll Methods Available (283):	1, 0, 0
	libinput Scroll Method Enabled (284):	1, 0, 0
	libinput Scroll Method Enabled Default (285):	1, 0, 0
	libinput Click Methods Available (286):	1, 1
	libinput Click Method Enabled (287):	0, 1
	libinput Click Method Enabled Default (288):	0, 1
	Device Node (263):	"/dev/input/event10"
	Device Product ID (264):	1452, 567

If now I tick the "enable tap to click" box in Gnome control center :
$ xinput list-props 11
Device 'bcm5974':
	Device Enabled (139):	1
	Coordinate Transformation Matrix (141):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Tapping Enabled (275):	0
	libinput Tapping Enabled Default (276):	0
	libinput Accel Speed (277):	0.000000
	libinput Accel Speed Default (278):	0.000000
	libinput Natural Scrolling Enabled (279):	0
	libinput Natural Scrolling Enabled Default (280):	0
	libinput Send Events Modes Available (260):	1, 1
	libinput Send Events Mode Enabled (261):	0, 0
	libinput Send Events Mode Enabled Default (262):	0, 0
	libinput Left Handed Enabled (281):	0
	libinput Left Handed Enabled Default (282):	0
	libinput Scroll Methods Available (283):	1, 0, 0
	libinput Scroll Method Enabled (284):	1, 0, 0
	libinput Scroll Method Enabled Default (285):	1, 0, 0
	libinput Click Methods Available (286):	1, 1
	libinput Click Method Enabled (287):	0, 1
	libinput Click Method Enabled Default (288):	0, 1
	Device Node (263):	"/dev/input/event10"
	Device Product ID (264):	1452, 567


I did not try the suggested fix which is to remove xorg-x11-drv-libinput.

Do not hesitate to ask for for more information. Regards,
Yvan

Comment 1 Hans de Goede 2015-05-09 14:27:02 UTC
This seems to be a bug in mutter, probably a dup of 1214477.

Comment 2 Rui Matos 2015-05-11 11:40:13 UTC
If you change the options in the UI while running

xinput watch-props 11

on a terminal, are the value changes reflected on the terminal?

Also, if you you try to enable tapping via

xinput set-prop 11 'libinput Tapping Enabled' 1

on a terminal, does it work then?

Comment 3 yvan.masson 2015-05-13 08:30:41 UTC
(In reply to Rui Matos from comment #2)
> If you change the options in the UI while running
> 
> xinput watch-props 11
> 
> on a terminal, are the value changes reflected on the terminal?
> 
> Also, if you you try to enable tapping via
> 
> xinput set-prop 11 'libinput Tapping Enabled' 1
> 
> on a terminal, does it work then?

For some other reasons the person who owns the computer had to wipe the disk: I won't be able to provide these informations. I let you close this bug properly.

Sorry for the noise,
Yvan

Comment 4 yvan.masson 2015-05-15 22:06:12 UTC
Finally I could try on another MacBook Pro, which has the same touchpad (bcm5974). The only difference from above is that I'm using a live USB.

If I change the setting while running "xinput watch-props 11", nothing happens.

If I use "xinput set-prop 11 'libinput Tapping Enabled' 1", it does enable the "tap to click" (and the right click with two fingers).

Regards,
Yvan

Comment 5 Hans de Goede 2015-05-16 07:57:25 UTC
Hi,

(In reply to yvan.masson from comment #4)
> Finally I could try on another MacBook Pro, which has the same touchpad
> (bcm5974). The only difference from above is that I'm using a live USB.
> 
> If I change the setting while running "xinput watch-props 11", nothing
> happens.
> 
> If I use "xinput set-prop 11 'libinput Tapping Enabled' 1", it does enable
> the "tap to click" (and the right click with two fingers).

Please do "xinput list" and make sure that 11 is the correct id. e.g. if the output of xinput list is like this:

xinput list
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ bcm5974                                 	id=12	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Power Button                            	id=8	[slave  keyboard (3)]
    ↳ Sleep Button                            	id=9	[slave  keyboard (3)]
    ↳ Built-in iSight                         	id=10	[slave  keyboard (3)]
    ↳ Apple Inc. Apple Internal Keyboard / Trackpad	id=11	[slave  keyboard (3)]
    ↳ Apple Computer, Inc. IR Receiver        	id=13	[slave  keyboard (3)]

Then the touchpad is id 12, The touchpad is always under the "Virtual core pointer" parent of the tree.

Regards,

Hans

Comment 6 Hans de Goede 2015-05-17 09:50:51 UTC
Hi,

So in the mean time we've gotten confirmation from other users on this, and this is being tracked in another bug so I'm marking this one as a duplicate.

Regards,

Hans

*** This bug has been marked as a duplicate of bug 1206961 ***


Note You need to log in before you can comment on or make changes to this bug.