Bug 122031 - Xorg-X11 fails to stop when logging off
Xorg-X11 fails to stop when logging off
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-29 16:27 EDT by John Diaz
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 11:54:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Diaz 2004-04-29 16:27:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
On my HP pavilion ze4220 laptop (ATI IGP 340M video card). X appears
not to completly stop and or release the screen (sorry for not being
technical) when logging off, switching to another virtual terminal (
ex. ctrl-alt-f2 just incase i called it the wrong thing), stoping X
with ctrl-alt-backspace, exiting system-config-display on initial
boot, or when booting with rhgb in my grub.conf (x seems to load but
nothing is displayed). In all cases I get a black (blank) screen and
the computer won't respond to any combination of keystrokes. As I said
above this seems to happen any time X is stopped or no longer
accessing the display. This happens with both the vesa and radeon
drivers and did not occur in test 2 (with the exception of having to
remove rhgb from grub.conf for the first boot only).

 - HP ze4220 laptop
 - generic 1024x768 display
 - unaltered clean install of fct3
 - unaltered xorg.config (execpt adding 1024x768 res. by hand. bug
already open on the subject)
 - fully up2dated from rawhide (default source)
 - kernel 2.6.5-1.327




Version-Release number of selected component (if applicable):
xorg-x11-6.7.0-0.5

How reproducible:
Always

Steps to Reproduce:
1. install fc2t3 on a laptop with a IGP 340M video card (pos. others)
2. attempt to perform any of the actions listed above

    

Actual Results:  blank black screen and no response from keybord or
pointer

Expected Results:  X to play nice and restart, start, stop, or
whatever it should do depending on the action performed

Additional info:

Let me know if you need any other info i.e. my xorg.config, logs (they
dont show anything funny though - at least to me), or want me to run
any commands and post the results

John
Comment 1 John Diaz 2004-04-30 11:48:38 EDT
Problem seems to have corrected itself over night. Nothing done to the
machine other than installing j2sdk1.4.2 and apt-get (unused) from
rpm. Will leave it up to the powers to be if they want to keep this
bug open and look into it.

Puzzled
John 
Comment 2 Kristian Høgsberg 2004-08-26 11:54:33 EDT
Sounds odd, could be a duplicate of bug #123424.
Since it seems to have gone away, I'm closing the bug.
If you experience something like this again, please consider upgrading
the a more recent kernel RPM.

Note You need to log in before you can comment on or make changes to this bug.