Bug 123424 - Logout of X leads to "Sync Out of Range" using ATI Rage 16MB + Dell P991 Monitor
Logout of X leads to "Sync Out of Range" using ATI Rage 16MB + Dell P991 Monitor
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
:
: 122351 124677 124873 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-18 10:29 EDT by Andrew McHugh
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 11:32:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew McHugh 2004-05-18 10:29:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6)
Gecko/20040113

Description of problem:
Standard Dell Optiplex GX150 with 16MB ATI Rage AGP card installs
Fedora Core 2 without a problem. System behavior is expected
throughout the entire user experience until you logout of Gnome or
KDE. Upon logout the screen flickers, then blanks, then the Dell P991
monitor states that the Monitor is on, but that the input signal is
beyond the scan range. The system is frozen afterwards, no amount of
keyboard escape will work, Control-Alt-Backspace or
Control-Alt-Delete. The only path out is to press the power button and
force the power supply to turn off. Upon restart the system complains
about an unclean shutdown and prompts to fsck the root filesystem. The
entire experience up to this point is what I expect to see from Fedora
Core, it's only just past logout that it fails.

Version-Release number of selected component (if applicable):
X11R6.7.0

How reproducible:
Always

Steps to Reproduce:
1.Start System
2.Login to X as user
3.Logout ----> Fail.
    

Actual Results:  System unresponsive to keyboard input, montior states
"out of sync range"

Expected Results:  Return to the graphical login screen for a new user
to log in. This screen does appear normally after a power-on, before
the first and last login for the machine.

Additional info:

Dell GX150 - 8ZQMQ11. Full install of Fedora Core 2 from FTP, selected
standard workstation install and added a small amount of extra
packages for exploration of distribution. Compeltely vanilla
first-time-install, auto-partition, remove all prior partitions, rpm
installation and system startup ran perfectly, with no faults.
Comment 1 Andrew Petrukhin 2004-05-25 08:52:14 EDT
I had almost the same problem with ATI Rage Pro Ultra 32 Mb video card
on FC2. But a few logouts were sucsesful. 

After comenting 
Load dri 
in /etc/X11/Xorg.config all logouts are fine. 
But Tuxracer became very slow. :-)

andrew
Comment 2 Andrew McHugh 2004-05-26 10:51:40 EDT
That did it! Thanks!
Comment 3 Mike A. Harris 2004-05-26 12:17:33 EDT
While disabling DRI may work around the problem, the video driver
should really be detecting an invalid configuration (if that is the
case) and disabling DRI itself, so we should try to reproduce at
least.

I have both a Dell P991 monitor, and several ATI Rage 128 16Mb cards,
and can investigate this sometime in the future, and possibly fix it
or work around it in the driver.

Thanks.
Comment 4 Mike A. Harris 2004-05-26 12:18:07 EDT
Changing component to "xorg-x11"  (We do not ship XFree86)
Comment 5 Vinu Moses 2004-06-03 14:07:05 EDT
I have similar problems with ATI Radeon 9800Pro AGP on an ASUS AV333
(Via KT333 chipset) motherboard. System freezes on switching to a
virtual text console or shutting down X. The error is always reproducible.

I'm using FC2 with a 2.6.6 kernel, but had the same problem while
running a 2.6 kernel on FC1 also. The error occurs with all versions
of the 2.6 kernel, and also regardless of whether I use the radeon
driver bundled with X.org or ATi's binary only fglrx drivers (both
3.7.6 and 3.9.0 versions).

I've tried disabling DRI as mentioned above, but not had any success.

I've already posted a rather longish description of the same problem
at http://www.fedoraforum.org/forum/showthread.php?s=&threadid=2929

Regards,
Vinu.
Comment 6 Vinu Moses 2004-06-03 14:10:13 EDT
I have similar problems with ATI Radeon 9800Pro AGP on an ASUS AV333
(Via KT333 chipset) motherboard. System freezes on switching to a
virtual text console or shutting down X. The error is always reproducible.

I'm using FC2 with a 2.6.6 kernel, but had the same problem while
running a 2.6 kernel on FC1 also. The error occurs with all versions
of the 2.6 kernel, and also regardless of whether I use the radeon
driver bundled with X.org or ATi's binary only fglrx drivers (both
3.7.6 and 3.9.0 versions).

I've tried disabling DRI as mentioned above, but not had any success.

I've already posted a rather longish description of the same problem
at http://www.fedoraforum.org/forum/showthread.php?s=&threadid=2929

Regards,
Vinu.
Comment 7 Andrew McHugh 2004-06-03 14:27:27 EDT
I would be willing to turn DRI back on and test using the hardware I
have here if it would lead to a "real fix" versus a "shotgun fix".
Comment 8 Greg Felix 2004-07-30 14:48:40 EDT
I have a rage 128 that does this same exact thing.  Has anyone heard
back from Mike Harris if he was able to dup this or fix it maybe?
Comment 9 Jani Frilander 2004-07-30 23:02:28 EDT
I have the same problem with Rage 128 PF/PRO. Commenting
the Load "dri" line solves the problem, but I also had
success with changing /etc/X11/gdm/gdm.conf line

AlwaysRestartServer=true

And I got accelerated 3d!
Comment 10 Kristian Høgsberg 2004-08-25 21:41:13 EDT
*** Bug 124873 has been marked as a duplicate of this bug. ***
Comment 11 Kristian Høgsberg 2004-08-25 21:41:47 EDT
*** Bug 122351 has been marked as a duplicate of this bug. ***
Comment 12 Kristian Høgsberg 2004-08-26 11:32:55 EDT
This seems to be related to SIGHUP'ing the server and DRI.  I can
reproduce this with the FC2 kernel (2.6.5-1.358), but updating to any
newer kernel from FC2-updates or rawhide solves the problem.
                                                                     
          
Please try to install a newer kernel and see if that fixes it.
Comment 13 Richard Gill 2004-08-27 14:54:04 EDT
For me too, a newer kernel fixes the problem.
Comment 14 Kristian Høgsberg 2004-08-30 18:01:42 EDT
*** Bug 124677 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.