Bug 122032 - anaconda will not install via NFS ISO (DVD)
anaconda will not install via NFS ISO (DVD)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: 133260
  Show dependency treegraph
 
Reported: 2004-04-29 16:30 EDT by Forrest
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-21 08:44:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Forrest 2004-04-29 16:30:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
I have several problems installing via nfsiso using boot.iso:

1.  At the boot: prompt, I try to do an NFS/NFSISO install:
  linux method=nfs://server/path
  linux method=nfsiso://server/path
I probably have the syntax incorrect, although I have tried various
permutations (nfs:server:/path, nfs:/server/path, etc.).  All of these
methods try to mount the CD, which doesn't have the full tree.

2.  Simply hitting <ENTER> at the boot: prompt, I can choose an NFS
installation.  I put in the server name and the path to the ISOs. 
That directory has FC2-test2-i386-DVD.iso and FC2-test3-i386-DVD.iso.
 It tries test2 unsuccessfully, and never tries test3.  I realize that
this is to avoid trying disc1, disc2..., but is there a better method
to determine this?

3.  After removing test2 ISO, it tries test3 but fails:

  * Path to valid iso is /mnt/source/FC2-test3-i386-DVD.iso
  * mntloop loop1 on /mnt/source2 as
/mnt/source/FC2-test3-i386-DVD.iso fd is 41
  * mntloop loop0 on /mnt/runtime as
/mnt/source2/Fedora/base/stage2.img fd is 41
  * failed to mount loop: Invalid argument
  * umounting loopback /mnt/source2 loop1


Version-Release number of selected component (if applicable):
anaconda-9.92-8

How reproducible:
Always

Steps to Reproduce:
1.  Use boot.iso to boot
2.  Try various method=nfs*
3.  Try to use FC2-test3-i386-DVD.iso for NFSISO method
    

Actual Results:  CD not found, or not able to mount the stage2.img
Comment 1 david d zuhn 2004-05-19 12:40:36 EDT
The same thing occurs for the final release of FC2.  I chose an NFS
install (not using any command line arguments) and am unable to
install directly from the DVD ISO.   
Comment 2 Chris Rainey 2004-06-22 02:14:12 EDT
Confirming same problem, here, with FC2-i386-DVD.iso.  Would really
like to have this functionality.
Comment 3 david d zuhn 2004-07-14 16:05:20 EDT
I cannot do an NFS install from the DVD iso image with FC3test1
either.  Same results as the FC2 series.  

Comment 4 Jeremy Katz 2004-10-01 16:47:48 EDT
Fixed in CVS.  Turns out we were still doing nfs v2 (!) mounts instead
of nfsv3.

Note You need to log in before you can comment on or make changes to this bug.