Bug 122085 - can't make changes using tool main ok button does not modify files
Summary: can't make changes using tool main ok button does not modify files
Status: CLOSED DUPLICATE of bug 119849
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-httpd   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-30 10:56 UTC by stuart
Modified: 2015-03-05 01:13 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:02:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description stuart 2004-04-30 10:56:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040422

Description of problem:
system-config gui is unable to write to files?

Traceback (most recent call last):
  File "/usr/share/system-config-httpd/ApacheConf.py", line 273, in
on_main_ok_button_clicked
    if not control.write():
  File "/usr/share/system-config-httpd/ApacheControl.py", line 63, in
write
    return stack.apache.write(force)
  File "/usr/share/system-config-httpd/ApacheGizmo.py", line 770, in write
    return ApacheBase.write (force)
  File "/usr/share/system-config-httpd/ApacheBase.py", line 4346, in write
    proc.appendStylesheet(STY)
  File "/usr/lib/python2.3/site-packages/Ft/Xml/Xslt/Processor.py",
line 178, in appendStylesheet
    sty = self._styReader.fromSrc(iSrc, extElements=self.extElements)
  File
"/usr/lib/python2.3/site-packages/Ft/Xml/Xslt/StylesheetReader.py",
line 160, in fromSrc
    stylesheet =  self._parseSrc(new_source)
  File
"/usr/lib/python2.3/site-packages/Ft/Xml/Xslt/StylesheetReader.py",
line 184, in _parseSrc
    expat.ErrorString(error.code))
Ft.Xml.Xslt.XsltException: Stylesheet
(file:///usr/share/system-config-httpd/httpd.conf.xsl): XML parse
error at line 10, column 15: not well-formed (invalid token)


Version-Release number of selected component (if applicable):
system-config-httpd-1.2.0-3

How reproducible:
Always

Steps to Reproduce:
1. run system-config-httpd as root
2. make changes in gui
3. hit ok button
4. program does not quit or make changes to httpd config files (get
error messages shown in description field above)
    

Actual Results:  program does not quit or make changes to httpd config
files

Expected Results:  quit and make changes to httpd settings

Additional info:

Comment 1 Alan Cox 2004-05-02 22:51:50 UTC
Duplicated here. Also spews

(system-config-httpd:28219): Gtk-WARNING **: Attempting to add a
widget with type GtkLabel to a GtkButton, but as a GtkBin subclass a
GtkButton can only contain one widget at a time; it already contains a
widget of type GtkLabel
 
(system-config-httpd:28219): Gtk-WARNING **: Attempting to add a
widget with type GtkLabel to a GtkButton, but as a GtkBin subclass a
GtkButton can only contain one widget at a time; it already contains a
widget of type GtkLabel
 
(system-config-httpd:28219): Gtk-WARNING **: Attempting to add a
widget with type GtkLabel to a GtkButton, but as a GtkBin subclass a
GtkButton can only contain one widget at a time; it already contains a
widget of type GtkLabel
 
(system-config-httpd:28219): Gtk-WARNING **: Attempting to add a
widget with type GtkLabel to a GtkButton, but as a GtkBin subclass a
GtkButton can only contain one widget at a time; it already contains a
widget of type GtkLabel
 
(system-config-httpd:28219): Gtk-WARNING **: Attempting to add a
widget with type GtkLabel to a GtkButton, but as a GtkBin subclass a
GtkButton can only contain one widget at a time; it already contains a
widget of type GtkLabel
 
(system-config-httpd:28219): Gtk-WARNING **: Attempting to add a
widget with type GtkLabel to a GtkButton, but as a GtkBin subclass a
GtkButton can only contain one widget at a time; it already contains a
widget of type GtkLabel
 
(system-config-httpd:28219): Gtk-WARNING **: Attempting to add a
widget with type GtkLabel to a GtkButton, but as a GtkBin subclass a
GtkButton can only contain one widget at a time; it already contains a
widget of type GtkLabel
 
(system-config-httpd:28219): Gtk-WARNING **: Attempting to add a
widget with type GtkLabel to a GtkButton, but as a GtkBin subclass a
GtkButton can only contain one widget at a time; it already contains a
widget of type GtkLabel
 
(system-config-httpd:28219): Gtk-WARNING **: Attempting to add a
widget with type GtkLabel to a GtkButton, but as a GtkBin subclass a
GtkButton can only contain one widget at a time; it already contains a
widget of type GtkLabel
 
(system-config-httpd:28219): Gtk-WARNING **: Attempting to add a
widget with type GtkLabel to a GtkButton, but as a GtkBin subclass a
GtkButton can only contain one widget at a time; it already contains a
widget of type GtkLabel
 
(system-config-httpd:28219): Gtk-WARNING **: Attempting to add a
widget with type GtkLabel to a GtkButton, but as a GtkBin subclass a
GtkButton can only contain one widget at a time; it already contains a
widget of type GtkLabel
 
(system-config-httpd:28219): Gtk-WARNING **: Attempting to add a
widget with type GtkLabel to a GtkButton, but as a GtkBin subclass a
GtkButton can only contain one widget at a time; it already contains a
widget of type GtkLabel
 
(system-config-httpd:28219): Gtk-WARNING **: Attempting to add a
widget with type GtkLabel to a GtkButton, but as a GtkBin subclass a
GtkButton can only contain one widget at a time; it already contains a
widget of type GtkLabel
 
(system-config-httpd:28219): Gtk-WARNING **: Attempting to add a
widget with type GtkLabel to a GtkButton, but as a GtkBin subclass a
GtkButton can only contain one widget at a time; it already contains a
widget of type GtkLabel
 
(system-config-httpd:28219): Gtk-WARNING **: Attempting to add a
widget with type GtkLabel to a GtkButton, but as a GtkBin subclass a
GtkButton can only contain one widget at a time; it already contains a
widget of type GtkLabel
 
(system-config-httpd:28219): Gtk-WARNING **: Attempting to add a
widget with type GtkLabel to a GtkButton, but as a GtkBin subclass a
GtkButton can only contain one widget at a time; it already contains a
widget of type GtkLabel
 
(system-config-httpd:28219): Gtk-WARNING **: Attempting to add a
widget with type GtkLabel to a GtkButton, but as a GtkBin subclass a
GtkButton can only contain one widget at a time; it already contains a
widget of type GtkLabel
 
(system-config-httpd:28219): Gtk-WARNING **: Attempting to add a
widget with type GtkLabel to a GtkButton, but as a GtkBin subclass a
GtkButton can only contain one widget at a time; it already contains a
widget of type GtkLabel
 
(system-config-httpd:28219): Gtk-WARNING **: Attempting to add a
widget with type GtkLabel to a GtkButton, but as a GtkBin subclass a
GtkButton can only contain one widget at a time; it already contains a
widget of type GtkLabel
 
(system-config-httpd:28219): Gtk-WARNING **: Attempting to add a
widget with type GtkLabel to a GtkButton, but as a GtkBin subclass a
GtkButton can only contain one widget at a time; it already contains a
widget of type GtkLabel
 
(system-config-httpd:28219): Gtk-WARNING **: Attempting to add a
widget with type GtkLabel to a GtkButton, but as a GtkBin subclass a
GtkButton can only contain one widget at a time; it already contains a
widget of type GtkLabel
 
(system-config-httpd:28219): Gtk-WARNING **: Attempting to add a
widget with type GtkLabel to a GtkButton, but as a GtkBin subclass a
GtkButton can only contain one widget at a time; it already contains a
widget of type GtkLabel
 
(system-config-httpd:28219): Gtk-WARNING **: Attempting to add a
widget with type GtkLabel to a GtkButton, but as a GtkBin subclass a
GtkButton can only contain one widget at a time; it already contains a
widget of type GtkLabel
 
(system-config-httpd:28219): Gtk-WARNING **: Attempting to add a
widget with type GtkLabel to a GtkButton, but as a GtkBin subclass a
GtkButton can only contain one widget at a time; it already contains a
widget of type GtkLabel
 
(system-config-httpd:28219): Gtk-WARNING **: Attempting to add a
widget with type GtkLabel to a GtkButton, but as a GtkBin subclass a
GtkButton can only contain one widget at a time; it already contains a
widget of type GtkLabel
 
(system-config-httpd:28219): Gtk-WARNING **: Attempting to add a
widget with type GtkLabel to a GtkButton, but as a GtkBin subclass a
GtkButton can only contain one widget at a time; it already contains a
widget of type GtkLabel
Traceback (most recent call last):
  File "/usr/share/system-config-httpd/ApacheConf.py", line 273, in
on_main_ok_button_clicked
    if not control.write():
  File "/usr/share/system-config-httpd/ApacheControl.py", line 63, in
write
    return stack.apache.write(force)
  File "/usr/share/system-config-httpd/ApacheGizmo.py", line 770, in write
    return ApacheBase.write (force)
  File "/usr/share/system-config-httpd/ApacheBase.py", line 4346, in write
    proc.appendStylesheet(STY)
  File "/usr/lib/python2.3/site-packages/Ft/Xml/Xslt/Processor.py",
line 178, in appendStylesheet
    sty = self._styReader.fromSrc(iSrc, extElements=self.extElements)
  File
"/usr/lib/python2.3/site-packages/Ft/Xml/Xslt/StylesheetReader.py",
line 160, in fromSrc
    stylesheet =  self._parseSrc(new_source)
  File
"/usr/lib/python2.3/site-packages/Ft/Xml/Xslt/StylesheetReader.py",
line 184, in _parseSrc
    expat.ErrorString(error.code))
Ft.Xml.Xslt.XsltException: Stylesheet
(file:///usr/share/system-config-httpd/httpd.conf.xsl): XML parse
error at line 10, column 15: not well-formed (invalid token)


Comment 2 Shane Daily 2004-05-05 00:06:58 UTC
removing the "<" and the ">" from line 10 of
/usr/share/system-config-httpd/httpd.conf.xsl helps.

Comment 3 Ben Levenson 2004-05-26 19:10:22 UTC
looks like a dup of bug# 119849

*** This bug has been marked as a duplicate of 119849 ***

Comment 4 Red Hat Bugzilla 2006-02-21 19:02:53 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.