Bug 119849 - system-config-httpd does not save changes
system-config-httpd does not save changes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-httpd (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
: 122085 122783 122839 124229 127842 128095 138526 140323 (view as bug list)
Depends On:
Blocks: FC2Blocker 135487
  Show dependency treegraph
 
Reported: 2004-04-02 11:54 EST by Steve
Modified: 2015-03-04 20:13 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-30 10:05:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
eliminate XSL conversion error in xml (520 bytes, patch)
2004-06-05 01:37 EDT, Jim Tittsler
no flags Details | Diff

  None (edit)
Description Steve 2004-04-02 11:54:01 EST
Description of problem:
The GUI comes up after prompting for SU password.

When changes are made and the "OK" button is clicked, and the 
dialogue "Are you sure you want to save and exit?" is answered "OK" 
nothing happens - i.e. the HTTP config tool does not exit.

When the tool is exited using the "X" the changes to the daemon are 
not changed.

Version-Release number of selected component (if applicable):
system-config-httpd-1.2.0-3

How reproducible:
Always

Steps to Reproduce:
1.Launch GUI
2.Make Changes
3.Click OK
4.Watch as Program does not exit
5.Exit Program
6.Re-Lauch GUI
7.Notice how changes have not taken place
    

Additional info:
Comment 1 Donald Harper 2004-04-02 13:41:26 EST
I get the following errors on the console:

Traceback (most recent call last):
  File "/usr/share/system-config-httpd/ApacheConf.py", line 273, in
on_main_ok_button_clicked
    if not control.write():
  File "/usr/share/system-config-httpd/ApacheControl.py", line 63, in
write
    return stack.apache.write(force)
  File "/usr/share/system-config-httpd/ApacheGizmo.py", line 770, in write
    return ApacheBase.write (force)
  File "/usr/share/system-config-httpd/ApacheBase.py", line 4346, in write
    proc.appendStylesheet(STY)
  File "/usr/lib/python2.3/site-packages/Ft/Xml/Xslt/Processor.py",
line 178, in appendStylesheet
    sty = self._styReader.fromSrc(iSrc, extElements=self.extElements)
  File
"/usr/lib/python2.3/site-packages/Ft/Xml/Xslt/StylesheetReader.py",
line 160, in fromSrc
    stylesheet =  self._parseSrc(new_source)
  File
"/usr/lib/python2.3/site-packages/Ft/Xml/Xslt/StylesheetReader.py",
line 184, in _parseSrc
    expat.ErrorString(error.code))
Ft.Xml.Xslt.XsltException: Stylesheet
(file:///usr/share/system-config-httpd/httpd.conf.xsl): XML parse
error at line 10, column 15: not well-formed (invalid token)
Comment 2 Brent Fox 2004-04-27 17:08:03 EDT
I'm seeing the same error in test 3.
Comment 5 Phil Knirsch 2004-05-07 05:47:49 EDT
Will fix today.

Read ya, Phil
Comment 6 Ben Levenson 2004-05-26 15:10:25 EDT
*** Bug 122085 has been marked as a duplicate of this bug. ***
Comment 7 Ben Levenson 2004-05-26 15:14:44 EDT
*** Bug 122839 has been marked as a duplicate of this bug. ***
Comment 8 Ben Levenson 2004-05-26 15:15:58 EDT
*** Bug 124229 has been marked as a duplicate of this bug. ***
Comment 9 Ben Levenson 2004-05-26 15:17:31 EDT
*** Bug 122783 has been marked as a duplicate of this bug. ***
Comment 10 Eric Beyer 2004-05-28 10:41:27 EDT
I am seeing the same error in the FC2 release version (system-config-
httpd-1.2.0-3). Received same console errors as Comment #1
Comment 11 PE Meunier 2004-05-29 08:41:36 EDT
The same error happens in FC2 release. Even when making no change, the
GUI does not close
Comment 12 Michael Obester 2004-06-04 14:46:59 EDT
Add me to the list of those seeing this error, using official release 
FC2. I did a new install of FC2. But since I couldn't edit the HTTPD 
config had to step back to FC1. What's really odd, tried to edit my 
httpd.conf manually (as root), saved and closed. Re-opened it, and 
changes were lost. (/etc/httpd/conf/httpd.conf)

The original thread posted 4-02-04, is there a resolution posted that 
I've missed?
Comment 13 Jim Tittsler 2004-06-05 01:37:22 EDT
Created attachment 100890 [details]
eliminate XSL conversion error in xml

remove '<>' surrounding a URL: in the comments of the .xsl file
Comment 14 Jim Tittsler 2004-06-05 01:40:00 EDT
One way to eliminate the problem is to remove the '<>' surrounding the
URL on line 10 of /usr/share/system-config-httpd/httpd.conf.xsl
Comment 15 Derek Scollon 2004-06-05 08:29:04 EDT
That's great Jim. That fix is working great for me on the release
version of FC2.
Comment 16 Ossama Khayat 2004-06-19 13:22:14 EDT
I tested this just now (as I did before for three days) and still it
doesn't work!
Here's the error from console:
(system-config-httpd:9083): Gtk-WARNING **: Attempting to add a widget
with type GtkLabel to a GtkButton, but as a GtkBin subclass a
GtkButton can only contain one widget at a time; it already contains a
widget of type GtkLabel
Traceback (most recent call last):
  File "/usr/share/system-config-httpd/ApacheConf.py", line 273, in
on_main_ok_button_clicked
    if not control.write():
  File "/usr/share/system-config-httpd/ApacheControl.py", line 63, in
write
    return stack.apache.write(force)
  File "/usr/share/system-config-httpd/ApacheGizmo.py", line 770, in write
    return ApacheBase.write (force)
  File "/usr/share/system-config-httpd/ApacheBase.py", line 4346, in write
    proc.appendStylesheet(STY)
  File "/usr/lib/python2.3/site-packages/Ft/Xml/Xslt/Processor.py",
line 178, in appendStylesheet
    sty = self._styReader.fromSrc(iSrc, extElements=self.extElements)
  File
"/usr/lib/python2.3/site-packages/Ft/Xml/Xslt/StylesheetReader.py",
line 160, in fromSrc
    stylesheet =  self._parseSrc(new_source)
  File
"/usr/lib/python2.3/site-packages/Ft/Xml/Xslt/StylesheetReader.py",
line 184, in _parseSrc
    expat.ErrorString(error.code))
Ft.Xml.Xslt.XsltException: Stylesheet
(file:///usr/share/system-config-httpd/httpd.conf.xsl): XML parse
error at line 10, column 15: not well-formed (invalid token)
Comment 17 Stein Magne Bjorklund 2004-06-28 12:36:38 EDT
Have this bug, but a error on line 2 col 0.
Invalid number attribute value '1.0'

Running FC2 with all the latest updates (23.6.2004)
Comment 18 T.Terlemez 2004-07-01 12:26:26 EDT
hello

I took same error too.

when I edited the file /usr/share/system-config-httpd/httpd.conf.xsl
with mcedit, I saw that, first line of the file went to one line down.
After then I reopened file and I deleted first blank line and saved
it, it worked without error.
Comment 19 T.Terlemez 2004-07-01 12:27:35 EDT
Hello

Excuse me, I forgot to say, I am using Fedora core 2 final version.
Comment 20 Phil Knirsch 2004-07-30 10:05:35 EDT
Fixed in latest rawhide version system-config-httpd-1.2.1-1 and later.

Read ya, Phil
Comment 21 Phil Knirsch 2004-07-30 10:14:29 EDT
*** Bug 127842 has been marked as a duplicate of this bug. ***
Comment 22 Phil Knirsch 2004-07-30 10:15:01 EDT
*** Bug 128095 has been marked as a duplicate of this bug. ***
Comment 23 Stefan Bleicker 2004-10-12 15:08:47 EDT
Hi Phil

i'm using the latest version (1.3.1.1) but i have this but too.

here is my console error:
Traceback (most recent call last):
  File "/usr/share/system-config-httpd/ApacheConf.py", line 273, in
on_main_ok_button_clicked
    if not control.write():
  File "/usr/share/system-config-httpd/ApacheControl.py", line 63, in
write
    return stack.apache.write(force)
  File "/usr/share/system-config-httpd/ApacheGizmo.py", line 772, in write
    return ApacheBase.write (force)
  File "/usr/share/system-config-httpd/ApacheBase.py", line 4346, in write
    proc.appendStylesheet(STY)
  File "/usr/lib/python2.3/site-packages/Ft/Xml/Xslt/Processor.py",
line 178, in appendStylesheet
    sty = self._styReader.fromSrc(iSrc, extElements=self.extElements)
  File
"/usr/lib/python2.3/site-packages/Ft/Xml/Xslt/StylesheetReader.py",
line 160, in fromSrc
    stylesheet =  self._parseSrc(new_source)
  File
"/usr/lib/python2.3/site-packages/Ft/Xml/Xslt/StylesheetReader.py",
line 180, in _parseSrc
    success = self.parser.ParseFile(src.stream)
  File
"/usr/lib/python2.3/site-packages/Ft/Xml/Xslt/StylesheetHandler.py",
line 348, in startElement
    raise e
Ft.Xml.Xslt.XsltException: In stylesheet
file:///usr/share/system-config-httpd/httpd.conf.xsl, line 2, column 0:
Invalid number attribute value '1.0'



Maybe you can help?


thx

Stefan Bleicker
Comment 24 Stefan Bleicker 2004-10-12 15:11:41 EDT
Hi Phil

i'm using the latest version (1.3.1.1) but i have this but too.

here is my console error:
Traceback (most recent call last):
  File "/usr/share/system-config-httpd/ApacheConf.py", line 273, in
on_main_ok_button_clicked
    if not control.write():
  File "/usr/share/system-config-httpd/ApacheControl.py", line 63, in
write
    return stack.apache.write(force)
  File "/usr/share/system-config-httpd/ApacheGizmo.py", line 772, in write
    return ApacheBase.write (force)
  File "/usr/share/system-config-httpd/ApacheBase.py", line 4346, in write
    proc.appendStylesheet(STY)
  File "/usr/lib/python2.3/site-packages/Ft/Xml/Xslt/Processor.py",
line 178, in appendStylesheet
    sty = self._styReader.fromSrc(iSrc, extElements=self.extElements)
  File
"/usr/lib/python2.3/site-packages/Ft/Xml/Xslt/StylesheetReader.py",
line 160, in fromSrc
    stylesheet =  self._parseSrc(new_source)
  File
"/usr/lib/python2.3/site-packages/Ft/Xml/Xslt/StylesheetReader.py",
line 180, in _parseSrc
    success = self.parser.ParseFile(src.stream)
  File
"/usr/lib/python2.3/site-packages/Ft/Xml/Xslt/StylesheetHandler.py",
line 348, in startElement
    raise e
Ft.Xml.Xslt.XsltException: In stylesheet
file:///usr/share/system-config-httpd/httpd.conf.xsl, line 2, column 0:
Invalid number attribute value '1.0'



Maybe you can help?


thx

Stefan Bleicker
Comment 25 Phil Knirsch 2004-10-13 09:51:38 EDT
Hm, if you look at the end of the traceback it complains about a
different line and value there.

Please remove system-config-httpd completely and reinstall it with the
latest version and see if that works.

Thanks,

Read ya, Phil
Comment 26 Stefan Bleicker 2004-10-14 11:00:01 EDT
Hi Phil,

i reinstalled it several times, at last, i reinstalled the whole
fedora2 system - nothing - always the same problem.

what next?

thx

stefan
Comment 27 Phil Knirsch 2004-10-14 11:06:48 EDT
Could you post the first few lines of the file
/usr/share/system-config-httpd/httpd.conf.xsl here in bugzilla?

It looks as that might be corrupt.

Also, the output of

  rpm -qf /usr/share/system-config-httpd/httpd.conf.xsl

and

  rpm -qf
/usr/lib/python2.3/site-packages/Ft/Xml/Xslt/StylesheetHandler.py

would be very helpful.

Read ya, Phil
Comment 28 Stefan Bleicker 2004-10-14 11:43:51 EDT
Sure!

here are the first lines of my httpd.conf.xsl:
<?xml version="1.0"?>
<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
version="1.0">
<xsl:output method = "text" />
<xsl:template match="apache/serveroptions" xml:space="preserve"> 


output from rpm -qf /usr/share/system-config-httpd/httpd.conf.xsl:
system-config-httpd-1.2.0-3


output from rpm -qf
/usr/lib/python2.3/site-packages/Ft/Xml/Xslt/StylesheetHandler.py:
4Suite-1.0-1.0.a3.1


Hope it helps!

Thx

Stefan
Comment 29 Phil Knirsch 2004-10-18 07:58:10 EDT
Could you install the latest packages of 4Suite and
system-config-httpd of Fedora Core 3 and see if the problem persits?

Your files look ok and shouldn't cause any problems...

Read ya, Phil
Comment 30 Laurent AUBERT 2004-10-19 13:47:21 EDT
Hello,

The same error occured on my Fedora 2.
I bugfixed it in modifying line 2 of httpd.conf.xsl like that :
<xsl:stylesheet version='1'
xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
See that I change version="1.0" in version='1' and Eurekaa I can save
change in HTTP server config program :-)
Comment 31 Phil Knirsch 2004-10-20 10:35:57 EDT
This sounds really like a bug of 4Suite not accepting the version
correctly on some system for unknow reasons in FC2.

It works nicely for me with the latest FC3 packages, so i'd like to
keep that bug closed if noone can see that problem with the latest FC3
packages of s-c-h and 4Suite.

Read ya, Phil
Comment 32 parq 2004-10-30 07:11:00 EDT
ok. working

i've changed /usr/share/system-config-httpd/httpd.conf.xsl:

- from: <xsl:stylesheet
xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="1.0">
- to:  <xsl:stylesheet
xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="1">

system info:
fedora core 2
system-config-httpd-1.2.0-3
4Suite-1.0-1.0.a3.1
libxml-1.8.17-10.1.1

tx!
Comment 33 Phil Knirsch 2004-11-11 10:07:00 EST
*** Bug 138526 has been marked as a duplicate of this bug. ***
Comment 34 Phil Knirsch 2004-11-29 05:50:16 EST
*** Bug 140323 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.