Bug 122087 - nautilus does not run
nautilus does not run
Status: CLOSED DUPLICATE of bug 123807
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-30 07:32 EDT by Rafael J. Wysocki
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
good fstab for nautilus (678 bytes, text/plain)
2004-05-01 11:18 EDT, Manuel Moreno
no flags Details
I also changed this ... (79 bytes, text/plain)
2004-05-01 11:23 EDT, Manuel Moreno
no flags Details

  None (edit)
Description Rafael J. Wysocki 2004-04-30 07:32:11 EDT
Description of problem: nautilus always crashes on startup


Version-Release number of selected component (if applicable):
nautilus-2.6.0-4.x86_64


How reproducible: Always


Steps to Reproduce:
1. Try to run nautilus (eg. "nautilus &" in an X terminal)
2.
3.
  
Actual results: nautilus does not start, a popup appears with a
message like "nautilus application has quit unexpectedly"


Expected results: nautilus should start


Additional info: The system is a dual Opteron (I used SMP kernel)
Comment 1 Manuel Moreno 2004-05-01 11:18:07 EDT
Created attachment 99862 [details]
good fstab for nautilus
Comment 2 Manuel Moreno 2004-05-01 11:21:29 EDT
I have been able to run nautilus...

Digging into gentoo lists it seems to be a hard to track problem
which possibly involves glibc and/or nptl ... and only shows on
x86_64 architecture.

There is a workaround that seems to work (at least it works for me)
you have to edit /etc/fstab and comment out lines for floppy, cdrom,
etc... until you get nautilus to run.

Here (attached) is my /etc/fstab that makes it run well.

The funny thing is that if I change the last line from

/dev/fd0        /mnt/floppy     auto    noauto          0 0

to

/dev/fd0        /mnt/floppy     auto    noauto,owner          0 0

then nautilus crashes again! ;-/
Comment 3 Manuel Moreno 2004-05-01 11:23:50 EDT
Created attachment 99863 [details]
I also changed this ... 

Maybe this is also needed
Comment 4 Manuel Moreno 2004-05-01 11:31:31 EDT
Forgot to say, my hardware is AMD64 processor
Asus k8v de luxe motherboard and several pata/sata disks 1,2 Gb RAM


P.S. I was fed up from using KDE (which otos works flawlessly...)
Comment 5 Alexander Larsson 2004-05-03 13:48:00 EDT
Does anyone have a backtrace of the crash (with symbols)?
Comment 7 Chuck Mead 2004-05-10 13:49:59 EDT
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=122662 <---- this
is surely related! Here is my fstab file for reference:

[csm@stealth csm]$ cat /etc/fstab
LABEL=/                 /                       ext3    defaults     
  1 1
LABEL=/boot             /boot                   ext3    defaults     
  1 2
none                    /dev/pts                devpts  gid=5,mode=620
 0 0
none                    /dev/shm                tmpfs   defaults     
  0 0
LABEL=/home             /home                   ext3    defaults     
  1 2
LABEL=/opt              /opt                    ext3    defaults     
  1 2
none                    /proc                   proc    defaults     
  0 0
none                    /sys                    sysfs   defaults     
  0 0
LABEL=/usr              /usr                    ext3    defaults     
  1 2
LABEL=/usr/local        /usr/local              ext3    defaults     
  1 2
LABEL=/var              /var                    ext3    defaults     
  1 2
/dev/hdc3               swap                    swap    defaults     
  0 0
/dev/hda5               swap                    swap    defaults     
  0 0
/dev/cdrom              /mnt/cdrom              udf,iso9660
noauto,owner,kudzu,ro 0 0
/dev/cdrom1             /mnt/cdrom1             udf,iso9660
noauto,owner,kudzu,ro 0 0
/dev/fd0                /mnt/floppy             auto   
noauto,owner,kudzu 0 0
Comment 8 Alexander Larsson 2004-09-06 08:48:21 EDT

*** This bug has been marked as a duplicate of 123807 ***
Comment 9 Red Hat Bugzilla 2006-02-21 14:02:53 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.