Bug 123807 - Nautilus crashes on startup on x86_64
Nautilus crashes on startup on x86_64
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
2
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Alexander Larsson
:
: 121912 122087 122662 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-20 13:31 EDT by Alessandro Polverini
Modified: 2007-11-30 17:10 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 10:15:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patched x86_64 ORBit2 rpm (253.88 KB, application/octet-stream)
2004-06-27 12:17 EDT, Thomas Walker
no flags Details
xxx.patch (132.79 KB, patch)
2004-07-20 01:46 EDT, Chris Landrieu
no flags Details | Diff

  None (edit)
Description Alessandro Polverini 2004-05-20 13:31:31 EDT
Description of problem:
If I use gnome, I can't use nautilus: it crashes on startup with the
following error:
"The applicatino nautils has quit unexpectly"

Version-Release number of selected component (if applicable):
2.6.0-4

How reproducible:
I reinstalled the system two times, and I got two times the same error.

Steps to Reproduce:
1. Install Fedora Core 2 for AMD64 with both KDE and Gnome
2. log in with default settings
3. nautils crashes
  
Actual results:


Expected results:


Additional info:
Comment 1 Thorsten Leemhuis 2004-05-21 12:07:50 EDT
Can confirm this (standard install). Started to happen on the second
day (worked fine on day one) after install. Will look closer tomorrow. 
Comment 2 Jure Repinc 2004-05-21 14:27:29 EDT
Same problem here. It works OK sometimes but most of the time it just
crashes. I don't know if this is connected ot not but Epiphany also
crashes on startup.
Comment 3 Jake Piotrowski 2004-05-23 11:24:44 EDT
Also having the same problem.  Even tried upgrading to the 
Development version of Nautilus currently available which is 2.6.0-
5.  Still having the same problem.
Comment 4 David McCormick 2004-05-25 21:35:12 EDT
I have 2 cdrom drives, a floopy , a zip drive and a flash card reader.
If I hold my entries in /fstab to any two of these Nautilus starts
properly at login and the file browser works fine. If I add any other
devices from this group Nautilus crashes on login and if ti is
selected as that file browser. I have no idea why but thought it might
help you to have the information
Comment 5 Udi Finkelstein 2004-05-27 09:12:16 EDT
I also had the same problem, and can confirm that David's workaround
works (disabling cdroms and floppies in /etc/fstab).
Comment 6 Andrew Ragone 2004-05-29 22:23:10 EDT
This happened for my system too as soon as I started up. I do have 
KDE and GNOME installed. I am also not sure if this issue is related 
to my monitor going black about 15 minutes into each session but I 
will get back on that [may have been monitor config] 
Comment 7 Jure Repinc 2004-05-30 05:32:08 EDT
Any news on fixing this. It is quite important as we still can't use
GNOME because of it :(
Comment 8 Andrew Ragone 2004-05-30 14:25:26 EDT
doesnt seem to be related to my monitor but i do have 2 CDROM drives 
[CD-RW and DVD-RW]. Still havent fixed it
Comment 9 Jo Spring 2004-05-31 16:08:42 EDT
Same here. I also have 2 CD drives
Comment 10 David McCormick 2004-06-01 20:38:24 EDT
 i found that if I try to mount the second dev that fstab will hold
and still allow Nautilus to work, it immediatley crashes Nuatilus.  I
have had to remove X86_64 FC2 from my system and go to i396 FC2 in
order to use Fedora Core for normal work.  I feel that this should be
a high priority to be fixed. I don't know if this could be hardware
specific but I have a AMD64-FX51 processer on an Asus SK8N mother
board, 2gigs of memory, an Adaptec LV-2 scsi board, two 18 gig Segate
drives, a 36 gig Segate drive, a Sony CRX320E cdrom/dvd, a Sony
DRU500A dvd writer, Iomega 100meg ATAPI drive, and a San Disc USB
Flash Card Reader, ATI 9800 Pro Radeon graphics board,and a Sound
Blaster Live 5.1 sound card. 
Comment 11 David McCormick 2004-06-01 20:43:04 EDT
I forgot to mention that I did a clean istall of FC2 X86_64 with only
Gnome leaving KDE uninstalled and the results were the same. Nautilus
crashes with more than two devices listed in fstab.
Comment 12 Andrew Ragone 2004-06-02 07:57:37 EDT
I actually was getting fed up with this and decided to install i386 
over x86_64 because when on my server, it had no problems. 
Unfortunatly, the same problem occurs yet much more limited. It does 
not happen as often but when it does I may be able to get back into X 
but only where the mouse moves and the screen is messed up with 
random color lines throughout the display. That is IF I CAN get back 
into it. I'm hoping this will be resolved soon.
Comment 13 Mark Ferguson 2004-06-05 05:19:24 EDT
I've got 2 cdrom drives, and Nautilus crashes if there are is a CD in
both drives. Remove one CD and reboot and the problem goes away.
Comment 14 Don N. Pittman 2004-06-15 10:02:55 EDT
Same problem on my x86_64.  Had to delete cdrom, zip, and floppy from
fstab and updfstab.conf.default (to keep it from being re-entered in
fstab).  
Comment 15 Chris Landrieu 2004-06-16 18:10:05 EDT
This problem is caused by a memory alignment bug in ORBit2.  I posted
a quick fix for it over in GNOME bugzilla:
  http://bugzilla.gnome.org/show_bug.cgi?id=138986
Comment 16 Chris Landrieu 2004-06-17 16:49:30 EDT
Can someone with sufficient privileges please push this over to ORBit2?

There are also a bunch of dups:
    bug 126181
    bug 122087
    bug 122662
    bug 123066

There's also an updated patch on the gnome bugzilla link above.  It's
a forward port from an old-ORBit patch created by Matt Wilson.  It has
a couple of additional related alignment fixes.
Comment 17 David McCormick 2004-06-18 15:03:57 EDT
Is there any plan to release a rpm with the correction inculded?  
Comment 18 Chris Landrieu 2004-06-18 16:30:02 EDT
Instructions for creating your own rpm (in the interim) can be found here:
  http://fedoraforum.org/forum/showthread.php?s=&threadid=3404

Just replace "ORBit2-2.10.0.1-cbl-nautilus-crasher-fix.patch" with
whatever you name the patch file downloaded from the GNOME bug 138986.
 Also, remember to set $LIBRARY_PATH as described in the FedoraForum post.
Comment 19 David McCormick 2004-06-23 05:25:54 EDT
I followed your instructions but when I applied the patch it kept
asking for the file to patch, and then would reject the file I
entered. I tried every file in the folder /usr/src/redhat/SOURCES and
it rejected them all. Is in another folder, and what is it named?
Comment 20 Chris Landrieu 2004-06-23 13:07:35 EDT
I'm not certain, but it sounds like a problem with your patch file. 
How did you download it?

I recommend clicking on the attachment (so that it comes up in the
browser) then do a right-click->"Save Page As...".  If you did a cut
and paste, its possible you 

Also, is it possible that you skipped the "tar -xvjf
ORBit2-2.10.0.tar.bz2" step?

The source tar ball has to be extracted first and you have to be in
the /usr/src/redhat/SOURCES directory.

Either of these problems will give you an error saying "can't find the
file to patch...".

On the other hand, you may want to wait a day or two until anoncvs
syncs up and get ORBit2-2.10.3 which includes the fix.  I'll make
another patch then and post it here complete with instructions (and
changes to the spec file rather my previous untar-patch-retar ugliness).
Comment 21 David McCormick 2004-06-23 21:46:56 EDT
OK I'm not quite sure what I did but the file I downloaded as the
patch was definatly  not the right one. I did it again and it worked
just fine. I had clicked on the link but ended up with a 3.3 kb file
instead of the 510 byte file I should have. 
Comment 22 Thomas Walker 2004-06-27 12:17:48 EDT
Created attachment 101452 [details]
patched x86_64 ORBit2 rpm
Comment 23 Thomas Walker 2004-06-27 12:19:59 EDT
for those who are having a problem with the path (which works
wonderfully)...
fwiw, the ORBit2 SRPM bails unless you uninstall the i386 version of
popt temporarily.  Not a big bug (I've had to do it with a number of
other packages) but worth looking into.
Comment 24 Erich Hoover 2004-07-18 01:41:02 EDT
This bug still exists in FC3T1 and was frustrating me to no end, the
RPM from Thomas Walker appears to fix the problem but it would be nice
to have an official fix in rawhide.
Comment 25 Chris Landrieu 2004-07-20 01:46:44 EDT
Created attachment 102065 [details]
xxx.patch

For those of you who are having trouble building with the patch, I've attached
a patch file here that simplifies the process.	This is basically the recently
released ORBit2-2.10.3, which includes my fix.

1) Download the patch and name it xxx.patch
2) As root, copy xxx.patch to /usr/src/redhat
3) Install the ORBit2-2.10.0-2.src.rpm package from the Fedora installation CDs
or DVD ("rpm -ivh ORBit2-2.10.0-2.src.rpm")
4) Execute the following commands (still as root):
     cd /usr/src/redhat
     patch -p1 <xxx.patch
     cd SPECS
     rpmbuild -bb ORBit2.spec
     rpm -Uvh ../RPMS/x86_64/ORBit2-2.10.3-0.x86_64.rpm

This should work properly regardless of whether or not you have installed the
i386 version of libpopt.

I don't know what the hold-up is in putting this in rawhide or one of the FC3
test releases.	It's been accepted by gnome and gentoo weeks ago.
Comment 26 Chris Landrieu 2004-07-20 01:50:53 EDT
Oh, and, when downloading the patch, right click and select "Save Link
As...".
Comment 27 kg4zmp@ardmore.net 2004-07-22 04:37:04 EDT
Thanks, Chris!  Your solution worked like a charm.
Comment 28 Alexander Larsson 2004-08-26 10:15:49 EDT
There was an ORBit2 update for this.
Comment 29 Alexander Larsson 2004-09-06 08:48:25 EDT
*** Bug 122087 has been marked as a duplicate of this bug. ***
Comment 30 Alexander Larsson 2004-09-06 08:48:52 EDT
*** Bug 121912 has been marked as a duplicate of this bug. ***
Comment 31 Alexander Larsson 2004-09-06 08:48:54 EDT
*** Bug 122662 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.